cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
293
Views
30
Helpful
10
Replies

FMC and Google

Hello, 

 

I have a customer with FMC 6.4.0.1 which manages FTD. 

I have an issue when I click on a page in the FMC, it says "waiting for googletagmanager.com" and the page partially loads. That means some contents of the page are shown, but some others not. For example, the submenus do not show up. 

In general, I have delays with FMC and the "waiting" shows several google URLs, like google API, fonts...

 

What is the relation between the two? Does the FMC have any integration with google?

 

Thanks and regards, 

Konstantinos

3 ACCEPTED SOLUTIONS

Accepted Solutions
Beginner

Re: FMC and Google

Please check your browser having some plugin or check PC having some adware ,

 

Actually when we are accessing FMC its local connectivity between your pc to FMC   so it will not call to google as per my experience .

Highlighted
Hall of Fame Master

Re: FMC and Google

I agree with @harmesh88 - it's most likely a browser plug-in.

You can use something like Firefox's web developer tools (network tool specifically) to inspect your FMC pages and confirm for yourself that no third party pages or cookies etc. are being called or set. 

Here's an example - mine (FMC 6.4.0.4) took 225 ms to load and calls only the server itself:

 

FMC Load.PNG

Re: FMC and Google

While the two marked solutions are not accurate, here's an actual solution:

Log in to the FMC, then go System > Configuration > Web Analytics. Uncheck "Share usage information with Cisco" (enabled by default), hit save.

10 REPLIES 10
Beginner

Re: FMC and Google

Please check your browser having some plugin or check PC having some adware ,

 

Actually when we are accessing FMC its local connectivity between your pc to FMC   so it will not call to google as per my experience .

Highlighted
Hall of Fame Master

Re: FMC and Google

I agree with @harmesh88 - it's most likely a browser plug-in.

You can use something like Firefox's web developer tools (network tool specifically) to inspect your FMC pages and confirm for yourself that no third party pages or cookies etc. are being called or set. 

Here's an example - mine (FMC 6.4.0.4) took 225 ms to load and calls only the server itself:

 

FMC Load.PNG

Re: FMC and Google

Thank you both guys!!

I get the picture now. You are right that it is a local web page!!

 

Regards, 

Konstantinos

Re: FMC and Google

root@firepower:/usr/local/sf/htdocs# grep -ri "googletagmanager" *

html_templates/web-analytics-snippet.tt:<script async src="https://www.googletagmanager.com/gtag/js?id=[% tracking_id %]"></script>

localization/ko/templates/html_templates/web-analytics-snippet.tt:<script async src="https://www.googletagmanager.com/gtag/js?id=[% tracking_id %]"></script>

localization/jp/templates/html_templates/web-analytics-snippet.tt:<script async src="https://www.googletagmanager.com/gtag/js?id=[% tracking_id %]"></script>

localization/tw/templates/html_templates/web-analytics-snippet.tt:<script async src="https://www.googletagmanager.com/gtag/js?id=[% tracking_id %]"></script>

localization/en_US/templates/html_templates/web-analytics-snippet.tt:<script async src="https://www.googletagmanager.com/gtag/js?id=[% tracking_id %]"></script>

localization/zh/templates/html_templates/web-analytics-snippet.tt:<script async src="https://www.googletagmanager.com/gtag/js?id=[% tracking_id %]"></script>

templates/html_templates/web-analytics-snippet.tt:<script async src="https://www.googletagmanager.com/gtag/js?id=[% tracking_id %]"></script>

 

That doesn't seem like "local pages" to me...

Hall of Fame Master

Re: FMC and Google

@Alexandre Hautequest 

Interesting - I see those same files on both a 6.4.0.4 and 6.2.3.14 FMC.

Have you observed any pages that are calling those files?

Re: FMC and Google

I had this very same problem right after I logged into FMC, and thru all top level menu pages I tried to launch.

 

Based off the template files this domain is found, I suspect this is part of “Web analytics", as found on the System > Configuration pane (very last option on the left side). Disabling it might make FMC “air gap aware”, which is what I expect from a security tool: not sharing my internal devices information with no one other than Google (HTTP referral header sends the system host name and/or IP address, if you haven’t got any privacy concerns yet), or doesn’t bite me in the a$$ if my Internet access is cut and I must reconfigure the firewalls, only to not be able to because a stupid JavaScript doesn’t load and I can not navigate thru FMC (business continuity during crisis, hope you never go thru a real life one).

 

All in all, this is a very bad decision from Cisco.

Re: FMC and Google

@Marvin Rhoads - See screen capture attached. This has just happened on my lab environment: Fresh install of macOS, used Safari to download Firefox, launched the Firefox browser, toggled the Network tab tools, launched FMC, logged in, there's our googletagmanager.com being blocked at DNS (RPZ) level. Note the header of the GTM request, with my internal server name as Referrer.

Hall of Fame Master

Re: FMC and Google

Thanks @Alexandre Hautequest - your screenshot and analysis is very informative. I learned something from it.

I confirmed the same observations on my FMC 6.4.0.4. Disabling the "System > Configuration > Web Analytics" option changed the page load such that the GTM request was no longer made.

Re: FMC and Google

After I too faced this issue, I escalated this with my Cisco account manager team. They just replied they are engaging with other internal teams to understand what needs to be cleared (either on the application or at the documentation). I suggest you do the same, if you have concerns as we do (privacy, security, business continuity), so they see those are not isolated requests.

Re: FMC and Google

While the two marked solutions are not accurate, here's an actual solution:

Log in to the FMC, then go System > Configuration > Web Analytics. Uncheck "Share usage information with Cisco" (enabled by default), hit save.