cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to Cisco Firewalls Community


114
Views
0
Helpful
1
Replies
Highlighted
Beginner

ASA 5505 DNS issue

Dear Community,

 

This is the first post I'm writting. I have trying to set up a cisco 5505, but unfortunately I have a problem in the "inside" interface.

In the DHCP server I have set up the DNS servers of google and when a computer is connected to the any of the ethernet ports of the interface, the firewall assigns the IP, masks and the DNS set up in the DHCP server configuration.

 

Now the problem is that when I set up a computer with a manual network configuration I dont want to assign the dns, I need to set up the firewall inside IP address as the DNS server. In this case the 192.168.1.1. In this case, the computer cannot resolve names. I think that I should be possible...

 

Here you have the configuration:

 

interface Ethernet0/0
switchport access vlan 6
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan6
nameif outside
security-level 0
ip address dhcp setroute
!
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
name-server 8.8.8.8
name-server 8.8.4.4
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj_any
subnet 0.0.0.0 0.0.0.0
object network ShareCenter
host 192.168.1.254
description NAS
object network IPCameras
range 192.168.1.249 192.168.1.250
description Camaras IP de Saln y Habitacin
object service WebPage
service tcp source eq www
description WebPage
object service WebSSL
service tcp source eq https
description Web Page SSL
object-group service DM_INLINE_TCP_1 tcp
port-object eq www
port-object eq https
access-list outside_access_in extended permit tcp any object ShareCenter object-
group DM_INLINE_TCP_1
pager lines 24
logging enable
logging asdm debugging
mtu inside 1500
mtu outside 1500
ip verify reverse-path interface outside
icmp unreachable rate-limit 1 burst-size 1
icmp deny any echo-reply outside
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static ShareCenter interface service any WebPage
nat (inside,outside) source static ShareCenter interface service any WebSSL
!
nat (inside,outside) after-auto source dynamic any interface dns
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

dhcpd auto_config outside
!
dhcpd address 192.168.1.10-192.168.1.100 inside
dhcpd auto_config outside interface inside
dhcpd update dns both override interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection scanning-threat
threat-detection statistics
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 averag
e-rate 200
ntp server 132.163.97.1 prefer
ntp server 176.221.42.125 prefer
ntp server 213.251.52.234 prefer
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
id-randomization
id-mismatch action log
tsig enforced action log
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options

 

Maybe that it is related with NAT and ACL, but I did not figure out how to apply it to the port 53...

Thanks in advance

 

Everyone's tags (2)
1 REPLY 1
VIP Advisor

Re: ASA 5505 DNS issue

 

The ASA is not designed to be a DNS server

Workaround we can do so that when you query the inside IP of your ASA on port 53, it will forward the request to one single DNS server on the internet.

 

Here is a example :

object network obj-8.8.8.8
nat (outside,inside) static interface service udp domain domain

BB
*** Rate All Helpful Responses ***