cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to Cisco Firewalls Community


470
Views
0
Helpful
1
Replies
Beginner

ASA 5510 ACL VLAN to Internet Issue...

Hi

 

New to using  Cisco ACL's, I have an ASA 5510 (Cisco Adaptive Security Appliance Software Version 9.1(7)13 )

 

I have nat'd subnets on Ethernet0/1 & Ethernet0/3, security-level 100 and these work correctly.

 

I have a sub interface, Ethernet0/1.1 (vlan 201) when this is SL 100 everything works as expected, however when I drop this to SL 0 and create my ACL's I am running into issues. I have tried various permutations of ACL, I am beginning to wonder if I am missing the obvious now.... My intention is to restrict the VLAN to specific URLs/IP/ports later on, for VOIP only access.

 

Here is my current ACL (as said I have tried various permutations, as the ACL shows)

 

access-list voip line 1 extended permit tcp any any (hitcnt=1761) 0xb531f850
access-list voip line 2 extended permit udp any any (hitcnt=2261) 0x3f6ed024
access-list voip line 3 extended permit tcp 192.168.201.0 255.255.255.0 any eq www (hitcnt=0) 0x7cbe745b
access-list voip line 4 extended permit tcp 192.168.201.0 255.255.255.0 any eq https (hitcnt=0) 0x48fa2e74
access-list voip line 5 extended permit tcp 192.168.201.0 255.255.255.0 any eq domain (hitcnt=0) 0xbcdc5a8c
access-list voip line 6 extended permit ip host 192.168.201.10 any (hitcnt=2) 0x24ce17dc 

 

sh int ip b

Interface IP-Address OK? Method Status Protocol
Ethernet0/0 192.168.8.100 YES CONFIG up up
Ethernet0/1 unassigned YES unset up up
Ethernet0/1.1 192.168.201.1 YES manual up up
Ethernet0/2 unassigned YES unset administratively down down
Ethernet0/3 192.168.200.254 YES CONFIG down down
Management0/0 192.168.100.254 YES CONFIG down down

 

 

Many thanks in advance; Config is below:

 

 

ASA-Home(config-subif)# sh run
: Saved
:
: Serial Number: xxxxxxxxxxx
: Hardware: ASA5510, 1024 MB RAM, CPU Pentium 4 Celeron 1599 MHz
:
ASA Version 9.1(7)13
!
hostname ASA-Home
domain-name local
enable password xxxxxxxxxxx encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
names
!
interface Ethernet0/0
nameif outside
security-level 0
ip address 192.168.8.100 255.255.255.0
!
interface Ethernet0/1
no nameif
no security-level
no ip address
!
interface Ethernet0/1.1
vlan 201
nameif vlanvoip
security-level 100
ip address 192.168.201.1 255.255.255.0
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
nameif inside
security-level 100
ip address 192.168.200.254 255.255.255.0
!
interface Management0/0
nameif management
security-level 0
ip address 192.168.100.254 255.255.255.0
!
ftp mode passive
dns server-group DefaultDNS
domain-name local
object network inside-subnet
subnet 192.168.200.0 255.255.255.0
object network vlanvoip-subnet
subnet 192.168.201.0 255.255.255.0
access-list voip extended permit tcp any any
access-list voip extended permit udp any any
access-list voip extended permit tcp 192.168.201.0 255.255.255.0 any eq www
access-list voip extended permit tcp 192.168.201.0 255.255.255.0 any eq https
access-list voip extended permit tcp 192.168.201.0 255.255.255.0 any eq domain
access-list voip extended permit ip host 192.168.201.10 any
pager lines 24
mtu outside 1500
mtu inside 1500
mtu management 1500
mtu vlanvoip 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network inside-subnet
nat (inside,outside) dynamic interface
object network vlanvoip-subnet
nat (vlanvoip,outside) dynamic interface
access-group voip out interface outside
route outside 0.0.0.0 0.0.0.0 192.168.8.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
dhcpd dns 8.8.8.8 8.8.4.4
!
dhcpd address 192.168.200.40-192.168.200.50 inside
dhcpd enable inside
!
dhcpd address 192.168.201.10-192.168.201.50 vlanvoip
dhcpd dns 8.8.8.8 8.8.4.4 interface vlanvoip
dhcpd enable vlanvoip
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
anyconnect-essentials
cache
disable
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect ip-options
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect xdmcp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:c2b39920961d3a9cc954f4065cf13d4a
: end
ASA-Home(config-subif)

1 REPLY 1
Highlighted
VIP Advisor

Re: ASA 5510 ACL VLAN to Internet Issue...

Hi
What is the communication flow? Source subnet and destination subnet?

What's not working?

Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question