cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to Cisco Firewalls Community


243
Views
5
Helpful
3
Replies
Highlighted
Beginner

ASA 5510 site to site VPN

Hi guys,

I am trying to use ASA 5510 to create a site to site VPN. After follow configuration guide, I don't see it is trying to establish the connection.

Configuration guide:
https://www.cisco.com/c/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/119141-configure-asa-00.html


Below is my configuration:

TEST-FW# sh run
: Saved
:
ASA Version 8.2(5)13
!
hostname TEST-FW
domain-name TEST.sg
enable password 9jNfZuG3TC5tCVH0 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
 description WAN_Interface
 nameif WAN
 security-level 0
 ip address 99.126.183.228 255.255.255.248
!
interface Ethernet0/1
 description LAN_Interface
 nameif LAN
 security-level 100
 ip address 172.31.0.1 255.255.255.0
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif Mgmt
 security-level 0
 ip address 192.168.1.1 255.255.255.0
!
banner motd "USE OF THIS NETWORK IS RESTRICTED TO AUTHORISED USERS ONLY."
ftp mode passive
clock timezone SGP 8
dns server-group DefaultDNS
 domain-name TEST.sg
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service PING
 service-object icmp
 service-object icmp echo
 service-object icmp echo-reply
 service-object icmp traceroute
object-group network DESTINATION_SERVER
 network-object host 172.16.12.32
 network-object host 172.16.12.33
 network-object host 172.16.12.34
 network-object host 172.16.12.35
object-group network DM_INLINE_NETWORK_1
 network-object host 172.16.24.10
 group-object DESTINATION_SERVER
object-group service DM_INLINE_SERVICE_1
 service-object ip
 service-object tcp eq www
 service-object tcp eq https
object-group network DM_INLINE_NETWORK_2
 network-object host 172.16.12.32
 network-object host 172.16.12.33
object-group network DM_INLINE_NETWORK_3
 network-object host 172.16.12.32
 network-object host 172.16.12.33
object-group service DM_INLINE_TCP_1 tcp
 port-object eq 4001
 port-object eq 4002
 port-object eq 4003
 port-object eq 6000
 port-object eq 7000
object-group service DM_INLINE_TCP_2 tcp
 port-object eq 4001
 port-object eq 4002
 port-object eq 4003
 port-object eq 6000
 port-object eq 7000
object-group network DM_INLINE_NETWORK_4
 network-object host 172.16.12.32
 network-object host 172.16.12.33
object-group network DM_INLINE_NETWORK_5
 network-object host 172.16.12.32
 network-object host 172.16.12.33
object-group service DM_INLINE_SERVICE_2
 service-object ip
 group-object PING
object-group service DM_INLINE_SERVICE_3
 service-object ip
 group-object PING
object-group service DM_INLINE_SERVICE_4
 service-object ip
 group-object PING
object-group service DM_INLINE_SERVICE_5
 service-object ip
 group-object PING
object-group service DM_INLINE_SERVICE_6
 service-object ip
 group-object PING
access-list SSH extended permit tcp 192.168.1.0 255.255.255.0 host 192.168.1.1
access-list PING_ACL extended permit object-group PING any any log
access-list LAN_access_in remark Data Ports
access-list LAN_access_in extended permit tcp 172.31.0.0 255.255.255.0 object-group DM_INLINE_NETWORK_2 object-group DM_INLINE_TCP_1
access-list LAN_access_in remark Picturel & WaterSpec Port
access-list LAN_access_in extended permit tcp 172.31.0.0 255.255.255.0 object-group DM_INLINE_NETWORK_4 eq ftp
access-list LAN_access_in remark Testing Purpose
access-list LAN_access_in extended permit object-group DM_INLINE_SERVICE_1 172.31.0.0 255.255.255.0 host 172.16.24.10
access-list LAN_access_in extended permit object-group DM_INLINE_SERVICE_2 172.31.0.0 255.255.255.0 129.126.183.224 255.255.255.248
access-list LAN_access_in extended permit object-group DM_INLINE_SERVICE_4 any any
access-list WAN_access_in remark Data Ports
access-list WAN_access_in extended permit tcp object-group DM_INLINE_NETWORK_3 172.31.0.0 255.255.255.0 object-group DM_INLINE_TCP_2
access-list WAN_access_in remark Picturel & WaterSpec Port
access-list WAN_access_in extended permit tcp object-group DM_INLINE_NETWORK_5 172.31.0.0 255.255.255.0 range 10101 10130
access-list WAN_access_in remark Testing Purpose
access-list WAN_access_in extended permit object-group DM_INLINE_SERVICE_3 host 172.16.24.10 172.31.0.0 255.255.255.0
access-list WAN_access_in extended permit object-group DM_INLINE_SERVICE_5 any any
access-list WAN_access_in_1 extended permit object-group DM_INLINE_SERVICE_6 any any
access-list LAN_nat0_outbound extended permit ip 172.31.0.0 255.255.255.0 object-group DESTINATION_SERVER
access-list WAN_1_cryptomap extended permit ip 172.31.0.0 255.255.255.0 object-group DESTINATION_SERVER
pager lines 24
logging enable
logging timestamp
logging standby
logging buffer-size 65536
logging console critical
logging buffered informational
logging trap informational
logging history informational
logging asdm informational
logging facility 17
mtu WAN 1500
mtu LAN 1500
mtu Mgmt 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
icmp permit any LAN
asdm image disk0:/asdm-645-206.bin
no asdm history enable
arp timeout 14400
nat (LAN) 0 access-list LAN_nat0_outbound
access-group LAN_access_in in interface LAN
access-group SSH in interface Mgmt
route WAN 0.0.0.0 0.0.0.0 99.126.183.225 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
aaa authentication serial console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 Mgmt
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec security-association lifetime seconds 3600
crypto ipsec security-association lifetime kilobytes 4608000
crypto map WAN_map 1 match address WAN_1_cryptomap
crypto map WAN_map 1 set peer 111.222.111.222
crypto map WAN_map 1 set transform-set ESP-AES-128-SHA
crypto map WAN_map 1 set security-association lifetime seconds 43200
crypto map WAN_map 1 set phase1-mode aggressive
crypto map WAN_map interface WAN
crypto isakmp enable WAN
crypto isakmp policy 10
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 43200
telnet timeout 5
ssh timeout 15
ssh version 2
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 216.239.35.4
webvpn
username admin password e1z89R3cZe9Kt6Ib encrypted privilege 15
tunnel-group 111.222.111.222 type ipsec-l2l
tunnel-group 111.222.111.222 ipsec-attributes
 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect ip-options
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny  
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip  
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:d750e5075199aa488b6063c263d9e324
: end

TEST-FW#

There  is no traffic when i check on the ASA.

TEST-FW# sh crypto isakmp stats

Global IKE Statistics
Active Tunnels: 0
Previous Tunnels: 0
In Octets: 0
In Packets: 0
In Drop Packets: 0
In Notifys: 0
In P2 Exchanges: 0
In P2 Exchange Invalids: 0
In P2 Exchange Rejects: 0
In P2 Sa Delete Requests: 0
Out Octets: 0
Out Packets: 0
Out Drop Packets: 0
Out Notifys: 0
Out P2 Exchanges: 0
Out P2 Exchange Invalids: 0
Out P2 Exchange Rejects: 0
Out P2 Sa Delete Requests: 0
Initiator Tunnels: 0
Initiator Fails: 0
Responder Fails: 0
System Capacity Fails: 0
Auth Fails: 0
Decrypt Fails: 0
Hash Valid Fails: 0
No Sa Fails: 0

TEST-FW# sh crypt isakm sa

There are no isakmp sas

TEST-FW#

Posible to advise what I missed out or configure wrongly ?

Thank you.

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Rising star

Re: ASA 5510 site to site VPN

you dont have identity nat rules to exampt the inside and remote traffic in your config

i assume you are uisng code 8.4+ if so this is what you need.

!
object network LAN
 subnet 172.31.0.0 255.255.255.0
!
nat (LAN,WAN) source static LAN LAN dest static DESTINATION_SERVER DESTINATION_SERVER no proxy arp

!

access-list WAN_1_cryptomap extended permit ip object nework LAN object-group DESTINATION_SERVER

 

 

 

Any reason you setup this command

 

crypto map WAN_map 1 set phase1-mode aggressive

 

 

i am sure ASA by default are in main-mode. if you have setup mode aggressive than the remote VPN router also need to be in an aggressive mode.

please do not forget to rate.
3 REPLIES 3
VIP Advocate RJI VIP Advocate
VIP Advocate

Re: ASA 5510 site to site VPN

Hi,
The VPN won't establish until interesting traffic (defined in your crypto ACL) attempts to communicate from the remote network. Are you pinging or sending traffic from a device in the 172.31.0.0/24 network to the destination IP range?

How is the device on the other end configured?
HTH
Rising star

Re: ASA 5510 site to site VPN

you dont have identity nat rules to exampt the inside and remote traffic in your config

i assume you are uisng code 8.4+ if so this is what you need.

!
object network LAN
 subnet 172.31.0.0 255.255.255.0
!
nat (LAN,WAN) source static LAN LAN dest static DESTINATION_SERVER DESTINATION_SERVER no proxy arp

!

access-list WAN_1_cryptomap extended permit ip object nework LAN object-group DESTINATION_SERVER

 

 

 

Any reason you setup this command

 

crypto map WAN_map 1 set phase1-mode aggressive

 

 

i am sure ASA by default are in main-mode. if you have setup mode aggressive than the remote VPN router also need to be in an aggressive mode.

please do not forget to rate.
Beginner

Re: ASA 5510 site to site VPN

Hi All, 

 

Thanks @Sheraz.Salim for the advise. After i include the nat rules, the tunnel able to establish.  Also as mention by @RJI, the tunnel only up when there is traffic pass through. 

 

Regarding the aggressive mode, it was configure for testing purpose only. 

 

Thank you very much.