cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to Cisco Firewalls Community


5604
Views
0
Helpful
36
Replies
Contributor

ASA 8.4 NAT not working

Tim,

I noticed this statement:

object network obj_any

nat (inside,outside) dynamic interface

I would remove that since you already have this one:

nat (inside,outside) source dynamic internal interface

The reason I am suggesting removing that is because of where it lies in the nat order.  Even though it is at the bottom in the ASDM, it is as the top in the config.  That may be causing this issue.

Dan

Highlighted
Beginner

Re: ASA 8.4 NAT not working

Still the same issue in the packet trace, same error as in image:

My config now looks like:

ASA Version 8.4(3)
!
hostname ciscoasa
enable password cE8CBbDsvd encrypted
passwd 2KYOU encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.253 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 95.*.*.218 255.255.255.248
!
ftp mode passive
object network obj_any
subnet 0.0.0.0 0.0.0.0
object network server1_smtp
host 192.168.1.10
object network server1_pop3
host 192.168.1.10
object network internal
subnet 192.168.1.0 255.255.255.0
access-list outside_access_in extended permit tcp any host 192.168.1.10 eq smtp
access-list outside_access_in extended permit tcp any host 192.168.1.10 eq pop3
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (inside,outside) source dynamic internal interface
!
object network server1_smtp
nat (inside,outside) static interface service tcp smtp smtp
object network server1_pop3
nat (inside,outside) static interface service tcp pop3 pop3
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 95.*.*.217 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
client-update enable
telnet timeout 5
ssh timeout 5
console timeout 0

dhcpd auto_config outside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:5cee770b5ae708fc7de15292aabeea9a

Contributor

Re: ASA 8.4 NAT not working

Alright, this is going to drive me nuts until I figure this one out.  I have an ASA5505 at home that has the same code and only one IP address as well.  Let me do some testing and I will let you know what if I figure out.

Contributor

Re: ASA 8.4 NAT not working

Ok, so I tried some things out on my home ASA.  For a test, I made the public IP address on my static nat 1.1.1.1.  I ran a packet trace and it worked fine.  I switched back to the interface and it fails like the packet trace you have posted above.  What is odd is that I know I used pat/nat to the interface in my ASA 5505.  I am starting to wonder if this is a bug in the newer code.  I can't remember if I was running pre-8.3 code when I did this before or not. 

You may want to open a case with TAC and see what they have to say.  In the meanwhile, I am going to try to figure this out since it will effect companies that don't want to spend the money for more than 1 public IP address.  If there is a way to get more public IPs from your provider, it will fix your problem.

Beginner

Re: ASA 8.4 NAT not working

I have more then one public IP! Should I downgrade the IOS you think?

Contributor

Re: ASA 8.4 NAT not working

If you can use that other public IP for the nat to the server, I would just do that instead.  However, if you need that public IP address for something else, then downgrading would be an option.

Contributor

ASA 8.4 NAT not working

Any updates on this Tim?

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here