cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to Cisco Firewalls Community


156
Views
0
Helpful
0
Replies
Highlighted
Beginner

ASA5512 Routing issues between VLAN and subnets

Hi there,

 

I have an issue with an ASA-5512X, which i cannot figure out.

 

Situation is as follow:

VLAN 15 network (192.168.15.x), with an Cisco ASA 5512X (192.168.15.254), used for an high speed internet connection.

An local IP Router (192.168.15.100) connecting to 3 branche offices (containing VLAN10, VLAN12 and VLAN14). This Router is working perfectly. I can ping and connect to the branche offices form a PC in VLAN15 without any problems if i use the gateway 192.168.15.100.

 

I have made some static routes in the ASA 5512, so that i can change the default gateway on the PC's to the ASA 5512.

But when i change the gateway on the PC's, i can ping the branche offices on the IP-Adress, but not connect to the resources (SMB/RDP etc). I Don't have an layer 3 switch at this location.

 

i Think it has something to do with NAT and/or Access Lists.

Please advise

 

ASA Configuration:

: Saved

:
: Serial Number: FCH210676AC
: Hardware: ASA5512, 4096 MB RAM, CPU Clarkdale 2792 MHz, 1 CPU (2 cores)
: Written by admin at 03:34:54.669 UTC Tue Sep 3 2019
!
ASA Version 9.9(2)
!
hostname ASA5512FP
domain-name company.local
enable password ER.FV96laXIOFD7/ encrypted
names

!
interface GigabitEthernet0/0
description WAN Interface
nameif outside
security-level 0
ip address 1.1.178 255.255.255.252
!
interface GigabitEthernet0/1
description LAN Interface
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/1.1
description VLAN15 Interface
vlan 15
nameif VLAN15
security-level 100
ip address 192.168.15.254 255.255.255.0
!
interface GigabitEthernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/4
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/5
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
management-only
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
!
boot system disk0:/asa992-smp-k8.bin
ftp mode passive
dns domain-lookup outside
dns domain-lookup VLAN15
dns server-group DefaultDNS
name-server 192.168.15.15
name-server 192.168.12.43
name-server 192.168.12.35
name-server 8.8.8.8
name-server 8.8.4.4
domain-name company.local
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj_any
subnet 0.0.0.0 0.0.0.0
object network Hyper-W2K19-LAN
host 192.168.15.99
object network VLAN15_Subnet
subnet 192.168.15.0 255.255.255.0
object network VLAN15_WAN
host 2.2.2.219
object network VLAN10_Subnet
subnet 192.168.10.0 255.255.255.0
object network VLAN12_Subnet
subnet 192.168.12.0 255.255.255.0
object network VLAN14_Subnet
subnet 192.168.14.0 255.255.255.0
access-list outside_inside extended permit icmp any any echo
access-list outside_inside extended permit udp any any range 33434 33523
access-list outside_inside extended permit icmp any any time-exceeded
access-list outside_inside extended permit icmp any any source-quench
access-list outside_inside extended permit icmp any any echo-reply
access-list outside_inside extended permit icmp any any unreachable
access-list ICMPACL extended permit icmp any any
access-list outbound extended permit tcp host 192.168.15.99 any eq smtp
access-list outbound extended deny tcp any any eq smtp
access-list outbound extended permit ip any any
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu VLAN15 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-7122.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
arp rate-limit 8192
!
object network obj_any
nat (any,outside) dynamic interface
object network VLAN15_Subnet
nat (VLAN15,outside) static VLAN15_WAN
access-group outside_inside in interface outside
route outside 0.0.0.0 0.0.0.0 1.1.177 10
route VLAN15 192.168.10.0 255.255.255.0 192.168.15.100 1
route VLAN15 192.168.12.0 255.255.255.0 192.168.15.100 1
route VLAN15 192.168.14.0 255.255.255.0 192.168.15.100 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 sctp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
timeout conn-holddown 0:00:15
timeout igp stale-route 0:01:10
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
aaa authentication http console LOCAL
aaa authentication enable console LOCAL
aaa authentication serial console LOCAL
aaa authorization command LOCAL
aaa authorization exec LOCAL
aaa authorization http console LOCAL
aaa authentication login-history
http server enable
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
no ssh stricthostkeycheck
ssh 192.168.15.0 255.255.255.0 VLAN15
ssh 192.168.12.0 255.255.255.0 VLAN15
ssh timeout 30
ssh version 1 2
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
dynamic-access-policy-record DfltAccessPolicy
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect netbios
inspect tftp
inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous

 

 

Everyone's tags (3)