cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to Cisco Firewalls Community


219
Views
0
Helpful
3
Replies
Highlighted

ASAv, Azure and ASDM - Initial Web Page not loading

During the initial set up of the ASAv in Azure, I created the virtual machine, all the IP Addresses, etc.  After setting up (what I thought was the correct way to do so), I cannot get the initial ASDM web page to load.  It's an odd thing.  Let me explain:

1) set up the ASDM

 

asdm image boot:/asdm-710161.bin (verified this is the location of the file)
no asdm history enable
http server enable
http 192.168.0.0 255.255.0.0 management

 

2) Management IP 172.18.1.4

3) I can PING the Mamangement0/0

4) I can SSH to Management0/0

5) I get the following results when accessing the page at https://172.168.1.4/admin/public/index.html

HTTP: processing GET URL '/admin/' from host 192.168.xxx.xxx
HTTP: redirecting to: /admin/public/index.html
HTTP: admin session verified =  [0]
HTTP: processing GET URL '/admin/public/index.html' from host 192.168.xxx.xxx
HTTP: authentication not required
HTTP: sending file: public/index.html, length: 7239, response header options 0000001f

The webpage results in the following image.website_failure_to_load.png

What am I missing?

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: ASAv, Azure and ASDM - Initial Web Page not loading

The image at the Azure virtual device had the asdm bin file located on the boot: disk. 

 

I've made the change and pointed the correct file location.  While I'd done this before, I had to rebuild the entire VM in Azure to make it work the second time around.  The failure wasn't the asdm image command, but rather where it was located.  I copied the image to the disk0:, tested and it worked perfectly.

I rebuilt the VM again, then tried with the .bin file located on boot: and it worked flawlessly.  I'm not sure where the break was, but it's working, now.

3 REPLIES 3
VIP Advocate RJI VIP Advocate
VIP Advocate

Re: ASAv, Azure and ASDM - Initial Web Page not loading

Hi,
You are connecting to the webpage using the IP address 172.18.1.4 the error is indicating that the hostname specified within the certificate is not 172.18.1.4, therefore this error would be expected. You can still click "Go on to the webpage....." to access it.

If you do not wish to see that error again, you will have to check the certificate and connect using the hostname specified, you would potentiallly need a DNS entry defined.

HTH

Re: ASAv, Azure and ASDM - Initial Web Page not loading

While I agree that the error is about the certificate:

asav error 2.PNG

the resulting page (original message) is AFTER the "Continue to Webpage (not recommended)" option.  This is where the site hangs.  It does not continue forward, even though the debug http shows that the file transfer begins:

 

HTTP: sending file: public/index.html, length: 7239, response header options 0000001f

 The webpage load cycle shows this:

asav error 4.PNG

Re: ASAv, Azure and ASDM - Initial Web Page not loading

The image at the Azure virtual device had the asdm bin file located on the boot: disk. 

 

I've made the change and pointed the correct file location.  While I'd done this before, I had to rebuild the entire VM in Azure to make it work the second time around.  The failure wasn't the asdm image command, but rather where it was located.  I copied the image to the disk0:, tested and it worked perfectly.

I rebuilt the VM again, then tried with the .bin file located on boot: and it worked flawlessly.  I'm not sure where the break was, but it's working, now.