cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to Cisco Firewalls Community


4890
Views
0
Helpful
4
Replies
Beginner

ASAv OVF Parse Error

Hello

I deployed ASAv 9.3.1 on ESXi 5.5 using vCenter.

 

After powering the vm on, ASAv reboots uninterruptedly and shows this Error:

Error: Platform type has not been configured.

ERROR: OVF environment unavailable, errno: 2.

OVF XML parsing for device configuration - Fail ... cannot read OVF, Check the hardware configuration of this VM and make sure there is a CD ROM drive assigned to this VM. Verify thatCDROM drive is enabled to connect after VM power on.

What can I do now?

Everyone's tags (1)
4 REPLIES 4
Participant

Can someone chime in here

Can someone chime in here please. I'm having the same problem as mentioned above. 

Highlighted
Beginner

I ran into this issue only

I ran into this issue only when I did not set my networks during the setup then tried to boot.  If I edit the virtual machine settings and set my networks I then boot cleanly. 

We found an issue with the

We found an issue with the vASA software and apparently this is a common problem and it has been escalated to the Cisco development team as of the time I wrote this post.

For anyone Googling this, this was the only mention of this problem on these forums.

The Cisco vASA appliance expects to see two .iso files on two different CD-ROM devices.

The first ISO contains the OVF environment information for the virtual machine.

It is stored with in the same datastore folder as the virtual machine and has the filename of "_ovfenv-(VM Name).iso"

The second ISO contains the device image and is called "_deviceImage-0.iso". It also is stored with the virtual machine in the same folder on the datastore.

When the VM is Storage vMotioned from one datastore to another, the .ISO files do not get migrated along with the virtual machine. As a result, this error occurs because the VM can't find that _ovfenv file.

The solution to this problem is to do the following:

1. Backup the running configuration of the vASA somewhere, like to a TFTP server.

2. Deregister the smart license of the vASA.

3. Deploy a new vASA into the environment where it will finally be.

4. Register the smart license of the vASA

5. Restore the configuration from the old vASA.

Going forward, the way how to prevent this issue from happening is to copy the iso files to your local machine first before you storage vMotion the VM, copy them back when it is in its final datastore and then point the first and second CD-ROM devices at the appropriate files.

Beginner

Old post I know but I've just

Old post I know but I've just found this post when experiencing the same issues deploying ASAv 9.7 on my vCenter 6.5. I've checked the ASA compatibility guide and at present ASAv only shows support up to vSphere 6.0

http://www.cisco.com/c/en/us/td/docs/security/asa/compatibility/asamatrx.html#pgfId-132226

I do have a version of 9.7 running on ESXi 6.0 without issues.

Cheers,

Rob