cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to Cisco Firewalls Community


253
Views
15
Helpful
6
Replies
Beginner

Cisco ASA 5508 K8 no ASDM available

Hello,

 

I am very new to Cisco ASA Firewalls. I have to configure a new ASA5508-X (K8) to be used as a VPN Server.

Now I have the problem that I cannot access the ASDM Software for configuration. When I try to access the Webpage (192.168.1.1) I only get a time out.

I connected the PC for configuration on the second LAN Port and the Router on the first one, as per description by Cisco.

 

I would be very grateful if someone could help me with this matter.

 

ciscoasa# show run
: Saved

:
: Serial Number: JAD233804DW
: Hardware: ASA5508, 8192 MB RAM, CPU Atom C2000 series 2000 MHz, 1 CPU (8 cores)
:
ASA Version 9.8(2)
!
hostname ciscoasa
enable password $sha512$5000$dSl+dZpmsUEjbeIguWrPXA==$otNt0xhFZjM7hK2duUUEuQ== pbkdf2
names

!
interface GigabitEthernet1/1
nameif outside
security-level 0
ip address dhcp setroute
!
interface GigabitEthernet1/2
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet1/3
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/4
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/5
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/6
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/7
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/8
shutdown
no nameif
no security-level
no ip address
!
interface Management1/1
management-only
no nameif
no security-level
no ip address
!
ftp mode passive
object network obj_any
subnet 0.0.0.0 0.0.0.0
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
no failover
no monitor-interface service-module
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
arp rate-limit 16384
!
object network obj_any
nat (any,outside) dynamic interface
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 sctp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
timeout conn-holddown 0:00:15
timeout igp stale-route 0:01:10
user-identity default-domain LOCAL
aaa authentication login-history
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
service sw-reset-button
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

dhcpd auto_config outside
!
dhcpd address 192.168.1.5-192.168.1.254 inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
dynamic-access-policy-record DfltAccessPolicy
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:4920d14afae9ad80398a0d22f14dc263
: end

2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Advisor

Re: Cisco ASA 5508 K8 no ASDM available

Hi there,

Can you confirm you actually have an ASDM image available on the firewall. What is the output of sh flash

 

Also, your config is missing the line specifying the ASDM image to load. It will be of the format:

!
asdm image disk0:/<asdm_image.bin>
!

 

cheers,

Seb.

View solution in original post

Hall of Fame Guru

Re: Cisco ASA 5508 K8 no ASDM available

Can you confirm that you used the following pages and that the serial number you used was from "show version" (not "show inventory")?

ASA 3DES-AES License page.PNG

 

ASA 3DES-AES License page 2.PNG

View solution in original post

6 REPLIES 6
VIP Advisor

Re: Cisco ASA 5508 K8 no ASDM available

Hi there,

Can you confirm you actually have an ASDM image available on the firewall. What is the output of sh flash

 

Also, your config is missing the line specifying the ASDM image to load. It will be of the format:

!
asdm image disk0:/<asdm_image.bin>
!

 

cheers,

Seb.

View solution in original post

Beginner

Re: Cisco ASA 5508 K8 no ASDM available

Thank you so much for the reply.

 

The ASDM image is present:

 

ciscoasa# sh flash
--#-- --length-- -----date/time------ path
92 108563072 Oct 02 2019 15:10:38 asa982-lfbff-k8.SPA
93 26970456 Oct 02 2019 15:11:00 asdm-782.bin
94 33 Dec 09 2019 11:18:16 .boot_string
11 4096 Oct 02 2019 15:14:18 log
13 1375 Dec 09 2019 11:20:50 log/asa-appagent.log
21 4096 Oct 02 2019 15:15:10 crypto_archive
22 4096 Oct 02 2019 15:15:12 coredumpinfo
23 59 Oct 02 2019 15:15:12 coredumpinfo/coredump.cfg

7863623680 bytes total (4504776704 bytes free)

 

I added the suggested line and now I get a different Error "SSL_ERROR_NO_CYPHER_OVERLAP".

I think that means that I am missing the strong encryption license. I will try to get this on the device and hopefully be able to access ASDM.

 

So thank you again for helping me with this issue!

 

Cheers,

Johannes

 

 

Hall of Fame Guru

Re: Cisco ASA 5508 K8 no ASDM available

Yes - the "k8" image does not include the strong encryption license by default. "k9" would have it.

You can obtain the free license (assuming you aren't in a prohibited country like North Korea) from software.cisco.com. Once you install it ASDM should work for you.

Beginner

Re: Cisco ASA 5508 K8 no ASDM available

Thank you for the reply.

 

I got myself the free license but if I want to activate it I get the following Error Code:

ERROR: The requested activation key was not saved because it is not
valid for this system.

I am based in Germany, so it should not be prohibited. I have downloaded the ASA5500-ENCR-K9 license and the device is connected to the Internet.

 

Or do I need the ASACX5500-ENCR-K9 license?

Has someone an idea on what is going on with my device?

 

Kind regards,

Johannes

 

Hall of Fame Guru

Re: Cisco ASA 5508 K8 no ASDM available

Can you confirm that you used the following pages and that the serial number you used was from "show version" (not "show inventory")?

ASA 3DES-AES License page.PNG

 

ASA 3DES-AES License page 2.PNG

View solution in original post

Beginner

Re: Cisco ASA 5508 K8 no ASDM available

Oh no, I am sorry.

 

I did not read the instructions and used the serial number on the box.

 

I did it right this time and now it works.

 

Thank you so much for your help, I really appreciate it!

 

Cheers,

 

Johannes

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here