cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to Cisco Firewalls Community


159
Views
0
Helpful
2
Replies
Highlighted
Beginner

Cisco ASA 5510 upgarde path

Dear All,

 

I have been using Cisco ASA 5510 for last 7-8 years now the requirement is to upgrade to IOS so that the current firewall supports advance encryption schemes. Currently i am running Cisco Adaptive Security Appliance Software Version 8.2(5)55 . What should be the upgrade path so that i can make maximum use of the current hardware ?

 

Hardware: ASA5510, 256 MB RAM, CPU Pentium 4 Celeron 1599 MHz
Internal ATA Compact Flash, 256MB

 

Encryption hardware device : Cisco ASA-55x0 on-board accelerator (revision 0x0)
Boot microcode : CN1000-MC-BOOT-2.00
SSL/IKE microcode: CNLite-MC-SSLm-PLUS-2.03
IPSec microcode : CNlite-MC-IPSECm-MAIN-2.05

1 ACCEPTED SOLUTION

Accepted Solutions
Rising star

Re: Cisco ASA 5510 upgarde path

Hello Taha,

 

Looks like you only have 256 MB RAM, the minimum requirement for 8.3 onwards is minimum 1 GB RAM:

 

https://www.cisco.com/c/en/us/products/collateral/security/asa-5500-series-next-generation-firewalls/product_bulletin_c25-586414.html

 

https://community.cisco.com/t5/security-documents/asa-8-3-upgrade-what-you-need-to-know/ta-p/3127078

 

Please fix this before upgrade to make a smooth transition.

 

HTH
AJ

2 REPLIES 2
Participant

Re: Cisco ASA 5510 upgarde path

Based on the release notes for the most recent version of 5510 software here is the upgrade path.

 

Current ASA Version
First Upgrade to:
Then Upgrade to:

8.2(x) and earlier

8.4(5)

9.1(3) or later

 

You would need to go from your current version to 8.4(5) and then up to the latest which at this time is 9.1(7)

 

However, before you upgrade please check the release notes for both version 8.4(5) and 9.1(7) to make sure it won;t cause any issues with your configuration. 

 

Here are links to the release notes.

https://www.cisco.com/c/en/us/td/docs/security/asa/asa84/release/notes/asarn84.html

https://www.cisco.com/c/en/us/td/docs/security/asa/asa91/release/notes/asarn91.html#pgfId-324358

Rising star

Re: Cisco ASA 5510 upgarde path

Hello Taha,

 

Looks like you only have 256 MB RAM, the minimum requirement for 8.3 onwards is minimum 1 GB RAM:

 

https://www.cisco.com/c/en/us/products/collateral/security/asa-5500-series-next-generation-firewalls/product_bulletin_c25-586414.html

 

https://community.cisco.com/t5/security-documents/asa-8-3-upgrade-what-you-need-to-know/ta-p/3127078

 

Please fix this before upgrade to make a smooth transition.

 

HTH
AJ