cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to Cisco Firewalls Community


547
Views
0
Helpful
1
Replies
Highlighted
Beginner

Ping and reply from inside to dmz and vice versa

I'm just starting off on ASA's and i'm out of ideas here with this problem. I simply want to be able to ping from inside to dmz and vice versa. At this time i don't have any servers in the dmz except for the dmz interface which is 172.16.100.254, my inside network is 192.168.50.x.

I think i may have my static nat incorrect. if anyone could shed some light on this i would greatly appreciate it. I've also read numerous other discussions online but each one differs from the other.

Thanks all,

Cesar

--------------------------------------------------------------------------------------------------------------------------------------------------------------

ASA Version 8.2(5)

!

hostname clabsasa

domain-name clabs.com

enable password fSi.GJ38BR0IplZP encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

name 192.168.50.253 inside description inside

!

interface Ethernet0/0

nameif outside

security-level 0

ip address dhcp setroute

!

interface Ethernet0/1

nameif inside

security-level 100

ip address 192.168.50.254 255.255.255.0

!

interface Ethernet0/2

description DMZ

nameif DMZ

security-level 50

ip address 172.16.100.254 255.255.255.0

!

interface Ethernet0/3

shutdown

no nameif

no security-level

no ip address

!

interface Management0/0

shutdown

no nameif

no security-level

no ip address

management-only

!

boot system disk0:/asa825-k8.bin

ftp mode passive

clock timezone CST -6

clock summer-time CDT recurring

dns server-group DefaultDNS

domain-name clabs.com

same-security-traffic permit inter-interface

same-security-traffic permit intra-interface

access-list 101 extended permit ip any any

pager lines 24

logging enable

logging asdm warnings

mtu outside 1500

mtu inside 1500

mtu DMZ 1500

no failover

icmp unreachable rate-limit 1 burst-size 1

icmp deny any outside

icmp permit any echo inside

icmp permit any echo-reply inside

icmp permit any time-exceeded inside

icmp permit any inside

icmp permit any echo DMZ

icmp permit any echo-reply DMZ

icmp permit any DMZ

icmp permit any time-exceeded DMZ

asdm image disk0:/asdm-649-103.bin

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0

static (inside,DMZ) 192.168.50.0 192.168.50.0 netmask 255.255.255.0

access-group 101 in interface DMZ

!            

router eigrp 100

network 172.16.0.0 255.255.0.0

!

route outside 0.0.0.0 255.255.255.255 192.168.50.254 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

aaa authentication enable console LOCAL

aaa authentication http console LOCAL

aaa authentication serial console LOCAL

aaa authentication ssh console LOCAL

http server enable

http 192.168.50.0 255.255.255.0 inside

http 0.0.0.0 0.0.0.0 outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

telnet timeout 5

ssh 192.168.50.0 255.255.255.0 inside

ssh timeout 5

console timeout 0

dhcpd dns 8.8.4.4

!

dhcpd address 192.168.50.100-192.168.50.199 inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics host

threat-detection statistics port

threat-detection statistics protocol

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

ntp authenticate

ntp server 38.106.177.10 prefer

webvpn

username admin1 password 9tVcm8CVRD8uUKqw encrypted privilege 15

username cesarc password K0uqAPPfLclLg3xy encrypted privilege 15

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect ip-options

  inspect netbios

  inspect rsh

  inspect rtsp

  inspect skinny 

  inspect esmtp

  inspect sqlnet

  inspect sunrpc

  inspect tftp

  inspect sip 

  inspect xdmcp

  inspect icmp

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

call-home

profile CiscoTAC-1

  no active

  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService

  destination address email callhome@cisco.com

  destination transport-method http

  subscribe-to-alert-group diagnostic

  subscribe-to-alert-group environment

  subscribe-to-alert-group inventory periodic monthly

  subscribe-to-alert-group configuration periodic monthly

  subscribe-to-alert-group telemetry periodic daily

Everyone's tags (2)
1 REPLY 1

Ping and reply from inside to dmz and vice versa

Hello Cesar,

Looks good the configuration

You said you do not have any host on the DMZ

If you are trying to ping the DMZ interface from an inside host that will not work as you cannot ping a far end interface.

Place a host on the DMZ interface and run a test.

Any other question...Sure..Just rate all of my answers.

Regards,

Julio

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC