cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to Cisco Firewalls Community


546
Views
0
Helpful
2
Replies
Frequent Contributor

Unable to access Internet from LAN - Cisco ASA 9.1(2)

Hi,

  I have Cisco 5515 IOS 9.1(2). I had configured out-to-in rule with 'ssh' and able to access the Internet server, but the same server is unable to access the Internet. Not sure what i am missing here. Please look in to the configuration below and suggest.

10.4.20.2 is the host i am trying to access the Internet and it fails, but able to 'ssh' to this IP from the internet.

 

ASA Version 9.1(2)

interface GigabitEthernet0/0
 description OUTSIDE
 nameif outside
 security-level 0
 ip address 1.1.1.1 255.255.255.248
!
interface GigabitEthernet0/1
 description BACKUP
 nameif backup
 security-level 0
 ip address 2.2.2.2 255.255.255.248
!
interface GigabitEthernet0/4
 description INSIDE
 nameif inside
 security-level 100
 ip address 10.4.20.1 255.255.255.0
!
boot system disk0:/asa912-smp-k8.bin
ftp mode passive
clock timezone PT -8
clock summer-time PT recurring
dns domain-lookup outside
object network 2.2.2.4_10.4.20.2
 host 10.4.20.2
access-list out2in extended permit icmp any any inactive
access-list in2out extended permit ip 10.4.20.0 255.255.255.0 any
access-list out2in_bkp extended permit icmp any any inactive
access-list out2in_bkp extended permit tcp any object 2.2.2.4_10.4.20.2 eq ssh
pager lines 24
logging enable
logging timestamp
logging standby
logging monitor debugging
logging trap debugging
logging history debugging
logging asdm debugging
mtu outside 1500
mtu backup 1500
mtu inside 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-713.bin
asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network 2.2.2.4_10.4.20.2
 nat (inside,backup) static 2.2.2.4 net-to-net dns
access-group out2in in interface outside
access-group out2in_bkp in interface backup
access-group in2out in interface inside
route outside 0.0.0.0 0.0.0.0 1.1.1.2 10 track 100
route backup 0.0.0.0 0.0.0.0 2.2.2.3 20 track 101
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
aaa authentication http console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
http 0.0.0.0 0.0.0.0 outside
http 0.0.0.0 0.0.0.0 backup
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
sla monitor 100
 type echo protocol ipIcmpEcho 8.8.8.8 interface outside
sla monitor schedule 100 life forever start-time now
sla monitor 101
 type echo protocol ipIcmpEcho 8.8.4.4 interface backup
sla monitor schedule 101 life forever start-time now
service resetoutside
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
!
track 100 rtr 100 reachability
!
track 101 rtr 101 reachability
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 backup
ssh timeout 60
ssh version 2
ssh key-exchange group dh-group1-sha1
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 123.108.225.6 source outside
ssl encryption rc4-sha1 aes128-sha1 aes256-sha1 3des-sha1
username xyz password ***** encrypted privilege 15
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:9b63e3cfc9f98800d2bb3efa34c75906
: end

 

1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Hi Anand

Hi Anand Could you please do a packet tracer on the Asa? Packet-tracer input inside icmp 10.20.4.2 8 0 4.2.2.2 detailed Are you able to ping 4.2.2.2 from the server ? Please use the following command "fixup protocol icmp" And then check whether you are able to ping the Internet. Regards Aditya
2 REPLIES 2
Beginner

Hi Anand

Hi Anand Could you please do a packet tracer on the Asa? Packet-tracer input inside icmp 10.20.4.2 8 0 4.2.2.2 detailed Are you able to ping 4.2.2.2 from the server ? Please use the following command "fixup protocol icmp" And then check whether you are able to ping the Internet. Regards Aditya
Frequent Contributor

Thanks a lot, adding '

Thanks a lot, adding ' inspect icmp' made the magic.