cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
 
ISE 2.3 Patch 7 has been posted. This will be the last patch for the ISE 2.3 release!
Choose one of the topics below to view our ISE Resources to help you on your journey with ISE

This community is for technical, feature, configuration and deployment questions.
For production deployment issues, please contact the TAC! We will not comment or assist with your TAC case in these forums.
Please see How to Ask the Community for Help for other best practices.

2190
Views
6
Helpful
14
Replies
Highlighted

Error while installing patch 5 on ISE 2.2

Hello guys,

I had an issue when I tried to apply patch 5 on our ISE cluster in version 2.2:

This error message appears after I uploaded patch via GUI. I checked in log file, but I didn’t see anything helpful…

7 [10899]:[debug] config:network: sysconfig.c[463] [admin]: Getting Domainname...

7 [10899]:[debug] config:network: sysconfig.c[485] [admin]: Getting Gateway...

7 [10899]:[debug] config:network: sysconfig.c[530] [admin]: Getting Nameserver...

7 [10899]:[debug] config:network: sysconfig.c[530] [admin]: Getting Nameserver...

7 [10899]:[debug] config:network: sysconfig.c[530] [admin]: Getting Nameserver...

7 [10899]:[debug] user: sysconfig.c[4655] [admin]: route print return value: 0

7 [10899]:[debug] config:network: sysconfig.c[4661] [admin]: ip route  output:


Does somebody already have the same issue? If so, did you find a workaround?


Thanks in advance for your help!

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Error while installing patch 5 on ISE 2.2

Its best to troubleshoot the issue with TAC. please raise a TAC case for this. 

14 REPLIES 14
Cisco Employee

Re: Error while installing patch 5 on ISE 2.2

Its best to troubleshoot the issue with TAC. please raise a TAC case for this. 

Re: Error while installing patch 5 on ISE 2.2

Hello Nidhi,

I already asked to open a case. Meanwhile I hoped to have an answer here from somebody who could have the same issue.

Do you know if it's a known issue?

Cisco Employee

Re: Error while installing patch 5 on ISE 2.2

Potentially, "/localdisk" on one of ISE nodes in the deployment is running out of space. Please SSH to and log onto the ISE admin CLI of each of ISE nodes and issue "dir" to verify the available space of this /localdisk file system.

Re: Error while installing patch 5 on ISE 2.2

Hello,

I checked, and there is enough space on my nodes.

Adm 1 :

Usage for disk: filesystem

     10764681216 bytes total used

     3779428352 bytes free

     15347318784 bytes available

Adm 2:

Usage for disk: filesystem

     512114688 bytes total used

     14031994880 bytes free

     15347318784 bytes available

Mnt :

Usage for disk: filesystem

     512114688 bytes total used

     14031994880 bytes free

     15347318784 bytes available

PSN 1 :

Usage for disk: filesystem

     9643720704 bytes total used

     4900388864 bytes free

     15347318784 bytes available

PSN 2:

Usage for disk: filesystem

     10764681216 bytes total used

     3779428352 bytes free

     15347318784 bytes available

But what is strange is that I failed over the cluster few times. Finally the patch was successfully installed but only on two nodes (adm from which I launched patch installation, and the primary monitoring node).

Cisco Employee

Re: Error while installing patch 5 on ISE 2.2

If not already done, please provide the support bundles from all ISE nodes to TAC for investigation. If you do not want to wait, I would suggest to apply the patch via ISE CLI on those "not installed" ones.

Re: Error while installing patch 5 on ISE 2.2

Actually before I was able to install patch from GUI on two nodes, I tried to install it on my primary admin via CLI. After patch installation, ISE processus was stuck on "initializing", and I had to reimage the node (I tried cold reboot without success). I'm afraid this issue happens again and I really don't want to reimage my full cluster.

Cisco Employee

Re: Error while installing patch 5 on ISE 2.2

It's important to find out why ISE stuck in "initializing" by engaging TAC, unless you are able to share the support bundle in this public forum. Patching via CLI should work as good as via Web UI, if not better, unless some specific bug preventing it to work.

Re: Error while installing patch 5 on ISE 2.2

Honestly I didn't check the logs, but I guess it's because a process locked the database, so ISE application wasn't able to access the DB (I already had this issue).

The problem is that for now I just tried to patch our mockup environment (5 nodes), but our production one has 19 nodes, and I really didn't want to patch them all in CLI...

Contributor

Re: Error while installing patch 5 on ISE 2.2

Are you installing on primary administration node?

Re: Error while installing patch 5 on ISE 2.2

Yes I am. I have a distributed infrastructure, so after promoting the secondary adm node as a primary, I tried again to install the patch. I had exactly the same message.

Advocate

Re: Error while installing patch 5 on ISE 2.2

Check the md5 checksum/crypto hash of posted patch file to the one you have to make sure not corrupted in transfer. 

Re: Error while installing patch 5 on ISE 2.2

The md5 sum is ok. I had the same issue with another laptop, and another patch.

Beginner

Re: Error while installing patch 5 on ISE 2.2

Hi jgrastilleur

 

Did you find any solution for this issue?  I'm having a similar issue when applying patch 9 for ISE 2.4 version.  It is only installed in the PAN but not replicated to the PSNs. 

 

Re: Error while installing patch 5 on ISE 2.2

Hello,

 

I finally patched my whole cluster using CLI, and it worked