cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
445
Views
0
Helpful
1
Replies
Beginner

Using a Cisco 809 as a Serial Server over Cellular Link. Modbus Protocol to Modicon Device

I am attempting to use a Cisco 809 as a serial server over cellular link.  I am trying to use the ASYNC 0 port without interfacing with the Virtual Machine, but rather directly to the hardware.  The serial devices I have at my disposal are Modicon Momentums and M340s with rj45 Modbus ports. Thus far I have been unsuccessful in this.  However, I have successfully polled a device over DNP3 to a SCADA-PACK RTU with a straight thru rj45 to rj45.  However, the Momentum and the base M340 are restricted to MODBUS.

Has anyone been able to make this work?

 

Thanks in advance for any help!!

 

Steve K.

Austin TX

below is the config:

SerialTEST01#sho run

Building configuration...

 

Current configuration : 3540 bytes

!

version 15.6

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname SerialTEST01

!

boot-start-marker

boot system flash:/ir800-universalk9-mz.SPA.156-3.M2

boot system flash ir800-universalk9-mz.SPA.156-3.M2

boot-end-marker

!

!

!

no aaa new-model

!

!

!

!

!

!        

!

!

!

!

!

 

 

!

!

!

!

no ip domain lookup

ip cef

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"

!

!

license udi pid IR809G-LTE-NA-K9 sn FCW211900FB

!

!

username xxxx

!

redundancy

!

!

!

crypto ikev2 keyring SCADA-ring

peer xxx

address xxx

pre-shared-key local xxx

pre-shared-key remote xxx

!

!

!

crypto ikev2 profile SCADA-v2-Profile

match identity remote address xxx 255.255.255.255

identity local address xxx

authentication local pre-share

authentication remote pre-share

keyring local SCADA-ring

!        

!

!

controller Cellular 0

lte sim max-retry 0

no lte gps enable

lte modem link-recovery rssi onset-threshold -110

lte modem link-recovery monitor-timer 20

lte modem link-recovery wait-timer 10

lte modem link-recovery debounce-count 6

!

!

!

!

!

crypto ipsec profile default

set ikev2-profile SCADA-v2-Profile

!

!

!

!

!

!

interface Tunnel121

description "xxx"

ip address xxx 255.255.255.252

ip mtu 1376

ip tcp adjust-mss 1336

tunnel source Cellular0

tunnel destination xxx

tunnel protection ipsec profile default

!

interface GigabitEthernet0

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet1

no ip address

shutdown

duplex auto

speed auto

!

interface Wpan2

no ip address

ieee154 txpower 25

no ieee154 fec-off

!

interface GigabitEthernet2

no ip address

shutdown

duplex auto

speed auto

!

interface Cellular0

description “xxx”

ip address negotiated

encapsulation slip

dialer in-band

dialer idle-timeout 0

dialer string lte

dialer watch-group 1

pulse-time 1

!

interface Cellular1

no ip address

encapsulation slip

!

interface Async0

no ip address

encapsulation raw-tcp

!

interface Async1

no ip address

encapsulation raw-tcp

!

!

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route xxx 255.255.255.255 Cellular0

ip route xxx 255.255.255.255 Cellular0

ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr

ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr

!

dialer watch-list 1 ip 5.6.7.8 0.0.0.0

dialer watch-list 1 delay route-check initial 60

dialer watch-list 1 delay connect 1

ipv6 ioam timestamp

!

!

snmp-server community S01arwinds RO

snmp-server enable traps wpan

!

control-plane

!

!

!

!

line con 0

login local

stopbits 1

line 1

exec-timeout 0 0

raw-socket tcp server 502

no exec

transport preferred none

transport input all

transport output none

stopbits 1

line 2

exec-timeout 0 0

no exec

transport preferred none

transport input all

transport output none

stopbits 1

line 3

script dialer lte

no exec

transport preferred none

transport output none

rxspeed 100000000

txspeed 50000000

line 8

no exec

transport preferred none

transport output none

rxspeed 100000000

txspeed 50000000

line 1/3 1/6

transport preferred none

transport output none

stopbits 1

line vty 0 4

login local

transport input xxx

!

no scheduler max-task-time

iox client enable interface GigabitEthernet2

!

!

!

!

!

!

end

 

1 REPLY 1
Highlighted
Cisco Employee

Re: Using a Cisco 809 as a Serial Server over Cellular Link. Modbus Protocol to Modicon Device

Hi Ken, I've sent you a private message to help get you an answer.

 

Thanks, Randy

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards
This widget could not be displayed.