cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Connecting CCP with CPO how-to

MatBecker
Beginner
Beginner

Is there a document available describing how to combine Cisco Cloud Portal (newScale) and Cisco Process Orchestrator (Tidal Enterprise Orchestrator)?


The documentation describes newScale and TEO, but not how you combine them to create the CIAC Solution.


I am looking for an how-to document describing in an example how to define a service plan delivery task that uses a ServiceLink workflow to initiate activities in TEO.

30 REPLIES 30

@Shaun Roberts: Indeed, I found one of your videos that gives an example of a custom process and agent.

My own agent don't work on our platform but neither do CIAC "native" ones, the services that should start the process "Cloud Portal Service Request Handler" don't do so, on TEO's side in "Operation->Activity Views->View Started" nothing appears, when I start manually a process in TEO it starts thought.

I think the reason my own agents/processes as well as CIAC one's don't work may be because the person who installed CCP and TEO didn't do it correctly.

Some ip's might have not been set up correctly, I'll have to check.

Cisco Server Provisioner is listed as a prerequesite in the file "Cisco-IAC-3.1.1-ConfigurationGuide-Part-OL-28882-02.pdf" that describes how to configure CIAC, but has not been installed, CSP isn't mandatory for processes to be started, is it?

TEO and CIAC aren't licensed (yet), this couldn't be the cause of our problem?

We started receiving hardware from Cisco and will have licenses in the next few days.

Ashley GASMI.

If you are able to start processes manually in PO, your license is good enough for your agents to start them, so that's not the issue.

No, CSP is not required for portal service requests to start processes.

Bad IPs, however, would definitely create a problem like you are describing. So would bad credentials in the agents.

Licenses should not matter.

Do you see any activity in ServiceLink for these agents?

Are the agents running?

Are the web services in CPO running/active?

--Shaun Roberts
Principal Engineer, CX
shaurobe@cisco.com

Thank you both for your answers,

the agents are running (green lights), sending/receiving (but the external tasks under the Transmissions tab in Service Link module stay at the status "ongoing"), the web services are active (I can see them in IIS manager and I can access the "http ://.../wsdl" (etc) links), but I'll have to check tomorrow if they are running in CPO.


We were planning to take a day to install CIAC again so we have one platform for developping and one for production on which we would import custom services and portlets once validated, the new one should work correctly if the problem is one of badly configured IP's, if it is we'll just fix our "developpment platform" or copy the VM on which was made a fresh installation.

Thank you for your time.

Nope, with a new installation, CCP doesn't interact with CPO. No matter what agent I use, I get the error : "Message Routing Exception", and when I clic on it details the error is actually a Http 403 error, I pasted the details under this post.

When I tried accessing processes from CCP to TEO in the previous version (Portal 9.4 patch 5a) it worked fine, but with the portal 9.4.1 and TEO 2.3.5 I have this issue.

I don't think it is an installation error since I tripled checked it, could this be a bug?

I haven't tried using SoapUI yet because I don't know the software, but it is my next step, I'll try to send the message CCP sends manually, to see where is the problem.

Here is the detail of the error message in Service link module:

(PS: My society has now 2 VM's with the portal and TEo on them - 1 has a TEO 1 year license and the other one only the 1 month trial)

com.newscale.is.core.RoutingException: Routing exception found: HTTP Post Error 403 caused by: HTTP Post Error 403 at com.newscale.is.core.MessageRouter.routeMessage(MessageRouter.java:118) at com.newscale.is.core.MessageExecutor.processOutboundMessage(MessageExecutor.java:600) at com.newscale.is.core.MessageExecutor.processMessage(MessageExecutor.java:124) at com.newscale.is.core.QueueListener.handleTextMessage(QueueListener.java:91) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at org.apache.camel.component.bean.MethodInfo.invoke(MethodInfo.java:340) at org.apache.camel.component.bean.MethodInfo$1.proceed(MethodInfo.java:237) at org.apache.camel.component.bean.BeanProcessor.process(BeanProcessor.java:168) at org.apache.camel.util.AsyncProcessorHelper.process(AsyncProcessorHelper.java:99) at org.apache.camel.component.bean.BeanProcessor.process(BeanProcessor.java:73) at org.apache.camel.impl.ProcessorEndpoint.onExchange(ProcessorEndpoint.java:101) at org.apache.camel.impl.ProcessorEndpoint$1.process(ProcessorEndpoint.java:71) at org.apache.camel.util.AsyncProcessorConverterHelper$ProcessorToAsyncProcessorBridge.process(AsyncProcessorConverterHelper.java:61) at org.apache.camel.util.AsyncProcessorHelper.process(AsyncProcessorHelper.java:73) at org.apache.camel.processor.SendProcessor$2.doInAsyncProducer(SendProcessor.java:115) at org.apache.camel.impl.ProducerCache.doInAsyncProducer(ProducerCache.java:285) at org.apache.camel.processor.SendProcessor.process(SendProcessor.java:110) at org.apache.camel.util.AsyncProcessorHelper.process(AsyncProcessorHelper.java:73) at org.apache.camel.processor.DelegateAsyncProcessor.processNext(DelegateAsyncProcessor.java:99) at org.apache.camel.processor.DelegateAsyncProcessor.process(DelegateAsyncProcessor.java:90) at org.apache.camel.management.InstrumentationProcessor.process(InstrumentationProcessor.java:71) at org.apache.camel.util.AsyncProcessorHelper.process(AsyncProcessorHelper.java:73) at org.apache.camel.processor.DelegateAsyncProcessor.processNext(DelegateAsyncProcessor.java:99) at org.apache.camel.processor.DelegateAsyncProcessor.process(DelegateAsyncProcessor.java:90) at org.apache.camel.processor.interceptor.TraceInterceptor.process(TraceInterceptor.java:91) at org.apache.camel.util.AsyncProcessorHelper.process(AsyncProcessorHelper.java:73) at org.apache.camel.processor.RedeliveryErrorHandler.processErrorHandler(RedeliveryErrorHandler.java:322) at org.apache.camel.processor.RedeliveryErrorHandler.process(RedeliveryErrorHandler.java:213) at org.apache.camel.processor.RouteContextProcessor.processNext(RouteContextProcessor.java:45) at org.apache.camel.processor.DelegateAsyncProcessor.process(DelegateAsyncProcessor.java:90) at org.apache.camel.processor.interceptor.DefaultChannel.process(DefaultChannel.java:303) at org.apache.camel.processor.RouteContextProcessor.processNext(RouteContextProcessor.java:45) at or