Showing results for 
Search instead for 
Did you mean: 


"Upgrade VM Tools" activity in CPO 3.0 is it supported for All Linux flavors?

"Upgrade VM Tools" activity in CPO 3.0 is it supported for All Linux flavors?

Upgrading VMTools for Linux is not success by using the activity.


Shaun Roberts
Cisco Employee



What error are you seeing in CPO? (screenshots might help)

What flavor(s) of linux are you using?

Can you do the upgrade/install of VM Tools via the vCenter gui?



--Shaun Roberts
Principal Engineer, CX

Hi Shaun,


I tried upgrading VMtools for Centos and the activity "Upgrade VMTools" got timed out. When i checked with the VM, VMtools was mounted to the vm and nothing happened. 

For RedHat vm VMTools were not installed, when tried to do it from activity got this error "The Upgrade Tools activity failed with the error: Cannot complete operation because VMware Tools is not running in this virtual machine."


For both it should work as those are common Linux flavors and are used in the field.


For your RedHat case, the activity does an UPGRADE of VMWare Tools, it does not do a fresh install, so you must have it already on the system and running. When you setup your templates/images best to install the OS, install VMWare tools and then clone that or template that.


For CentOS, you want to make sure VMWare tools is already running and you can try the same thing that the activity does(well close to it) manually by right clicking on that VM in vSphere client and select GUEST->Install/upgrade VMWare Tools and see what happens on the VM.


Note the activity(assuming it still works the same as the last time I saw it) basically uninstalls and reinstalls the tools, so if that VM was pending a reboot or something like that, then you'll have issues. (we saw this a lot in windows VMs, do not believe I ever saw this in a linux VM) You might have to raise the timeout too. It is set to 20 mins which is pretty good, but sometimes, just for a test, raise it very high and see if it works or never does.



--Shaun Roberts
Principal Engineer, CX


What values i can provide for "Options" field as in snap.

It allows you to modify the auto-install.



Basic command line syntax

vmrun <host authentication flags> <guest authentication flags> <command> <parameters>


To see all the options, click the Flyout Help icon in your toolbar in CPO. It looks like a white box with a question mark in it and it's the last icon on the toolbar. If you have selected the upgrade VMware activity and click this icon you'll get the help flyout for that activity. You will then see another link in the help flyout for options for install. (see screenshot below)


--Shaun Roberts
Principal Engineer, CX

Thank You.

Svetlana Kryukova

Please keep in mind that this activity is specifically for "Upgrade" of the tools. It cannot be used for install on a VM that had never had tools installed, because install usually requires user interaction.


Other than that, the upgrade should be supported on all OS-es supported by VMware.

Content for Community-Ad
This widget could not be displayed.