cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1025
Views
0
Helpful
6
Replies
Highlighted
Beginner

Tidal Transporter Automation

We are using Tidal version 5.3.1, we want to automate the process of job migration through Transporter by runing it into batch mode.

I have created a job with the help of the information provided in Transporter help however when i am runing that job it goes into Active status for long as if its hung into that status. Need to know if any one is using Transporter in batch mode or there is any way we can automate the migration process.

Thanks

Everyone's tags (3)
6 REPLIES 6
Highlighted
Beginner

Tidal Transporter Automation

I'm having the same issue.  I can transport jobs from the command line using the transporter in batch mode, however if I try to use the same command inside a job it hangs in the "active" state forever.  I'd like to know if there is a way to get some kind of status or logging out of the job so I can debug why it's stuck in the active state.

thanks.

Highlighted
Beginner

Tidal Transporter Automation

Hi Jay,

This issue got resolved for me i am able to run the Transporter into batch mode through a job.

Can you share the job details that you have created so that i can help you?

Thanks,

Parul Sharma

Highlighted
Beginner

Tidal Transporter Automation

Hi Parul.

(We're using version 5.3.1 as well)

in the "command" field i have this:  c:\Program Files\TIDAL\Transporter\XprtCmd.exe

in the "command parameters field i have this:  -s Adm_SB -d Adm_DEV -i c:\z_test_selectionfile.xpr -D -S -N N -A -T -m Adm_SB_to_DEV.map

Putting those two together on the command line will transport the job properly, but inside a job in the scheduler it just hangs.  I do believe the job has started the transporter because I see XprtCmd.exe as an active process in the task manager on the server where the agent is running after starting the job. 

What did you do to fix your issue?

Thanks,

Jay

Highlighted
Beginner

Tidal Transporter Automation

Hi Jay,

Have you tried to run this command from the command prompt where your transporter is installed?

I have created a selection file and then tried to run it in batch mode insted of passing the command parameter as you are doing.

Some checks would be:

The agent through which your job is runing shouldnt be using its logon as local system.

The Runtime user id should be a super user to run the transporter into Batch mode.

Please check the security policies for the agent on the server.

you can have a selection file in place instead of passing so many command parameters. i found that an easy option instead.

Thanks,

Parul Sharma

Highlighted
Beginner

Tidal Transporter Automation

Just FYI,

The list of Local Security Policy permissions required for an agent service user:

Act as part of the operating system
Adjust memory quotas for the process
Bypass traverse checking
Logon as a batch job
Logon as a service
Replace a process level token

Highlighted
Beginner

Tidal Transporter Automation

Thanks Parul,  I was able to solve my issue of the job hanging by using a runtime user that had super user access for the connection.

I've noticed something else regarding passing parameters on the command line versus the selection file.  The "Running Transporter in Batch Mode" documentation implies that you can override what is in your selection file by passing the source alias, destination alias, and mapping file as paramters on the command line, however this does not work for me.

If I have the values in both places, the transporter always takes the values from the selection file.  I was hoping to create the selection file once, and then override the source alias, destination alias, and mapping file on the command line as I migrate the same jobs from DEV --> QA --> Prod.

Have you had a similar experience overriding values on the command line?

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey