cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
28453
Views
21
Helpful
34
Comments
Steve Zhang
Cisco Employee
Cisco Employee

IR829 router is similar to CGR routers. And IR809 is same as IR829.

IR829 has one GE0 wan interface which needs an Ethernet SFP for connecting the WAN Ethernet cable in our LAB switch, four LAN switch ports and 2 serial interfaces.

Access the console of IR829:

IR829 is using a mini-USB port for the serial interface. Please use a Mini-USB cable to connect to your PC. You may need to install the driver for the console. Here is the link for the drive. The default baud rate is 9600. For details, please refer to Cisco IR829 Industrial Integrated Services Router Hardware Installation Guide - Connecting the Router [Cisco 800 Series ….

Bundle image installation on the 829:

bundle image can be used to upgrade the 829 - ir800-universalk9-bundle.SPA.156-1.T1.bin -- which has IOS, guset OS , Hypervisor from ir800-universalk9-bundle.SPA.156-1.T1.bin. You need to download the bundle image from CCO and uploaded it for IR829 flash by SCP, HTTP, TFTP, etc. For example:

copy scp://username@10.10.10.10//home/username/ir800-universalk9-bundle.SPA.156-1.T1.bin flash:

bundle install flash:ir800-universalk9-bundle.SPA.156-1.T1.bin

The image can be upgraded using the 829 bundle image available here Cisco Systems CCO. You can upgrade the images individually also.

Please notify, the 15.6 or later can be upgraded from 15.5.3 only. All the other version such as 15.5.2 or earlier must be upgrated to 15.5.3 first, and then upgraded to 15.6 or later.

IR829 Configuration:

  • Step1: Configure the wan interface of the 829 router GE0.

===========================================

Set the GE interface with the specific IP address and network mask.

"ip nat outside" to specify that the interface is connected to the outside network. If your GOS is assigned with a publish IP address, you don’t need to set the NAT related in all the configurations below.

interface GigabitEthernet0

ip address 72.163.206.123 255.255.255.0

ip nat outside

ip virtual-reassembly in

[NOTE]: Here GLC-T SFP for GE0 is supported. The OS version on which it is officially supported is 15.5(3)M0a or above. And you need to add the below CLI.

config terminal

service internal

service unsupported-transceiver

And you may also use the GE interfaces (GE1-4) instead of WAN interface to access internet. Here we use GE1 and Vlan999 as an example.

interface GigabitEthernet1

switchport access vlan 999

no ip address

!

interface Vlan999

ip address 10.75.189.144 255.255.255.0

ip nat outside

ip virtual-reassembly in

!

  • Step2: Configure the "ip route" and "ip default gateway"

=======================================

ip default-gateway 72.163.206.1                              //or 10.75.189.1 if you are using GE1 as example

ip router 0.0.0.0 0.0.0.0 72.163.206.1                      //or 10.75.189.1 if you are using GE1 as example

  • Step 3: Configure the GOS and IOS connectivity interface - GE5

=============================================

ip nat inside  -  Enter ip nat inside to specify that the interface is connected to the inside network and

ipv6 enable   -  IPv6 must be enabled also have to configured

interface GigabitEthernet5

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

ipv6 enable

  • Step 4: To assign an IP address to the Guest OS, configure a Local DHCP pool:

============================================================

ip dhcp excluded-address 192.168.1.1 192.168.1.5

ip dhcp pool gospool

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1                                 <<<<<<<<<<<<<<<,GE5 is the gateway to GOS

dns-server 64.104.123.144

  • Step 5: Nat configurations:

====================

ip nat inside source list NAT_ACL interface GigabitEthernet0 overload

ip nat inside source static tcp 192.168.1.6 22 interface GigabitEthernet0 2222

ip nat inside source static tcp 192.168.1.6 8443 interface GigabitEthernet0 8443

ip access-list standard NAT_ACL

permit 192.168.0.0 0.0.255.255

[NOTE]: Please replace the GigabitEthernet0 with Vlan999 in case the GE1-4 is used for connecting internet.

ip nat inside source list NAT_ACL interface Vlan999 overload

ip nat inside source static tcp 192.168.1.6 22 interface Vlan999 2222

ip nat inside source static tcp 192.168.1.6 8443 interface Vlan999 8443

ip access-list standard NAT_ACL

permit 192.168.0.0 0.0.255.255


Make sure 8443 is enabled for further deployment of applications. Verifying GOS is running and got the IP address from the DHCP pool with “show iox host list detail”.

And you should have “privilege 15” to access the Web interface (such as IOx Local Manager) for IR829. The IOS command is: username yourusername privilege 15 password 0 yourpassword

Verifying GOS is running and get the IP address from the DHCP pool:

=================================================

IR800#show iox host list detail

IOX Server is running. Process ID: 261

Count of hosts registered: 1

Host registered:

===============

    IOX Server Address: FE80::86B8:2FF:FE9C:ED8C; Port: 22222

    Link Local Address of Host: FE80::1FF:FE90:8B05

    IPV4 Address of Host:       192.168.1.6                                      <<<<<<<<<<<<<<<<<<<<<<ip address got from the DHCP Pool.

    IPV6 Address of Host:       fe80::1ff:fe90:8b05

    Client Version:             0.1

    Session ID:                 1

    OS Nodename:                IR800-GOS-1

    Host Hardware Vendor:       Cisco Systems, Inc.

    Host Hardware Version:      1.0

    Host Card Type:             not implemented

    Host OS Version:            1.28

    OS status:                  RUNNING

    Interface Hardware Vendor:  None

    Interface Hardware Version: None

    Interface Card Type:        None

    Applications Registered:

    =======================

        Count of applications registered by this host: 0                        <<<<<<<<<<<<<<<<<<<<<<<< applications running on the GOS

IR800#

Starting Guset OS :

===========

IR800#guest-os 1 start

Stopping GOS:

============

IR800#guest-os 1 stop

Upgrade of guest OS:

============

Copy Guest OS image to IOS flash partition

guest-os 1 stop

guest-­os 1 image uninstall

guest-os 1 image install flash:<GOS image in falsh> verify

guset-os 1 start

If you want to install the original Guest OS from the bundle image, you may run the below command:

bundle install flash:<bundle image in falsh> exclude HV-IOS

All the cartridges and applications for IOx are stored in the specific partition in IR829, and will not be impacted by the upgrade of Guest OS. If you have installed the cartridges and applications for the old Guest OS, all the cartridges and applications will be still there after the upgrade with the new Guest OS. (Please notify: for some early versions, due to the modification of CAF framework, there is some impact for the applications. You'd better remove all the cartridges and applications before upgrade of Guest OS to avoid the incompatibility, and then re-install them accordingly after upgrade.)

FOR THE LATEST INFORMATION AND CONFIGURATION, PLEASE REFER TO https://developer.cisco.com/docs/iox/#ir-800-series

Comments
evo
Beginner
Beginner

Hi Jun,

Thanks for your response.

Do you have a list of sensors integrated already in IR829?

Thanks!

Regards,

Edgar

junxu2
Cisco Employee
Cisco Employee

Hi Edgar,

Because IOx is based on Yocto Linux and customer can integrate their drivers on this platform, sensor drivers is not default integrated in IR829 and we don't have a list of recommended sensors. But, when you plug USB to IR829, you can see a "ttyUSBx" device which can be utilized by your driver. That just like to insert a device to a linux device. Many linux drivers with x86 64bit arch can be used in IOx.

Regards

Jun

rbaindou
Cisco Employee
Cisco Employee

Hello,

I received an IR829 for a project.

My current setup is that I have a cable modem and netgear nighthawk for wifi and wired nodes.

I purchased this GLC-T compatible SFP to copper adapter for the WAN/GE0 port.

amazon.com/gp/product/B01CU2ZGVI

But the light is not turning on when I plug it into my netgear router.

But when I plug in GE1 into the netgear, I acquire an IP address for the IR829 itself, and the GE2-4 seemed to act like a switch, effectively adding all the nodes wired to the 829 onto the DHCP network advertised from the netgear.

My original goal was to set the DHCP pool to 192.168.2.0/24 for GE1-4 and receive an IP address via DHCP also on WAN/GE0 from the 192.168.1.0/24 block.

So a couple of questions.

Should I exchange the adapter? I added the `no shutdown` command to the interface GigabitEthernet0 configuration. So it should be up, I am assuming.

And is what I am trying to do even possible?

And if so how to execute this idea off of GE1 if my copper adapter is bad?

Thanks in Advance

Here is some of my show run output:

http://pastebin.com/avyY3YLZ

And sorry if my networking theory is all off, I took CCNA over a decade ago, and then became a web developer.

Steve Zhang
Cisco Employee
Cisco Employee

Hi Robert,

The dhcp pool speedway (192.168.2.x) you set is for GOS on IR829 IOx, not for the GE0-4. For GE0, it is the WAN port (SFP), and GE1-4 are GE LAN port(RJ45). The GE0 and GE1-4(with switchport) IP addresses depends on what external port they connect. For details, you may refer to Cisco IR829 Industrial Integrated Services Router Hardware Installation Guide - Product Overview [Cisco 800 Series Indus…. Hope it helps.

Thanks,

Steve

fcolumbu
Cisco Employee
Cisco Employee

Hi Robert,

This link will help you with to explain the configuration of the platform:

https://developer.cisco.com/media/iox-dev-guide-11-28-16/platforms/platform-ir8xx/

This link will help you regarding the SFP:

Unsupported GBIC (SFP) in sub-module of Catalyst 3850 Switch – Mitigation Techniques - Cisco

Hope this works for you.

Regards,

Frank

rbaindou
Cisco Employee
Cisco Employee

Hi,

I am still full of questions:

For Example, here is one confusing thing:

I think am supposed to install version 15.6(1)T1 because when I do show run I it says version 15.5

But when I do show platform guest-os it says 1.28.

That's is very confusing. So I am supposed to copy the ioxvm image for 15.6 and install it on to guest-os and its supposed to read version 1.29?

Also I am unable to access the Local Manager. What is the default username and password?

None of the commands to update credentials work.


I get output like this when I try to put the username and password according to the document

IR800>enable

IR800#config t

Enter configuration commands, one per line.  End with CNTL/Z.

IR800(config)#username admin privilege 15 secret admin

IR800(config)#end                                    

IR800#show run | sec username

username admin privilege 15 secret 5 $1$YzuF$jVTZzgDuEjIyyxMGU2NoT.

IR800#

But then I still can't access the Web UI.

Then my question was not really answered, is my SFP to GBE adapter bad if the light doesn't turn on?

Did I miss some command to actually power up GE0?

Thanks

-Robert Baindourov

fcolumbu
Cisco Employee
Cisco Employee

Hi Robert,

If you observed that "when I do show run I it says version 15.5," it means that you will need to do a bundle install to the latest software.


IOx will not run using 15.5.


Please follow the guide here:

https://developer.cisco.com/media/iox-dev-guide-11-28-16/platforms/platform-ir8xx/#upgrade-using-bundle

Please use the latest image from cisco.com.

https://software.cisco.com/download/release.html?mdfid=286287074&softwareid=280805680&release=15.6.3M1&relind=AVAILABLE&rellifecycle=ED&reltype=latest

Thanks,

Frank

junxu2
Cisco Employee
Cisco Employee

Based on meeting with you, hope you have solved the problem. Basically, the initial configuration is need to be done for network on IOS side.

rbaindou
Cisco Employee
Cisco Employee

Thank you Jun, you were a great help.

I am very humbled by all the commands that are needed to setup the router.

I have so many questions still, like why the loopback interface needed to be 1.1.1.1.

IOS vs IOX

Why dual operating systems, and do I only need to upgrade the guest os and not the... I guess firmware?

Or I guess the firmware lives even lower, under the hypervisor?

Will the configuration you entered survive the ioxvm upgrade?

Unfortunately I started recording our webex a little late, and still don't have the confidence that I would like about how to set these industrial routers up correctly.

So Now I am trying to search the cisco learning network to try and find a way to fill my knowledge gap.

Reading a command reference is only going to show me how to use the commands correctly and I won't understand why you did the steps you did.


Can someone recommend a course on the cisco learning network for me?



Thanks in Advance.

junxu2
Cisco Employee
Cisco Employee

Hi Robert,


"1.1.1.1" is for easy access to IOS. You can ignore that. That won't impact any function.

For more detail information about IOx, please refer to https://developer.cisco.com/site/iox/

Jun

anirukas
Cisco Employee
Cisco Employee

Hi All,

I have followed the procedure provided for initial set up. The output of the command "show iox host list" gives me the below result:

IR800#show iox host list

  No host is registered.

Please help in resolving this.

a.veneziano
Beginner
Beginner

Hi All,

today i've try to modify root password on GOS but I've received this error:

ir829#iox host exec "resetpw cisco" sw1-GOS-1

  Error: operation failed (at IOX Client): Script not found

ir829# Cisco IOS Software, ir800 Software (ir800-UNIVERSALK9-M), Version 15.7(3)M, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2017 by Cisco Systems, Inc.

ir829# show platform guest-os

Guest OS status:

Installation: Cisco-GOS,version-1.4.2.3

State: RUNNING

Could you help me?

Thanks in advance

Steve Zhang
Cisco Employee
Cisco Employee

Please note, the latest versions of IOx use the “username _______ password ______” configured in IOS for access to IOx. It is not recommended to use "resetpw" any more.

a.veneziano
Beginner
Beginner

Thank you very much Steve.

I found that command in the last IR829 configuration guide (Updated May 18, 2017) in the section related to Guest OS.

hengchang zhao
Beginner
Beginner

Hi,

I got a IR829 router from a project and i want to setup IOx on the router.  i have followed the procedure provided for initial setup  But now i got this information. And i can not login on the GOS.  If someone can help me to troubleshooting on it.

IR800#show iox host  list

  No host is registered.

IR800#telnet 192.168.1.1 2070

qemux86-64 login: root

IOS user password:

Login incorrect

GOS already got an IP address from internal DHCP server.

IR800#show ip dhcp  pool

Pool gospool :

Utilization mark (high/low)    : 100 / 0

Subnet size (first/next)       : 0 / 0

Total addresses                : 254

Leased addresses               : 1

Pending event                  : none

1 subnet is currently in the pool :

Current index        IP address range                    Leased addresses

192.168.1.12         192.168.1.1      - 192.168.1.254     1

IR800#

IR800#ping 192.168.1.11

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.11, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

IR800#

Below is our configuration file.

hostname IR800

!

boot-start-marker

boot-end-marker

!

!

enable password cisco123

!

aaa new-model

service-module wlan-ap 0 bootimage autonomous

!

ignition off-timer 900

!

ignition undervoltage threshold 9

!

no ignition enable

!

!

!

ip dhcp excluded-address 192.168.1.1 192.168.1.5

!

ip dhcp pool gospool

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 64.104.123.144

!

!

!

ip domain name cisco.com

ip cef

ipv6 unicast-routing

ipv6 cef

!

multilink bundle-name authenticated

!

!

!

chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"

!

!

license udi pid IR829GW-LTE-LA-QK9 sn FGL21132601

!

!

username cisco123 privilege 15 password 0 cisco123

username root privilege 15 password 0 cisco123

username test password 0 test

!

redundancy

!

!

!

!

!

!

interface GigabitEthernet0

ip address 10.199.92.48 255.255.255.192

ip nat outside

ip virtual-reassembly in

!

!

interface GigabitEthernet5

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

ipv6 enable

!

ip nat inside source list NAT_ACL interface GigabitEthernet0 overload

ip nat inside source static tcp 192.168.1.9 22 interface GigabitEthernet0 2222

ip nat inside source static tcp 192.168.1.9 8443 interface GigabitEthernet0 8443

ip route 0.0.0.0 0.0.0.0 10.199.92.1

ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr

ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr

!

ip access-list standard NAT_ACL

permit 192.168.0.0 0.0.255.255

!

ipv6 ioam timestamp

!

!

!

control-plane

!

!

line 1/4

transport preferred none

transport input all

transport output none

stopbits 1

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers
Quick Links