cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
18911
Views
97
Helpful
28
Replies
Beginner

ASA 5506 Firepower Timezone

How do i change the timezone for the Firepower module ?

It seems to default to New York, and i cant find any way to change this

/Per Buch

3 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

All,

All,

Please be advised that changing the time zone from the command line is NOT supported. Doing so will require you to re-image the device to enter back into a supported state.

Thank you,

Justin Roberts

Firepower TAC

View solution in original post

Cisco Employee

An enhancement has been

An enhancement has been submitted to have this feature added:

https://tools.cisco.com/bugsearch/bug/CSCuu10347

View solution in original post

Cisco Employee

The bug has been identified

The bug has been identified and the issue is expected to get fixed in the following versions:-

DULCE_VIDA 6.0.0.2 5.4.1.6_KENTON 5.4.0.7_AND_5.4.1.6_DC  

The default time settings on the Firepower CLI is in UTC timezone. We are not supposed to change the default timezone via CLI(ssh) . There are several cron jobs running based on the UTC timezone internally. If you change the default timezone settings , then it will also affect the schedule reports . Thus changing the timezone via CLI will leave the device is in unsupported state. Incase you have changed the timezone its adviced to reimage the device to get back the support .

View solution in original post

28 REPLIES 28
Hall of Fame Guru

We set the time for event and

We set the time for event and other displays in the managing FireSIGHT Management Center (or FMC section of the ASDM GUI for the low end devices).

On an FMC, it's under the Username (top right) > User Preferences > Time Zone preference.

 

Beginner

But on ASDM ?

But on ASDM ?

Hall of Fame Guru

My 5506 is at home and I don

My 5506 is at home and I don't have it in front of me to verify. The User Guide for that doesn't mention it so it might not be separately configurable. In that case it would pick it up from the ASA.

Have you set the timezone of the base ASA to your desired setting? (Configuration > Device Setup > System Time > Clock)

Beginner

Yes, the base asa is at the

Yes, the base asa is at the right timezone.

Cisco Employee

The bug has been identified

The bug has been identified and the issue is expected to get fixed in the following versions:-

DULCE_VIDA 6.0.0.2 5.4.1.6_KENTON 5.4.0.7_AND_5.4.1.6_DC  

The default time settings on the Firepower CLI is in UTC timezone. We are not supposed to change the default timezone via CLI(ssh) . There are several cron jobs running based on the UTC timezone internally. If you change the default timezone settings , then it will also affect the schedule reports . Thus changing the timezone via CLI will leave the device is in unsupported state. Incase you have changed the timezone its adviced to reimage the device to get back the support .

View solution in original post

Beginner

I suppose it is a bug. I got

I suppose it is a bug. I got the same problem. The fact is when you change the time by (further is an example) ln -sf /usr/share/zoneinfo/Europe/Moscow /etc/localtime and when you add in  /etc/sysconfig/clock

ZONE="Europe/Moscow"

UTC=true

the output of the date command and hwclock command is correct, but

logs in ASDM still show UTC.

On the very ASA time and zone settings are correct and the very ASA's ASDM show correct (Moscow) time.

I'd like to ask (it is a bit offtopic here) - I have the control and protection license on cisco ASA 5506-x and everything works with access policies but user awareness.

I have set up User Agent on windows 7 workstation, it sees Domain Controller and according to logs it polls logs from it, and sends info to ASA firepower (logs tell that "Reported Heartbeat from windows 7 wks to ip of Firepower module"). Also I have set up through ASDM user agent on ASA Firepower. But asa firepower report on dashboard says that user information is unavailable and of course no blocking user traffic from the host where user is logged on according to AccessPolicy (LDAP connection is succesfully set up).

I have spent a week with troubleshooting  - no success.

Hall of Fame Guru

I poked around in my home ASA

I poked around in my home ASA 5506X. No joy in setting the FirePOWER module time in the ASDM GUI.

However, it appears you can change it in the Linux shell if you really want to. the time is set via a symbol link from the timezone file to /etc/localtime.

Mine was set at UTC by default and I changed it to GMT-5 as follows:

 

Xshell:\> ssh admin@192.168.1.254

Connecting to 192.168.1.254:22...
Connection established.
To escape to local shell, press 'Ctrl+Alt+]'.

Last login: Thu Jul  2 16:09:38 2015

Copyright 2004-2015, Cisco and/or its affiliates. All rights reserved. 
Cisco is a registered trademark of Cisco Systems, Inc. 
All other trademarks are property of their respective owners.

Cisco Linux OS v5.4.1 (build 12)
Cisco ASA5506 v5.4.1 (build 211)

> 
> expert
admin@Sourcefire3D:~$ 

admin@Sourcefire3D:/etc/sysconfig$ date
Thu Jul 16 20:16:54 UTC 2015
admin@Sourcefire3D:/etc$ sudo ln -sf /usr/share/zoneinfo/Etc/GMT-5 /etc/localtime

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

Password: 
admin@Sourcefire3D:/etc$ date 
Fri Jul 17 01:26:17 GMT-5 2015
admin@Sourcefire3D:/etc$ 
Highlighted
Beginner

I tryed withsudo ln -sf /usr

I tryed with

sudo ln -sf /usr/share/zoneinfo/Etc/GMT+1 /etc/localtime

Date command show GMT+1 (Denmark)

I still get a warning on the reporting page in ASDM

"time range was adjustet to align with report data"

The time shown on the page is "Fri 17 Jul 2015, 2:35 PM (UTC)"

And the ASA time is 17:35

Hall of Fame Guru

Hmm. It could be either a bug

Hmm. It could be either a bug or just that neither of us understands it well enough.

If the unit has Smartnet perhaps you could open a TAC case on it.

Beginner

No smartnet, its my demo unit

No smartnet, its my demo unit.

A serious bug that it is impossible to set the time zone from ASDM.

There are also missing the possibility to change the admin password.

I cant be the only one with this problem.

 

Beginner

Did anyone else notice the

Did anyone else notice the time changes in the wrong direction? I am in Arizona and we are always GMT-7. When I set this, the time went forward 7 hours ahead of UTC.  You can even see this in Marvin's example. He's at 20:16:54 on a Thursday & then sets GMT-5 and he goes ahead 5 hours into Friday morning. Seems odd to me, but just applying reverse logic it works at least.

Cisco Employee

All,

All,

Please be advised that changing the time zone from the command line is NOT supported. Doing so will require you to re-image the device to enter back into a supported state.

Thank you,

Justin Roberts

Firepower TAC

View solution in original post

Beginner

How about an update that

How about an update that makes i possible from ASDM ?

Cisco Employee

An enhancement has been

An enhancement has been submitted to have this feature added:

https://tools.cisco.com/bugsearch/bug/CSCuu10347

View solution in original post

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards
This widget could not be displayed.