cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
251
Views
0
Helpful
2
Replies

2901 Router FXO problems

Denis Morin
Beginner
Beginner

I have a 2901 router setup as an h323 gateway for 4 fxo lines.  The problem is only 1 call can be placed at a time (inbound or outbound).  the second call seems to rings the other end once and but will not let you answer.  What would cause a router to only allow 1 call at a time?

2 Replies 2

Deven Gandhi
Beginner
Beginner

Could you please attach your running config so we can verify your config?


-Deven Gandhi
*Please rate all useful post

Here is a copy of the config

!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XXXX
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
clock timezone EST -5 0
clock summer-time EDT recurring
clock calendar-valid
!
!
!
!
!
!
!
!
!
!
!
!
ip dhcp pool DATA-DHCP
network 10.10.207.0 255.255.255.0
default-router 10.10.207.1
dns-server 10.10.10.9
lease 0 2
class DATA
address range 10.10.207.100 10.10.207.254
!
ip dhcp pool VOIP-DHCP
network 10.10.107.0 255.255.255.0
default-router 10.10.107.1
option 150 ip 10.100.1.14 10.100.1.15
dns-server 10.10.10.9
lease 0 2
class VOIP
address range 10.10.107.100 10.10.107.254
!
!
ip dhcp class DATA
!
ip dhcp class VOIP
!
!
no ip domain lookup
ip domain name xxx.local
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
trunk group ALL
max-retry 5
voice-class cause-code 1
hunt-scheme sequential
!
cts logging verbose
!
voice-card 0
!
!
!
voice service voip
ip address trusted list
ipv4 x.0.0.0 255.0.0.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
h323
no h225 timeout keepalive
call preserve
session transport udp
!
voice class codec 711
codec preference 1 g711ulaw
codec preference 2 g729r8
!
voice class codec 1
!
voice class h323 10
h225 timeout tcp establish 5
!
voice class h323 1
h225 timeout tcp establish 5
h225 timeout setup 3
!
!
!
!
!
!
voice translation-rule 10
rule 1 /555272(....)/ /9555272\1/
rule 2 /\([0-9].*\)/ /91\1/
!
voice translation-rule 1000
rule 1 /^911$/ /911/
rule 2 /^9\(.*\)/ /\1/
!
!
voice translation-profile Pre
translate calling 10
!
voice translation-profile Remove9
translate calling 1000
translate called 1000
!
!
!

hw-module pvdm 0/0
!
!
!

!
redundancy
!
!
!
!
!
!
class-map match-any VOIP
match access-group name XXXX
class-map match-any AutoQoS-VoIP-Remark
match ip dscp ef
match ip dscp cs3
match ip dscp af31
class-map match-any AutoQoS-VoIP-Control-UnTrust
match access-group name AutoQoS-VoIP-Control
class-map match-any AutoQoS-VoIP-RTP-UnTrust
match protocol rtp audio
match access-group name AutoQoS-VoIP-RTCP
!
policy-map VOIP-QOS
class VOIP
shape average 512000
policy-map AutoQoS-Policy-UnTrust
class AutoQoS-VoIP-RTP-UnTrust
priority percent 70
set dscp ef
class AutoQoS-VoIP-Control-UnTrust
bandwidth percent 5
set dscp af31
class AutoQoS-VoIP-Remark
set dscp default
class class-default
fair-queue
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp key cisco address x.x.x.x
!
!
crypto ipsec transform-set VPN esp-3des esp-md5-hmac
mode tunnel
!
!
!
crypto map REMOTEVPN 2 ipsec-isakmp
set peer x.x.x.x
set transform-set VPN
match address VPN-PERMIT
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description Physical ADSL Interface (Facing the ISP)
no ip address
ip tcp adjust-mss 1452
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
service-policy output VOIP-QOS
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.107
description VOIP VLAN
encapsulation dot1Q 107
ip address 10.10.107.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id XXX ipaddr 10.10.107.1 1719
h323-gateway voip bind srcaddr 10.10.107.1
!
interface GigabitEthernet0/1.207
description DATA VLAN
encapsulation dot1Q 207
ip address 10.10.207.1 255.255.255.0
!
interface Dialer1
description Logical ADSL Interface
ip address x.x.x.x 255.255.255.0
ip mtu 1492
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname xxxx
no ppp chap ignoreus
ppp chap password 0 xxxx
ppp pap sent-username xxxx password 0 xxxx
no cdp enable
crypto map REMOTEVPN
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!

ip access-list extended AutoQoS-VoIP-Control
permit tcp any any eq 1720
permit tcp any any range 11000 11999
permit udp any any eq 2427
permit tcp any any eq 2428
permit tcp any any range 2000 2002
permit udp any any eq 1719
permit udp any any eq 5060
ip access-list extended AutoQoS-VoIP-RTCP
permit udp any any range 16384 32767
ip access-list extended VPN-PERMIT
permit ip 10.10.107.0 0.0.0.255 any
permit ip 10.10.207.0 0.0.0.255 any
ip access-list extended VPN-VOIP
permit ip 10.10.107.0 0.0.0.255 any
permit ip 10.10.207.0 0.0.0.255 any
!
!
!
!
!
!
control-plane
!
rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS
!
voice-port 0/0/0
trunk-group ALL 4
translation-profile incoming Pre
translation-profile outgoing Remove9
echo-cancel coverage 24
timeouts interdigit 3
connection plar opx immediate 7213
!
voice-port 0/0/1
trunk-group ALL 3
translation-profile incoming Pre
translation-profile outgoing Remove9
echo-cancel coverage 24
timeouts interdigit 3
connection plar opx immediate 7213
!
voice-port 0/0/2
trunk-group ALL 2
translation-profile incoming Pre
translation-profile outgoing Remove9
echo-cancel coverage 24
timeouts interdigit 3
connection plar opx immediate 7213
!
voice-port 0/0/3
trunk-group ALL 1
translation-profile incoming Pre
translation-profile outgoing Remove9
echo-cancel coverage 24
timeouts interdigit 3
connection plar opx immediate 7213
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 1 voip
destination-pattern 9T
incoming called-number .
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 1000 voip
preference 2
destination-pattern [0-8]T
b2bua
session protocol sipv2
session target ipv4:10.100.1.15
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 1001 voip
preference 1
destination-pattern [0-8]T
session target ipv4:10.100.1.14
voice-class codec 711
voice-class h323 1
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 100 pots
trunkgroup ALL
description **10-Digit Local**
destination-pattern 9[2-9]..[2-9]......
forward-digits all
no sip-register
!
dial-peer voice 101 pots
trunkgroup ALL
description **Service Numbers**
destination-pattern 9[2-8]11
forward-digits all
no sip-register
!
dial-peer voice 104 pots
trunkgroup ALL
description **Emergency**
destination-pattern 9911
forward-digits all
no sip-register
!
dial-peer voice 103 pots
trunkgroup ALL
description **International**
destination-pattern 9011T
forward-digits all
no sip-register
!
dial-peer voice 105 pots
trunkgroup ALL
description **Emergency**
destination-pattern 911
forward-digits all
no sip-register
!
dial-peer voice 102 pots
trunkgroup ALL
description **Long Distance**
destination-pattern 91[2-9]..[2-9]......
forward-digits all
no sip-register
!
!
!
!
gatekeeper
shutdown
!
!
call-manager-fallback
secondary-dialtone 9
max-conferences 1 gain -6
transfer-system full-consult
timeouts interdigit 5
ip source-address 10.10.107.1 port 2000
max-ephones 42
max-dn 200 dual-line
system message primary SRST MODE
transfer-pattern .T
call-forward pattern .T
moh enable-g711 "moh.au"
time-zone 12
time-format 24
date-format dd-mm-yy
!
!
!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: