cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3623
Views
45
Helpful
28
Replies
Highlighted

2911GW, mgcp and Fax issue.

Hi everyone.

I just have installed a new branch for a costumer that include a 2911 with E1 primary for external calls and registered to a CUCM using a mgcp.

So, The CUCM have sip trunks connected to a Right Fax application. primary-> mgcpGw--->cucm sip--->right fax

The problem is the fax have error at the midle of the recepcion and many of them appear cut off. We have cheked send the fax to fax machine (instead of right fax) using ATAs and we have the same problem.  primary-->mgcpGW-->cucm-->ATA---Fax machine.

But depende of the fax machine which is sending the Fax, some works always others never.

The CUCM is 7.1. and this is the mgcp configuration.

SANPOR_2921_1#show run | s mgcp

pri-group timeslots 1-31 service mgcp

ccm-manager mgcp

mgcp

mgcp call-agent 168.124.50.12 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp package-capability srtp-package

mgcp package-capability fm-package

mgcp default-package fxr-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp validate call-agent source-ipaddr

mgcp fax rate 14400

mgcp fax t38 ecm

mgcp fax t38 ls_redundancy 2

mgcp fax t38 hs_redundancy 2

mgcp fax t38 gateway force

mgcp profile default

IOS C2900-UNIVERSALK9-M, Version 15.1(4)M3,

We use this configuration in another branchs and it works fine.

Any ideas?

Thank you for avance

Best Regards.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Mentor

2911GW, mgcp and Fax issue.

Yes, please adjust the config as below:

no ccm-manager fax protocol cisco

mgcp modem pass-through voip mode nse

no mgcp fax t38 ecm

no mgcp fax t38 gateway force

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts

View solution in original post

28 REPLIES 28
Beginner

2911GW, mgcp and Fax issue.

If you use this configuration at other branches and works fine the only other thing I see is that you are missing one config per the CUCM SRND...

no mgcp fax t38 inhibit

mgcp package-capability fxr-package

Highlighted
VIP Mentor

2911GW, mgcp and Fax issue.

Hi Gear,

First question what fax protocol are you using or do you want to use? It is modem pass-through or T.38. Your gateway configuration is wrong for either. You need to have one or the other enabled.

ISince your call is going over a sip trunk, I suppose you want to use modem pass-through or doeas your provider support T.38? For modem-passthrough to work, you need to make sure that T38 is disabled by configuring “mgcp fax t38 inhibit”. Also you need to make sure that fxr-package is not configure at all.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts
Highlighted

Re: 2911GW, mgcp and Fax issue.

Hi

Thank you for the answers.

OK, really I have removed and included few commands to try fix the problem and that configuration is not similar to I have used at the beginning hehe.

Anyway.

My objetive was use T38. What do you recommend me to use for Rightfax? I made a SIP trunk between the CUCM and the Right Fax costumer server. Everything in the same CPD.

mmm I though no mgcp fax t48 inhibit was at the configuration, ok I'm going to revise the configuration and try with pass through..

I will update the post whit news.

Thank you.

Best regards

Highlighted
VIP Mentor

Re: 2911GW, mgcp and Fax issue.

From investigations I did, I think it is better to use T.38 with rightfax. However please be 100% sure your sip provider support T.38.

Here is a config that worked for one of the users on this forum..The thread the config is from is also here..

https://supportforums.cisco.com/thread/2047028

"I just wanted to add this to the thread. I had issues with out setup and rightfax I did the following and it started to work:"

The issue was that the cisco gateways were not receiving t38 configs from call manager.

Resolution was to add the following to the config of the mgcp gateways:

no ccm-manager fax protocol cisco              

no mgcp fax t38 inhibit 

mgcp package-capability fxr-package

mgcp default-package fxr-package

no mgcp fax t38 ecm

mgcp fax t38 nsf 000000

Also you need to remove modem passthrough..with

no mgcp modem pass-through voip mode nse

Re-register the Gateway with CallManager by entering the following commands :

no mgcp

mgcp

Here is another thread that confirms that rightfax workes better with T.38 and that if things get really tough with MGCP, you may need to consider h323..But I suggest you try the above config first..

https://supportforums.cisco.com/thread/295084

no mgcp

mgcp

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts
Highlighted
Engager

2911GW, mgcp and Fax issue.

Note that ATA 186s don't support T.38

GTG

Please rate all helpful posts.
Highlighted

Re: 2911GW, mgcp and Fax issue.

Hi Again

I really hate the Faxes, We have email, Who need faxes?

Anyway.

The issue persist. Don't care if it is a fax machine or Righfax, both suffer the same problem, some faxes come succefully others just half of them and others don't come. The connexion always set, but many time don't finish well.

I have try many combinations of mgcp configuration: donwload the speed, desactivate t38, frame relay, etc.

I have using the same configuration of  another branch right now, and that configuration is working there, but in the new branch it had problems. The configuration is this.

cm-manager redundant-host 168.124.50.11

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 168.124.50.11 

ccm-manager config

!

mgcp

mgcp call-agent 168.124.50.12 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode nte-ca

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp package-capability fm-package

mgcp default-package fxr-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp validate call-agent source-ipaddr

mgcp fax t38 ecm

mgcp fax rate 14400

mgcp fax t38 ls_redundancy 2

mgcp fax t38 hs_redundancy 2

mgcp fax t38 gateway force

mgcp rtp payload-type g726r16 static

!

mgcp profile default

I'm starting to think the problem is in the WAN line, but it is not my responsability and I can't check it.The costumer don't want to finish the proyect until we fix it.

What do you recommend me to troubleshooting it?

Note. The calls are working well.

Edit: I gona try change the codec negociation between vgs regions and cm/branch regions to g711

Thank you

Regards

Highlighted
VIP Mentor

2911GW, mgcp and Fax issue.

As you can see this configuration is not going to help you. Fax can be a pain, but the right setup can deifnitely help.

I suggest you stick to ne thing and work through it. Do you want to use ATA? Th configuration requirements are different to right-fax. The config you posted above is not techinically right. Having T.38 and modem passthrough at the same time will create problems.

So let  me know what you want to go with. ATA or right fax.

ATA 186 and 188 supports only two mode of fax: fax pass-through mode and fax mode. The ATAs also need to e configured on cucm properly.

So if you want to stick with ATA, we can work through the configuration.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts
Highlighted

2911GW, mgcp and Fax issue.

Hi

Thank you for the answer

I'm using VG to connect the FAX no ATAs.

So some ddis go to right fax as this.

Primary E1----->gateway (branch)----->CUCM (headquater)----->sip---->right-fax (headquater)

Some ddis go to physical fax like this.

Primary E1----->gateway (branch)----->CUCM (headquater)----->VG 204 (branch)-----> FAX (Branch)

So every fax (to right-fax and VGs) have to through the branch gateway.

Which configuration do you need I should use?

Thank you.

Highlighted
VIP Mentor

Re: 2911GW, mgcp and Fax issue.

OK. Lets start with the Vg204 setup.

I suggest we use fax pass-through.

1. How is your VG204 configured in CUCM? Are you using SCCP? Is fax relay disabled on the sccp ports for the VG?

2. For fax pass-through to work we need to disable fax relay and fxr package on the gateway. So on your branch mgcp gateway you must have the ff:

mgcp modem pass-through voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability fxr-package----(This disables fxr package otherwise fax through mgcp gw will fail)

no mgcp default-package fxr-package---(This disables fxr package otherwise fax through mgcp gw will fail)

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit-----(This command disables T.38 and is needed for modem pass-through to work)

mgcp rtp payload-type g726r16 static

Pls configure your gateway as above.

Now place test fax call to the DDIs of the vg204 and send the ff: debug

Debug isdn q931

debug mgcp packet

debug voip vtsp all

debug voip rtp session named-event

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts
Highlighted

Re: 2911GW, mgcp and Fax issue.

Hi

Thank you very kind.

This is the VG configuration by mgcp

ccm-manager redundant-host 168.124.50.11

ccm-manager mgcp

ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 168.124.50.11 

ccm-manager config

ccm-manager sccp local FastEthernet0/0

!

mgcp

mgcp call-agent 168.124.50.12 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 ecm

mgcp fax t38 gateway force

mgcp rtp payload-type g726r16 static

!

mgcp profile default

Anythink to change?

Ok, I will try with your configuration, but the GW is very busy in working hours so the debugs will be big.

Thanks

Highlighted
VIP Mentor

2911GW, mgcp and Fax issue.

Yes, please adjust the config as below:

no ccm-manager fax protocol cisco

mgcp modem pass-through voip mode nse

no mgcp fax t38 ecm

no mgcp fax t38 gateway force

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts

View solution in original post

Highlighted
VIP Mentor

2911GW, mgcp and Fax issue.


Ensure you configure debugs to logg to buffer as follows:

logging buffered 10000000 debug
no logging console
no logging monitor

Then do a test with your debugs on. After you complete the test..

type.........sh loggin

Please try and put the debug in a text file and attach here..dont paste them so the thread is not too long

Please rate all useful posts
Highlighted

Re: 2911GW, mgcp and Fax issue.

For disable t38 inhibit I have to reset the mgcp connection it is enough with no mgcp, mgcp? o I have to reset the gw in the cucm?

Because I have to cut the service.

Thanks

Highlighted
VIP Mentor

2911GW, mgcp and Fax issue.

This is why I dont like MGCP. Yes you may need to do no mgcp/mgcp. And that will temporarily bring down the gateway. If you cant get a window to that right away. SConfigure the gateway and lets test. The debugs will show if T.38 is been negotiated. Ensure you reset the VG204

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts
CreatePlease to create content