cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
508
Views
0
Helpful
3
Replies
Highlighted
Beginner

2921 CME 10.5 with SIP endpoints Conference and Transfer issue

Hello,

I'd recently installed a 2921 SRST router with CME 10.5 and SIP endpoints.

Most of the SIP phones are 7821. 

I've 2 issues... let's say users A,B and C are making calls.

1) Conference is not working!  A called B; and pressing 'conference' button A again called C. Now when 'conference' button is pressed to put these A,B and C to be on conference, but not working. One is on hold. only one call is active at all time!

2) When A calls B and  B transfer this call to C, the caller ID on C is that of B. Even after B is transferred call and now call happening between A and C, on A's screen and C's screen the other party number is that of B. Here Transfer is working perfectly but Caller ID is not proper. Can we sort this?

 

I'm pasting the entire configuration below...

Appreciate your kind support. This is for first time I'm configuring for SIP endpoints other than SCCP.

Also, anybody can suggest a GUI tool to easily manage phones and extensions for this CME with SIP endpoints?

 

#Show run

 
Building configuration...
 
 
Current configuration : 28463 bytes
!
! Last configuration change at 18:25:00 Muscat Wed Jul 8 2015 by admin
! NVRAM config last updated at 18:25:02 Muscat Wed Jul 8 2015 by admin
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RTR2921
!
boot-start-marker
boot-end-marker
!
!
no logging buffered
enable password cisco
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
clock timezone Muscat 4 0
!
!
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 192.168.35.1 192.168.35.10
ip dhcp excluded-address 192.168.35.200 192.168.35.254
 --More--         !
ip dhcp pool VOICE
 network 192.168.35.0 255.255.255.0
 option 150 ip 192.168.35.1 
 default-router 192.168.35.1 
!
!
!
ip domain name adgroupho.ae
ip name-server 192.168.12.1
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
trunk group ALL_FXO
 max-retry 5
 voice-class cause-code 1
 hunt-scheme longest-idle
!
cts logging verbose
!
crypto pki trustpoint TP-self-signed-538078659
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-538078659
 revocation-check none
 rsakeypair TP-self-signed-538078659
!
!
crypto pki certificate chain TP-self-signed-538078659
 certificate self-signed 01
  30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030 
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 35333830 37383635 39301E17 0D313530 36323331 31333332 
  325A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F 
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3533 38303738 
  36353930 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100 
  EAC8DDC9 74AB6467 179A9DB9 911D3406 59D3DB67 F32DD8AF 24DF31E6 4C527733 
 --More--           289CF969 53838C02 C6827C1E B64A541C F673BD2C 26C6A117 B0212ABF D13D6E4A 
  14327357 FEC7CA91 91B597C9 69105137 3ADD387D B7863B2A 6FBD91F3 D23FF943 
  46764039 6CCD714C E0DD8DE3 36D30040 EE7DD369 21C153B6 D11AF790 F1D96FD9 
  02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D 
  23041830 16801479 DF3784AF D8C82B66 223D6989 4B39C8F4 41542230 1D060355 
  1D0E0416 041479DF 3784AFD8 C82B6622 3D69894B 39C8F441 5422300D 06092A86 
  4886F70D 01010505 00038181 00A5675D 1B9BB878 EB60F82A B94698B4 E940A4F8 
  A735D51F 0107432B 74F8B763 F858C278 DBC9D307 4130DB37 93AF18F2 8A47D5B8 
  18647D58 D46F178D 2F7C3F75 EBE89BF8 E21D5E05 BAAFCE2E 2A1D043D 2FEFEB30 
  5EA07501 D07B715E EFEFA3F4 819BF8EB 3C85905F 992C081A B8EB90E3 56C5C69E 
  B682D79F C5650E3B 98DD005C 2D
  quit
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
!
voice service voip
 no ip address trusted authenticate
 mode border-element license capacity 10
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  h225 h245-address on-connect
 sip
  bind control source-interface GigabitEthernet0/0
  bind media source-interface GigabitEthernet0/0
  registrar server
  no update-callerid
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
 codec preference 3 g711alaw
 codec preference 4 g729br8
!
!
!
 --More--         voice class dualtone-detect-params 1
 freq-max-deviation 20
 cadence-variation 20
!
voice class custom-cptone disconnect
 dualtone disconnect
  frequency 405
  cadence 400 345 230 520 400 245 230 520
 dualtone conference
  frequency 600 900
  cadence 300 150 300 100 300 50
!
!
voice register pool-type  8861
 phoneload-support
 num-lines 50
 addons 2
 description **Cisco 8861 SIP Phone**
!
voice register global
 mode  cme
 source-address 192.168.35.1 port 5060
 timeouts interdigit 2
 max-dn 100
 max-pool 100
 load 8861 sip88xx.10-2-1-16
 authenticate register
 timezone 35
 date-format D/M/Y
 call-forward system redirecting-expanded
 voicemail 2222
 tftp-path flash:
 create profile sync 0009560253473868
 conference hardware
 camera
 video
!
voice register dn  1
 number 201
 name Faisal H
 label Faisal Hamdan
!
voice register dn  2
 --More--          number 202
 name User2
 label User2
!
voice register dn  3
 number 203
 name Maher Y
 label Maher Yasin
!
 
### removed remaining dn config ###
 
!
voice register template  1
!
voice register pool  1
 busy-trigger-per-button 2
 id mac 204C.9EB3.2098
 type 7821
 number 1 dn 1
 dtmf-relay sip-kpml sip-notify
 username faisal password 12345
 codec g711ulaw
!
voice register pool  2
 busy-trigger-per-button 2
 id mac C472.95A8.9B8E
 type 7821
 number 1 dn 2
 dtmf-relay sip-kpml sip-notify
 username user2 password 12345
 codec g711ulaw
!
voice register pool  3
 busy-trigger-per-button 2
 id mac 204C.9EB3.5503
 --More--          type 7821
 number 1 dn 3
 dtmf-relay sip-kpml sip-notify
 username maher password 12345
 codec g711ulaw
!
### removed remaining similar pool config ### 
!
voice register pool  55
 busy-trigger-per-button 2
 id mac 204C.9E6C.05C5
 type 8945
 number 1 dn 55
 number 2 dn 59
 dtmf-relay rtp-nte
 username ceo password 12345
 description CEO
 codec g711ulaw
 camera
 video
!
 
!
voice register pool  100
 busy-trigger-per-button 1
 id mac 2834.A283.EFA5
 type 8861
 number 1 dn 100
 number 2 dn 91
 number 3 dn 92
 number 4 dn 93
 dtmf-relay sip-kpml sip-notify
 username ayaa password 12345
 codec g711ulaw
!
voice hunt-group 1 sequential
 list 200,291,292,293
 pilot 511 
!
!
voice logout-profile 1
 number 2001 type normal
!
voice user-profile 1
 user aaaa password 12345
 number 801 type normal
!
voice user-profile 2
 user bbbb password 12345
 number 802 type normal
!
voice user-profile 3
 user cccc password 12345
 number 803 type normal
!
 --More--         !
!
voice translation-rule 1000
 rule 1 /.*/ //
!
voice translation-rule 1112
 rule 1 /^9/ //
!
voice translation-rule 2001
!
voice translation-rule 2002
 rule 1 /^6/ //
!
voice translation-rule 2222
!
voice translation-rule 3247
 rule 1 /^7/ //
!
voice translation-rule 3248
 rule 1 /^8/ //
!
voice translation-rule 3249
 rule 1 /^\([0-9]\)/ /7\1/
!
voice translation-rule 3265
 rule 1 /^\([0-9]\)/ /9\1/
!
!
voice translation-profile CALLER_ID_TRANSLATION_PROFILE
 translate calling 1111
!
voice translation-profile CallBlocking
 translate called 2222
!
voice translation-profile OUTGOING_TRANSLATION_PROFILE
 translate called 1112
!
voice translation-profile XFER_TO_VM_PROFILE
 translate redirect-called 2002
!
voice translation-profile add7
 translate calling 3249
!
 --More--         voice translation-profile add9
 translate calling 3265
!
voice translation-profile nondialable
 translate called 1000
!
voice translation-profile remove7
 translate called 3247
!
voice translation-profile remove8
 translate called 3248
!
!
!
license udi pid CISCO2921/K9 sn FCZ1726618H
hw-module pvdm 0/0
!
!
!
username admin privilege 15 secret 5 $1$8EoT$Zq7tkCWCSSCHF
!
redundancy
!
!
no ip ftp passive
ip ssh time-out 60
!
!
!
!
interface Embedded-Service-Engine0/0
 ip unnumbered GigabitEthernet0/0
 service-module ip address 192.168.35.2 255.255.255.0
 service-module ip default-gateway 192.168.35.1
!
interface GigabitEthernet0/0
 description ***Connected to voice LAN***
 ip address 192.168.35.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description ***Connected to data LAN***
 --More--          ip address 192.168.12.20 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:
!
ip route 0.0.0.0 0.0.0.0 192.168.12.3
ip route 172.20.0.0 255.255.0.0 192.168.12.3
ip route 192.168.35.2 255.255.255.255 Embedded-Service-Engine0/0
!
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0
 translation-profile incoming add9
 supervisory disconnect dualtone mid-call
 supervisory custom-cptone disconnect
 supervisory dualtone-detect-params 1
 no battery-reversal
 input gain 3
 compand-type a-law
 cptone AE
 timeouts call-disconnect 0
 timeouts wait-release 1
 connection plar opx 249
 impedance complex1
 --More--          description Raffi_Direct_line
 caller-id enable
!
voice-port 0/0/1
 supervisory disconnect dualtone mid-call
 supervisory custom-cptone disconnect
 supervisory dualtone-detect-params 1
 no battery-reversal
 input gain 3
 compand-type a-law
 cptone AE
 timeouts call-disconnect 0
 timeouts wait-release 1
 connection plar opx 259
 impedance complex1
 description CEO_Direct_line
 caller-id enable
!
voice-port 0/0/2
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 supervisory custom-cptone disconnect
 supervisory dualtone-detect-params 1
 no battery-reversal
 input gain 3
 compand-type a-law
 cptone AE
 timeouts call-disconnect 0
 timeouts wait-release 1
 connection plar opx 511
 impedance complex1
 description etisalat_line1
 caller-id enable
!
voice-port 0/0/3
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 supervisory custom-cptone disconnect
 supervisory dualtone-detect-params 1
 no battery-reversal
 input gain 3
 compand-type a-law
 cptone AE
 --More--          timeouts call-disconnect 0
 timeouts wait-release 1
 connection plar opx 511
 impedance complex1
 description etisalat_line2
 caller-id enable
!
voice-port 0/1/0
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 supervisory custom-cptone disconnect
 supervisory dualtone-detect-params 1
 no battery-reversal
 input gain 3
 compand-type a-law
 cptone AE
 timeouts call-disconnect 0
 timeouts wait-release 1
 connection plar opx 511
 impedance complex1
 description etisalat_line3
 caller-id enable
!
voice-port 0/1/1
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 supervisory custom-cptone disconnect
 supervisory dualtone-detect-params 1
 no battery-reversal
 input gain 3
 compand-type a-law
 cptone AE
 timeouts call-disconnect 0
 timeouts wait-release 1
 connection plar opx 511
 impedance complex1
 description etisalat_line4
 caller-id enable
!
voice-port 0/1/2
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 supervisory custom-cptone disconnect
 --More--          supervisory dualtone-detect-params 1
 no battery-reversal
 input gain 3
 compand-type a-law
 cptone AE
 timeouts call-disconnect 0
 timeouts wait-release 1
 connection plar opx 511
 impedance complex1
 description etisalat_line5
 caller-id enable
!
voice-port 0/1/3
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 supervisory custom-cptone disconnect
 supervisory dualtone-detect-params 1
 no battery-reversal
 input gain 3
 compand-type a-law
 cptone AE
 timeouts call-disconnect 0
 timeouts wait-release 1
 connection plar opx 511
 impedance complex1
 description etisalat_line6
 caller-id enable
!
voice-port 0/2/0
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 supervisory custom-cptone disconnect
 supervisory dualtone-detect-params 1
 no battery-reversal
 input gain 3
 compand-type a-law
 cptone AE
 timeouts call-disconnect 0
 timeouts wait-release 1
 connection plar opx 511
 impedance complex1
 description etisalat_line7
 caller-id enable
 --More--         !
voice-port 0/2/1
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 supervisory custom-cptone disconnect
 supervisory dualtone-detect-params 1
 no battery-reversal
 input gain 3
 compand-type a-law
 cptone AE
 timeouts call-disconnect 0
 timeouts wait-release 1
 connection plar opx 511
 impedance complex1
 description etisalat_line8
 caller-id enable
!
voice-port 0/2/2
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 supervisory custom-cptone disconnect
 supervisory dualtone-detect-params 1
 no battery-reversal
 input gain 3
 compand-type a-law
 cptone AE
 timeouts call-disconnect 0
 timeouts wait-release 1
 connection plar opx 511
 impedance complex1
 description etisalat_line9
 caller-id enable
!
voice-port 0/2/3
 supervisory disconnect dualtone mid-call
 supervisory custom-cptone disconnect
 supervisory dualtone-detect-params 1
 no battery-reversal
 input gain 3
 compand-type a-law
 cptone AE
 timeouts call-disconnect 0
 timeouts wait-release 1
 --More--          connection plar opx 269
 impedance complex1
 description manager3_direct_line
 caller-id enable
 !
 !
 !
 !
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm 192.168.35.1 identifier 1 version 6.0 
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 1 register SC-CONF
!
!
!
dspfarm profile 1 conference  
 codec g729br8
 codec g729r8
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 codec ilbc
 associate application SCCP
 shutdown
!
dial-peer cor custom
 name internal
 name local
 name local-plus
 name international
 name national
 --More--          name national-plus
 name emergency
 name toll-free
 name raffiline
!
!
dial-peer cor list call-internal
 member internal
 member emergency
!
dial-peer cor list call-local
 member internal
 member local
 member emergency
 member toll-free
!
dial-peer cor list call-local-plus
 member internal
 member local
 member local-plus
 member emergency
 member toll-free
!
dial-peer cor list call-national
 member internal
 member local
 member local-plus
 member national
 member emergency
 member toll-free
!
dial-peer cor list call-national-plus
 member internal
 member local
 member local-plus
 member national
 member national-plus
 member emergency
 member toll-free
!
dial-peer cor list call-international
 member internal
 member local
 --More--          member local-plus
 member international
 member national
 member national-plus
 member emergency
 member toll-free
!
dial-peer cor list raffiline
 member raffiline
!
!
dial-peer voice 2222 voip
 description ***Voice Mail Pilot***
 destination-pattern 2222
 session protocol sipv2
 session target ipv4:192.168.35.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 2223 voip
 description ***AA Pilot***
 destination-pattern 2223
 session protocol sipv2
 session target ipv4:192.168.35.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 2224 voip
 description ***Promptmgmt Pilot***
 destination-pattern 2224
 session protocol sipv2
 session target ipv4:192.168.35.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 92 pots
 trunkgroup ALL_FXO
 corlist outgoing call-local
 description **CCA*UAE*dubai**
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
 --More--          preference 5
 destination-pattern 904.......
 forward-digits all
 no sip-register
!
dial-peer voice 93 pots
 trunkgroup ALL_FXO
 corlist outgoing call-local
 description **CCA*UAE*other*emirates**
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
 preference 5
 destination-pattern 90[236789].......
 forward-digits all
 no sip-register
!
dial-peer voice 94 pots
 trunkgroup ALL_FXO
 description **CCA*UAE*service**
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
 preference 5
 destination-pattern 9600T
 forward-digits all
 no sip-register
!
dial-peer voice 95 pots
 trunkgroup ALL_FXO
 description **CCA*UAE*tollfree**
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
 preference 5
 destination-pattern 9800T
 forward-digits all
 no sip-register
!
dial-peer voice 96 pots
 trunkgroup ALL_FXO
 corlist outgoing call-international
 description **CCA*UAE*isd**
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
 preference 1
 destination-pattern 900T
 forward-digits all
 no sip-register
!
 --More--         dial-peer voice 97 pots
 trunkgroup ALL_FXO
 corlist outgoing call-local
 description **CCA*UAE*LocalMob**
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
 preference 5
 destination-pattern 905........
 forward-digits all
 no sip-register
!
dial-peer voice 249 pots
 description ** incoming dial peer249 **
 port 0/0/0
!
dial-peer voice 70 pots
 description **Raffiline**
 translation-profile outgoing remove7
 preference 5
 destination-pattern 7T
 port 0/0/0
 forward-digits all
 no sip-register
!
dial-peer voice 71 pots
 corlist outgoing call-local
 description **CCA*Raffi*LocalMob**
 translation-profile outgoing remove7
 preference 5
 destination-pattern 705........
 port 0/0/0
 forward-digits all
 no sip-register
!
dial-peer voice 72 pots
 corlist outgoing call-local
 description **CCA*UAE**
 translation-profile outgoing remove7
 preference 5
 destination-pattern 70[2346789].......
 port 0/0/0
 forward-digits all
 no sip-register
!
 --More--         dial-peer voice 80 pots
 description **ceoline**
 translation-profile outgoing remove8
 preference 5
 destination-pattern 8T
 port 0/0/1
 forward-digits all
 no sip-register
!
dial-peer voice 81 pots
 corlist outgoing call-local
 description **CCA*ceo*LocalMob**
 translation-profile outgoing remove8
 preference 5
 destination-pattern 805........
 port 0/0/1
 forward-digits all
 no sip-register
!
dial-peer voice 82 pots
 corlist outgoing call-local
 description **CCA*ceoUAE**
 translation-profile outgoing remove8
 preference 5
 destination-pattern 80[2346789].......
 port 0/0/1
 forward-digits all
 no sip-register
!
dial-peer voice 1115 voip
 description ***Riyadh Ext.***
 destination-pattern 1...
 session target ipv4:172.20.0.1
 voice-class codec 1  
 dtmf-relay h245-alphanumeric
 no vad
!
dial-peer voice 1117 voip
 description ***Riyadh Ext.***
 preference 1
 destination-pattern 1...
 session target ipv4:172.20.0.1
 voice-class codec 1  
 --More--          dtmf-relay h245-alphanumeric
 no vad
!
dial-peer voice 91 pots
 trunkgroup ALL_FXO
 description **CCA*UAE*991**
 preference 3
 destination-pattern 99.
 forward-digits all
 no sip-register
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 conference hardware
 no auto-reg-ephone
 authentication credential admin cisco
 em keep-history
 em logout 21:0 
 max-ephones 100
 max-dn 200
 ip source-address 192.168.35.1 port 2000
 service phone webAccess 0
 system message CME
 time-zone 38
 date-format dd-mm-yy
 voicemail 2222
 max-conferences 8 gain -6
 web admin system name admin secret 5 $1$UPwN$ObUkHrEMIGf.nVRQwncgX.
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern .T
 secondary-dialtone 8
 create cnf-files version-stamp 7960 Jun 27 2015 18:58:43
!
 --More--         !
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 password cisco
 transport input telnet ssh
line vty 5 15
 privilege level 15
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server 104.209.134.106 source GigabitEthernet0/1
!
end
3 REPLIES 3
Highlighted
Frequent Contributor

try to do

 

conf t

dspfarm profile 1 conference  
no  shutdown

 

 

Highlighted
VIP Advisor

Your conference bridge is missing the maximum session config and it is turned off. You need to configure max sessions and bring it online.

dspfarm profile 1 conference  

 maximum sessions #

 no shutdown

 

Also, you are disabling caller-id update. You need to enable it.

 sip

  update-callerid

 

On a side note, do you need all these codecs for conferencing. You need to utilize you DSP resources more efficiently. If needed, then you can keep it.

Highlighted

Thank you for your support. I will check and will update you next day.

Content for Community-Ad