Showing results for 
Search instead for 
Did you mean: 

3PCC phones unable to resolve CLI with names in the LDAP

We have 3PCC CP-88XX phones.

Incoming calls are not resolved to the number stored in the address book (which would show the name) the issue is that LDAP reverse lookup does not work. This is basic functionality (CallerID) I do not understand why this would be a problem.


Accepted Solutions

The Guys fixed this for me with an engineering build last year. Publically accessible current versions are fine.



View solution in original post

Cisco Employee

What version of the 3pcc firmware is flashed on the phone? A PRT on the phone which has this issue would be helpful to diagnose. It can be taken from the phone webpage -> Info -> Debug Info -> Generate PRT




The problem is more than just LDAP:


The manual says here:


"Reverse name lookup searches the directories in the following order:
    Phone contacts => WORKS OK
    Call History => DOES NOT WORK
    Third-party Server Directory (BroadSoft, Asterisk, or MetaSphere) NOT TESTED
    LDAP Directory => DOES NOT WORK
    XML Directory => NOT TESTED




To create this PRT and test I have

1. factory reset

2. reprovisioned

3. made a simple LDAP lookup by pressing the directory button on the handset and making a search. This is so you can see that LDAP is working.

4. Make an outbound call to my cell, using LDAP as the lookup. This creates call history.

5. Made a call from my cell to the handset. Call arrives, but the handset does not carry out an LDAP lookup, or look in history.


PRT attached - needed to extract and rebuild as a tar, as this site does not allow uploading of .gz :-(




Hi Adam,


Can you please check if setting display attribute to following helps as a workaround for this issue?



Thank you.

Unfortunatly that did not work. I still can't see the phone reaching out to the LDAP server.


Your change makes all the different phone numbers for a contact, appear as a single entry as a comma separated list.



Ok. Thats for checking.


In this case I see that in the result both registeredAddress, telephoneNumber and mobile are all blank and the only tag with a proper number is homeTelephoneNumber. But "t=p" is being used for all the 4. And only the first numnber with "t=p" will be honored which in this case is blank.

So to make this work please change the Display Attribute to the following:



The other way out will be to add a number for all these other attributes


If even after these changes the lookup does not work, then please take another PRT with debug level set to DEBUG to analyze further. Setting debug level -> Voice->System->Optional Network Configuration->Debug Level





An excerpt from the documentation for reference:

When t=p, that is, t is of type phone number, the retrieved number can be dialed. Only one number can be made dialable. If two numbers are defined as dialable, only the first number is used. For example, a=ipPhone, t=p; a=mobile, t=p; This example results in only the IP Phone number being dialable and the mobile number is ignored.

Honestly Cisco?

No LDAP lookup??

LDAP lookup should be working fine. What's the firmware you are using?

The Guys fixed this for me with an engineering build last year. Publically accessible current versions are fine.



View solution in original post

We have the same problem incoming caller id id names are not showing on our XSI, LDAP, or XML directories. 


I'm happy if this works on LDAP or XSI. 


I'm currently testing on an 8865 with this firmware:




How can I fix?


Try the newer firmware. It's 11.3.1MSR1.3

Thank you, I tried that firmware and I'm still having the same problem.

Neither XSI or LDAP contact names are recognised on incoming calls.

Is this a known issue or am I the only one?

Reverse Lookup using XSI will be part of a future release. As for LDAP there have been some bug fixes around it.

You can reach out to Small Business Support team and raise a case and they should share the latest build with you.


This used to be an issue but it has been repaired.

Under phone tab/ldap section set:-

Search item 3: Number

Search Item 3 Filter:telephoneNumber


and you should be good.


Its possible that if your SIP invite already has a description set then incoming lookup might be disabled.

I can remember Cisco asking me to try removing that as part of the initial investigation and we removed that, but haven't tried reinstating since the ldap fix came through.

From: "TryRemovingThisDescription" <>;tag=82ef1c63f8873f1o0


Thank you very much for your help, I tried:


Search item 3: Number

Search Item 3 Filter:telephoneNumber


But the issue persists. I can call contacts that are on the LDAP directory and it shows the contact name when I call them, but on incoming calls, it still only shows the number! No name.


I have tried to open a case but Cisco are saying that I don't have support against the serial? I have contacted the phone distributor see if they can help. If anyone has any other ideas please let me know?

Recognize Your Peers
Content for Community-Ad