cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1595
Views
35
Helpful
5
Replies

3rd Party SIP Wi-Fi Phone Registration to CUCM Issues

paul.higgsboyo
Beginner
Beginner

Hi all, a customer of mine is looking to replace a load of DECT devices and doesnt want the expense of Cisco 792x phones so has sourced a SIP-WiFi by a company called Incom, an ICW-1000G. I have the device on the WiFi and can ping the CUCM servers but the 3rd Party SIP device for it shows as unregistered in CUCM. The phone itself doesnt give any errors (it did do before I changed the digest user to an account who's userID is all numerical and the password a word). CallManager version is 8.6 which will be upgraded to 10.5 over this coming weekend. Has anyone had any experience of one of these devices and managed to get it to work?

5 Replies 5

dsobrinho
Engager
Engager

Hi Paul.higgsboyo@,
 

Normally  a 3rd Party SIP devices only need a User ID (Created manually in CUCM or via LDAP directory Synch) and a digest user and password (numeric).

These devices have web interface where these credentials will be inserted. So, the mac address is not important for 3rd Party , but the User ID and Credential are very important.


In cucm 8.6 3rd Party SIP need licensing DLU, for version of CUCM 10.5 Licensing is different, need check which type of lic will be needed.

 

Best regards,

Daniel Sobrinho

Daniel Sobrinho

Hi Daniel,

 

Thanks for your reply.

 

There are plenty of spare DLUs on the system so this wont be an issue. 3rd party SIP devices need their MAC address entered otherwise you cant add them to CUCM database so I have the phones MAC in there. The userID I'm using as the digest user is 69999 and I have tried the passwords "password" and "13579". Initially, when I was using a userID with alphnumerics the device was being shown as rejected and the phone reported that it was unable to find the user account. Since changing userID to 69999 I'm now seeing it an unregistered so it looks as if the registration attempt has been made and accepted by the CallManager but not held up by the phone. Perhaps the phone needs a firmware upgrade from the manufacturer but as yet they havent come back to me.

 

Hi,

 

Yes, you are rigth, you need some reference to CUCM database, but, for 3rd  Party SIP you can use Dummy Mac Address if you want. So, share the internal config of the device in CUCM and interface Web of Phone (SIP and LINE).

 

Try to do this:

 

The following CUCM administration tasks to prepare the CUCM for connecting a 3rd Party SIP Phone are described in detail:

1. Define a CUCM user that will be associated with the Phone Line1
2. Define a third-party SIP phone for the  Phone Line1
3. Associate a Line / DN (directory number) to the previously defined Phone Line1 third-party SIP device
4. Associate the Phone Line1 user with the Line1 third-party SIP device.

 

 

Navigate to Voice tab > Line 1 tab:


i. SIP Settings > SIP Transport: TCP/ or UDP
ii. Proxy and Registration: Proxy: <IP ADDRESS> [CUCM IP address]
iii. Subscriber Information:
1. User ID: 666698
2. Password: 666698
3. Use Auth ID: yes
4. Auth ID: 666698

 

In the Line 1 inside DN. Associate the Line to User ID

 

Best regards,
Daniel Sobrinho

 

 

Daniel Sobrinho

This fixed my issue with being able to register the phone with CCM, however i can't get audio on a call. If I dial the device from a 79 series phone the device will ring but when you accept the call on the wireless phone you just get a fast busy on the 79 series. 

Any ideas?

Hi tshounpriceit, apologies if you have already done but do make sure you are on ICW-1000G firmware ver 1.0.7 (attached). I will raise the issue with Incom about 7925G to ICW-1000G not working. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: