Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

7800 (7821,7841,7861) and Possible Other Cisco SIP Phone Models - Slow / Lagging DTMF Dialing - Appears Firmware Related

Hello All,

I'm trying to drum up support to get Cisco to identify and fix lagging DTMF issues in various Cisco SIP phones. I've mainly been working with 7800 series phones lately (with both CME and CUCM). The lag issue primarily appears when users have to enter a sequence of digits after their call is connected. For example, logging into voicemail, interacting with IVR systems, entering PIN codes, conference bridge codes, etc. The issue is that the phones start lagging in responding to button presses, causing end users to enter the wrong digits or the wrong digits being sent to the system they're interacting with. I've verified with debugging that the problem appears phone firmware related, as there is delays in the actual digits being received by the call control device.

Has anyone else noticed this issue? Just place a call, and enter several sequences of digits rapidly (for example, 123456789*0#). You will notice the phone seems to buffer button pushes, and delays in the phone giving a confirmation beep (or the actual DTMF tone if you are using the handset) back. Also, the issue seems to be worse when using a handset vs speakerphone, and when there is audio being received on the phone.


Getting reports from users with same issue. CME 10.5 and 7800 series phones running 10-2-1-12SR1-4

Thanks Michael. I'm working with a customer that is using CME 10.5 and the same firmware as well. I opened case 634102069 on it if we want to start building and linking cases on this issue. We tried ES4 firmware, but the issue still existed, and the settings button on the phone didn't work in ES4.

I also did a large CUCM install this summer and noticed the issue myself, however that customer mostly receives calls, and doesn't do a lot of outbound dialing.  A coworker of mine is working on an extremely large CUCM install and opened a case several days ago with users of 8945 phones reporting "sluggish" dialing. I've been trying to get them to hurry up and get some more information on it, but it's low on their priority list. That case number is 634097751. That may or may not end up being the same issue, but I'm sure the 8945's share some of the same code as the 7800 series phones.

Any resolution from TAC? I'll likely be opening a similar case today.


They said there's a new firmware release coming out in the next 2 weeks. We're hoping it's fixed in it, but I'm doubtful. Also for the 8900 and 9900 series phone, there is an issue where you have to change the new simplified call ui option in CUCM or else initial dialing is slow while the phone does a directory lookup after each digit pressed. The issue with the 7800 series phones is different from this.

Just an update on this - I installed firmware 10.3(1) (just released) yesterday at one site with these phones and with a brief check, it looks like Cisco snuck in or inadvertently added a fix for the slow/delayed dialing issue! I will have more feedback today. 

Hey darren360,

Appreciate the info on 10.3(1).

I have seen the issue intermittently on 8945s as well.  Not able to duplicate it this morning, but its there.

You're welcome. I can confirm that the 10.3(1) firmware definitely corrected the issue with lag in pressing DTMF buttons.

One note on the 8945's if you're experiencing slow dialing (but not while on a call) is that there is a bug with what's called the "Call Log Filter Enhancement" which does a lookup in the call history as you enter digits (similar to a cell phone) that causes lag. You can get around it by enable "Simplified New Call UI" in the phone settings. I would open a TAC case too if there isn't a bug ID on this yet so that Cisco is made aware of how many people are experiencing the issue.




Restarting the phone seems to help temporarily, but I still have the issue on our 7841 phones. We have tried sip78xx.11-5-1-18 and just loaded sip78xx.11-5-1SR1-1 to test. 

It almost seems like a memory leak or something.  The phones are fine after a restart, but a few weeks later they are unbearably slow. 

restarting the phones seems to help, well a physical power down of the phones does help. issue will come back after a few months.


Content for Community-Ad

Spotlight Awards 2021