cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
374
Views
0
Helpful
5
Replies
Highlighted
Beginner

7921 new firmware version issue

Hi all,

We had a Cisco Call Manager version 4.3, upgraded to 8.6.2.

On the other hand, we had some 7921G phones registered and working fine with firmware version 1.1.1.

One of the 7921 broke down and we replaced it by a new one with firmware version 4.1.6.3.

This new phone doesn't work. It registers and seems to work fine the first time it connects to the AP (AP1131 with IOS 12.4(3g)JA1) but when the user moves through the site, and the phone roams between APs, the phone gets unregistered status and doesn't register again, even if it goes back to the first AP where it was registered.

I know it's not possible to downgrade the firmware version to 1.1.1 (it's working in the other 7921 phones), so I'm not pretty sure if the issue is due to the phone firmware version, or the AP's IOS or configuration, or something in the Call Manager.

These phones haven't Cisco warranty anymore, so I can't open a TAC case. I've been searching in this community and googling about similar issues but without success.

If anyone could guide me I would appreciate...

Thank you very much, kind regards.

Marti.

 

Everyone's tags (6)
5 REPLIES 5
Highlighted
Rising star

Hi,Try upgrading the firmware

Hi,

Try upgrading the firmware to the following:

https://software.cisco.com/download/release.html?mdfid=280808676&softwareid=282074289&os=&release=1.4%286%29&relind=AVAILABLE&rellifecycle=&reltype=latest&i=!pp

 

Let us know if the issue persists.

Regards

Highlighted
Beginner

Hi Samuel,This is the

Hi Samuel,

This is the firmware that I have (1.4.6.3). Sorry, I wrote 4.1.6.3, but it's 1.4.6.3.

Thank you.

Marti.

Highlighted
Rising star

One more question, before the

One more question, before the upgrade how was the 7921 behaving?

The underlying Wireless Infra could explain a lot with the call drop issues, however if you say, these phones have issues registering back with the CCM, once they have roamed out of the Wireless area, that sounds bit unusual.

 

Highlighted
Beginner

The new 7921G never worked,

The new 7921G never worked, it had 1.4.5 firmware version, and as I thought it may be a firmware issue I updated it to 1.4.6.3 version.

But as I told, only phones with firmware version 1.1.1 are working now.

My wireless infrastructure consists in 9 autonomous 1131 APs. All the site is well covered with those APs, phones with 1.1.1 firmware version are doing roaming between APs without problems. Only the phones with firmware version 1.4.x are having problems when roaming. 

I've tested it in several ways:

1. Upgrading a working 7921 phone with version 1.1.1 to 1.4.6.3. Doesn't work.

2. New 7921 phone with version 1.4.6.3. Doesn't work.

3. New 7921 phone with version 1.4.5. doesn't work. Upgraded to 1.4.6.3. Doesn't work.

 

Highlighted
Hall of Fame Community Legend

The new 7921G never worked,

The new 7921G never worked, it had 1.4.5 firmware version, and as I thought it may be a firmware issue I updated it to 1.4.6.3 version.

But as I told, only phones with firmware version 1.1.1 are working now.

I recommend you stick with firmwares 1.4(6) because this firmware has MAJOR roaming improvements compared to the 1.1 versions.  


Another thing, the old version you're currently running is just an interim version.  It was NOT designed to be put into production running with that old version as it was meant entirely to get the customer "over the line" and the CUCM manager to upgrade to a more stable and reliable firmware. 

 

If you can't get firmware 1.4(6) to work, you will need more information what is broken.  I am suspecting your wireless is breaking.