cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
3566
Views
0
Helpful
6
Replies
counseledu
Beginner

7960 Cannot Receive Calls

I have a Cisco 7960 IP phone that can send calls with no issue, but it cannot receive calls. I tried port forwarding port 5060 and it doesn't make a difference. I have also turned off SIP ALG and that didn't make a difference either. Since the VoIP control port and the proxy port on the 7960 are set to 5060, that should mean it is listening on port 5060 which is the port that I made the port forwarding rule for ( I tried both UDP and TCP but neither made a difference.). NAT on the phone is on. I can send and receive calls with no issue when using a softphone. I am running SIP firmware version 8-12. All incoming calls to the 7960 go straight to voicemail. I am at a loss at what else I need to address.

My hardware setup is as follows: 

Internet feed goes to the modem (The modem is just a modem and not a modem/router device.)

The modem is connected to a wireless router.

The 7960 is connected to the wireless router. (This router is where I created the port forwarding rule and also toggled the SIP ALG.)

6 REPLIES 6
HARIS_HUSSAIN
Rising star

Dear 

Where is 7960 registered to CUCM, CUCME ?

Is you phone registered over expressway? May be you have to check if ports are opened ?

Thanks

Haris

Hi,

Thank you for the response. This phone is not connected to CUCM/CUCME. It is connected to the server of a VoIP provider. The VoIP provider gives me the SIP credentials so I can connect to their server and receive service. I input the credentials and the phone can connect as well as send calls but not receive calls. I'm not sure how to answer the expressway question. 

SwathyEdayath
Beginner

Hi, I have the same problem in our network . did u resolve the issue.

I unfortunately was not able to solve the issue. I thought the problem may have had to do with port forwarding or SIP ALG, but those were ruled out. I narrowed the problem down to the phone itself. There is something in the settings that is keeping the phone from receiving calls. I used a different brand of IP phones on my network and they both send and receive calls with no issue but those phones are brand new and current. The latest SIP firmware version for the 7960 is 8.11, which requires a SmartNet entitlement. However, this firmware version is about eight years old now. Additionally, the phone itself is over eight years old. The age of the phone could play as a major factor in the problem regarding receiving calls. Everyone I know of that is still using a 7960 or similar model is using it on SCCP firmware. There never really was much support for the SIP firmware platform on these phones when compared to SCCP and MGCP. I put my 7960 on the side and hope to find out one day what specifically causes the receiving calls problem. You would need to look to the settings on the XML configuration file and use a TFTP server to transfer them to the phone, but I don't know of any settings on the XML configuration file that can solve the problem. Most of the pertinent settings are accessible directly through the phone. I have brought this issue up on other forums, but I didn't receive any responses that lead to a resolution. If I ever find a solution to this issue or at the least the specifics as to the problem, then I will post the answer here. 

Hi, Finally it has given a temporary solution . The problem was that TCP three way hand shake not happening . Hence the communication problem . Created a new phone security profile with transport type only as UDP , which resolved the issue.

May I know how do you create a security profile for this one?

Create
Recognize Your Peers
Content for Community-Ad