cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

11536
Views
38
Helpful
28
Replies
Davidwagman1
Rising star

7970 won't register

I've googled this to death and can't find a solution, I'm hoping that someone here can point me in the right direction.

I have a 7970 hooked up to call manager express 8.0 running on a 2851. The 7970 will register only if set to factory defaults each time. Once its registered, and then its reset, it goes to the updating screen and errors out, or sits at registration and never connects up. This started when I tried to fix the clock on the 7970.

So, in trying to fix this I downloaded the latest firmware for the 7970 (sccp 9-2-3TH1-9), tftped the term70.default.loads and the other files to the flash and gave the load 7970 term70.default.loads.

I get the following error:

Updating CNF files

CNF-FILES: Clock is not set or synchronized, retaining old versionStamps

CNF files update complete for phonetype(7970)

The clock is set, and I have NTP in there, which doesn't seem to be working properly. I also tried removing the NTP, same results.

CME#sh clock

*21:18:49.104 EDT Wed May 16 2012

CME#sh calendar

21:18:53 EDT Wed May 16 2012

CME#

My config is here.

Any help would be greatly appreciated.

Best,

David

2 ACCEPTED SOLUTIONS

Accepted Solutions

David,

You need to download the whole 8-5-3S firmware needed, not just the default loads.

Here are the files you need. Download then if you dont have them and use the file in * on your load command with the .loads extension

apps70.8-5-3TH1-6.sbn

cnu70.8-5-3TH1-6.sbn

cvm70sccp.8-5-3TH1-6.sbn

dsp70.8-5-3TH1-6.sbn

jar70sccp.8-5-3TH1-6.sbn

SCCP70.8-5-3S.loads*

term70.default.loads

term71.default.loads

Please rate all useful posts

View solution in original post

A few years ago I had a similar problem with time on some phones and using an ephone-template fixed it.

ephone-template  1

type 7970

ephone 1

ephone-template 1

Then reset the phone.

View solution in original post

28 REPLIES 28
paolo bevilacqua
Hall of Fame Master

Two separate issues.

One, check you ntp server. eg  0.us.pool.ntp.org

Second, configure the actual .loads file as load. Never configure term.default.loads.

Thanks for the reply Paolo.  I'm used to seeing the loads as TERM, but should I point it to SCCP70.9-2-3S.loads? That was the only other non-default .loads in the zip I got from the download.

Correct. And configure cnf-files location flash so the tftp bindings are created automatically.

Please remember to rate useful posts clicking on the stars below.

Thanks again for the reply.

I think I figured out the clock issue, I'm not getting the clock error anymore. I don't follow re: the cnf-files location. Do I have to give it

  • ip source-address
  • cnf-file location flash:

Do you put it right to flash or in to the its or its/vrf1 folder? Do you need to add it to the tftp server list?

No luck with the following, the phones spinning @ registering:

CME(config-telephony)#load 7970 SCCP70.9-2-3S.loads

Updating CNF files

CNF files update complete for phonetype(7970)

CME(config-telephony)#create cnf-files

Creating CNF files

CME(config-telephony)#

Thanks for your help.

Best,

David

If the phones doesn't register, means it's not configure as ephone with its right mac address.

Also, don't include the ".loads" on your load statments.

It should look like this:

load 7970 SCCP70.9-2-3S

NOT:

load 7970 SCCP70.9-2-3S.loads

This applies to all load statements.

HTH

Gregory Garrian wrote:

Also, don't include the ".loads" on your load statments.

It should look like this:

load 7970 SCCP70.9-2-3S

NOT:

load 7970 SCCP70.9-2-3S.loads

This applies to all load statements.

HTH

N,t that's not correct anymore.

.loads should be included as it save from configuring the tftp stamente manually.

I can point you to the documentation if you desire.

The phone does register, but only after a factory reset - every time. If the phone gets unplugged, etc, it will spin at registering and never connect. If I hold # and clear it, the phone will register properly and is usable.

!
ephone  1
 mac-address 0019.30D4.D369
 username "user1"
 type 7970
 button  1:1 2:5 3:6 4:30
!

If I go into Status->Status Messages on the 7970, there are a few errors: Error Updating Locale (which I understand is normal when you're in the US), and SEP001930D4D369.cnf.xml (which is the phone's MAC)

Thanks for the help

No errors. You can take on router, "debug tftp event" with term mon.

Other than tha check voice vlans. Is this your only phone and you doing a lab for study ?

Its just the 7970 that does't want to play nice. I have a 7960 and 7940 that are registering fine, but I understand thats a different load than the 7970.

I'll let you know what the tftp debug reveals

TFTP Event debugging is on

CME#

May 17 18:24:19.114: TFTP: Looking for CTLSEP001930D4D369.tlv

May 17 18:24:19.226: TFTP: Looking for ITLSEP001930D4D369.tlv

May 17 18:24:19.330: TFTP: Looking for ITLFile.tlv

May 17 18:24:19.626: TFTP: Looking for SEP001930D4D369.cnf.xml

May 17 18:24:19.638: TFTP: Opened flash:/its/vrf1/XMLDefault7970.cnf.xml, fd 10, size 1307 for process 216

May 17 18:24:19.646: TFTP: Finished flash:/its/vrf1/XMLDefault7970.cnf.xml, time 00:00:00 for process 216

May 17 18:24:23.066: TFTP: Looking for English_United_States/td-sccp.jar

May 17 18:24:25.010: TFTP: Looking for United_States/g3-tones.xml

right now the 7970 only has the date and time (incorrect), nothing else on the screen after it went through configuring IP and registering with no success.

Maybe the phone firmware is too new and cause registration to fail, in that case you can try updating IOS.

David,

The problem you are experinecing is likely that the firmware on the 7970 at the moment cannot upgrade to the firmware on the CME router. You need to download an intermediary firmware before you then upgrade to 9-2-3. You can try using firmware 8-5 first and then you can then upgrade it

+++Here is the release note for 9.2 Formware+++

Firmware Upgrade Issues for SCCP


Note For all SCCP firmware upgrades from firmware release versions earlier than 8.3(3) to version 9.2(1) or greater, you must first upgrade your firmware to an intermediate version (8.3(3) - 8.5(2)) then upgrade to 9.2(1).


      

From the release note

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/firmware/9_2_1/english/release/notes/7900_921.html#wp42493

Please rate all useful posts

Thanks for the help, I appreciate it.

The load that was originally on here was 8-5-3S. So, I figured I would go back to that and save 9 for a later time. I changed the default loads back to the 8, gave it loads 7970 SCCP8-5-3S.loads, created new cnf-files, then plugged it back in. Now the phone shows updating the term70.defaults file, flashes a blue screen, and sits at the cisco screen with the bullseye.

I'm hesitant to upgrade the IOS as I don't want to mess with CME and Unity that are on the 2851, or deal with the licensing headache that I think results from the upgrade.

Content for Community-Ad