cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
388
Views
0
Helpful
10
Replies

Addig prefix digit to incoming CLID

Hi all!!

Can someone help me?

I have na CUCM 11 with 88XX sets and a 2911 gateway with a PRI connection.

I need to prefix 0 to all external incoming calls so the users can use the miss cal list and reply to the number.

I created a partition and a calling serarche space for this, then I created a calling party transformation pattern with XXXXXXXXX and put the prefix with 0 on the calling party transformation, then I went to the gateway port and on the Incoming calling party settings under calling serach space I put the css created before and removed the tick from the use device pool css.

When I receive a cal the system still does not change the clid.

I even tried this info below with no luck:

http://www.cisco.com/c/en/us/support/docs/voice-unified-communications/unified-communications-manager-callmanager/68223-digit2.HTML

What it's happening? Can anyone give me a clue?

I have this working on CUCM 9.

Best Regards, 

10 Replies 10

Deepak Rawat
Cisco Employee
Cisco Employee

Configuration looks good, did you try resetting the gateway after performing above. Also verify again that what you are writing, the same had been configured that way as well. Lot many times, it happens to me so worth checking again.

Regards

Deepak

Hi!! Yes I reset the gateway after changing the configuration. Dont understand what you are tring to say "Also verify again that what you are writing, the same had been configured that way as well "

Please see attached config.

Best Regards,

Can you verify all incoming calls ANI is of 10 digits? Otherwise instead of 10 digits pattern, create pattern as ! and add prefix 0, see if it works for you. - Vivek

Hi!!!!

It's working after making no mgcp and mgcp.

Thanks all for the Support.

This is odd mas worked!! :(

:)

Hmm.. MGCP, h323 does not give that level of pain :)

- Vivek

Jose you forgot and we all forgot to ask what type of gateway you were using. This is an old trick with mgcp. Any change must be accompanied by the old faithful.. No mgcp, mgcp.

Please rate all useful posts

Deleted

Please rate all useful posts

Hi!!

Sorry for not answering. No I didnt apply to the phone. I applied to the gateway port . I will test and then I will reply to you, again.

Thanks for your help.

Best Regards,

Jose,

I am sorry I have interpreted your requests incorrectly. Applying calling part css on the phone only localizes the ANI..This should be done at the gateway as you have done..

Can you send us CUCM logs please

Please rate all useful posts

Deleted

Please rate all useful posts
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers