cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1324
Views
5
Helpful
4
Replies

AS5400 one-way audio

aemcomcco
Beginner
Beginner

Hi Experts, I've a strange issue and any help is appreciated.


I've used three AS5400 in different ways:
- H.323 gateway
- SIP gateway
- MGCP gateway controlled by PGW (current scenario)

I've loaded different IOS during years but in all these environments I had always same SPE version (np.0.10.9.0.spe) and same issue.

In some calls my customers have one-way audio.

This problem is present only during incoming calls.
I've no NAT and IP routing is ok.
I've no codec negotiation problem.
The problem is indipended by customer CPEs. Is present with devices of different vendors (cisco ATA18x, Linksys SPA2102, Innovaphone, etc).

I've captured a problematic call with wireshark.


I notice two RTP flows, one from AS5400 to IP network and one in the opposite direction. 
RTP stream from IP device to AS5400 is correct (in wireshark you can listen the audio), but the RTP from AS5400 doesn't contain voice (wireshark plays only silence).

I've saved the audio trace and I've amplified the volume with Audacity.
After this manipulation you can hear the voice (see attachments).

Can be a DSP problem?

Regards.

4 REPLIES 4

frlindse
Cisco Employee
Cisco Employee

Hi,

The only way to be sure would be to do a PCM capture from the TDM side to see what you are getting from the service provider.  Here is the procedure.

PCM-Dump Procedure

Here is the procedure:

Add to config:
voice hpi capture destination flash:pcm.dat                
voice hpi capture buffer 5000000

Then check for incoming call:
UK-CV-2620XM-2#sh voice call summary
PORT           CODEC    VAD VTSP STATE            VPM STATE
============== ======== === ==================== ======================
1/0/0.1       g729r8    y  S_CONNECT             S_TSP_CONNECT      
   
Or

UK-CV-2620XM-2#sh voice port summary
                                    IN       OUT
PORT      CH   SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
========= == ============ ===== ==== ======== ======== ==
1/0/0     1   bri-voice   up    up   none     none     y
1/0/0     2   bri-voice   up    dorm none     none     y

So the call is on B-chan 1 of port 1/0/0

Start the capturing:

test voice port 1/0/0.1 pcm-dump caplog 7

Stop the pcm capturing:

test voice port 1/0/0.1 pcm-dump disable

Then

no voice hpi capture destination flash:pcm.dat

Upload the dat file to the case an I can decode it.  SPE 10.9 is the latest that I see, and there are no known issues like this.

Thanks

Frank

Hi, I've followed your instructions but I don't find the command to start pcm-dump.

This is the problematic call:

E0D  : 784472 1703794570ms.1 +0 pid:0 Originate  connecting
dur 00:07:24 tx:22081/3532960 rx:22095/3535200
IP 10.35.0.199:23142 SRTP: off rtt:1ms pl:425000/0ms lost:0/3/0 delay:160/155/175ms g711alaw TextRelay: off
media inactive detected:n media contrl rcvd:n/a timestamp:n/a
long duration call detected:n long duration call duration:n/a timestamp:n/a

E0D  : 784471 1703794570ms.2 +0 pid:0 Originate  active
dur 00:07:24 tx:22088/3533240 rx:22084/3533440
Tele 7/4:0 (784471) [7/4.15] tx:444460/1000/0ms g711alaw noise:-83 acom:50  i/0:-30/-16 dBm


I execute these command:

voice hpi capture destination flash:pcm.dat
voice hpi capture buffer 5000000


but when I try to use the next one, I got an error:

C5400-VoiceGW-01#test voice port 7/4:15 pcm-dump caplog 7
                            ^
% Invalid input detected at '^' marker.

C5400-VoiceGW-01#test voice ?
  class             Test voice class commands
  translation-rule  Test translation rule mechanism

C5400-VoiceGW-01#

Currently I use the IOS version c5400-is-mz.124-15.T15.bin

Can you give me the correct procedure?


Thanks in advance.

I've recently found this post on cisco support community about AS5400 one way audio problem:

... "no voice session-handle enable" is a hidden command to revert to behavior before CSCsg52095.

It was introduced with CSCsr60092, and changes some flag behavior at the DSP level in scenarios where packet generation is stopped and then resumed.

The fix was verified with 5 people hitting the issue.

So make sure you're running 12.4(15)T15, using the stock DSPware, and have 'no voice session-handle enable' and you should be good to go.

Execute "service internal" and after "no voice session-handle enable".

I've applied the hidden command and the problem seems fixed.

Can anyone give me more informations about this hidden command and related bugs?

Regards.

We have some news:

- after many years I've changed the TDM provider without fix the problem

- the problem regards about 2% of both incoming and outgoing calls, so it is indipendent from direction of the call

- the audio issue is always in the call leg from TDM to IP side

- we observed this strange issue on all AS5400HPX gateway (3 different gateway with different IP address and bought in different period)

- a bidirectional RTP flow is always estabilished

- the problematic RTP flow from TDM to IP have always the same volume level: -24,4 dBm

- the wireshark audio trace shows only noise but if I increase the volume I can hear the voice (see original attachments)

- it happens on different DSP slot

So the problem is in the AS5400. Can be a configuration problem or an IOS - DSP bug?

Do you have any suggestions?

Best Regards.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: