cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

2950
Views
0
Helpful
12
Replies
Beginner

AT&T --- CUBE --- CUCM

I am having problems getting calls across CUBE. AT&T calls are arriving to CUBE but CUBE is not sending the calls to CUCM. The same from CUCM getting to CUBE but CUBE not sending to AT&T.

 

Ive been trying different configurations with the dial peers with no success.

 

Any help will be greatly appreciated.

 

CUCM IP is 

CUBE IP is 

ATT IP is 

 

My current run conf is:


Building configuration...


Current configuration : 6066 bytes
!
! Last configuration change at 22:59:34 Caracas Thu Feb 16 2017 by admin
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname localhost
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
enable secret 5 $1$r9QL$i80izReXxRd1i375cw0lY.
enable password password
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
aaa authorization network default local
!
!
!
!
!
!
aaa session-id common
clock timezone Caracas -4 0
!
!
!
!
!
!
!
!
!
!
!


ip name-server 8.8.8.8

ip domain name localhost.local
!
!
!
!
!
!
!
!
!
!
subscriber templating
multilink bundle-name authenticated
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-937083921
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-937083921
revocation-check none
rsakeypair TP-self-signed-937083921
!
!
crypto pki certificate chain TP-self-signed-937083921
certificate self-signed 01
30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 39333730 38333932 31301E17 0D313730 32303432 31313531
355A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3933 37303833
39323130 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
E6FBD1F7 0AC10608 29AFB8ED FF4C02FB 9DCED0CE 8F79D09D 8DBA6E82 E59DAFE9
A73CDE0C C906CC80 537A05E1 7E6668EA 6C26D979 1088F1CA 78CD34EC 1E746945
00E4DF67 3D24D488 8045DE53 90529758 8F607301 53C56E4D 545D7BF0 898CFFF5
FE631E87 28167BDA 22E4D940 100A60DB B276A2D5 0B55C7C1 BDE3E417 B06A8517
02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D
23041830 168014CA C9F06A29 A510294D 3327412B 32F98674 CE3A0930 1D060355
1D0E0416 0414CAC9 F06A29A5 10294D33 27412B32 F98674CE 3A09300D 06092A86
4886F70D 01010505 00038181 00667401 7D32E0DD 38CB5A01 8607B29A DF74AEC4
C16C33C0 E597EBBC 722CA143 0794097D 87C7D145 EADA9D0E 8E63F8C8 40C1F70D
D8D9086B 90C4BE5C CB21A396 D5ED4057 D2F64539 80F912D1 1001A8EA 8A56BC05
55B676DE EC6286BE 4E16971A 6A056C96 14CD2701 7469217D D7D27F3E 2D416814
48A05D0E 8ABA3D25 42CB4CEE 76
quit
!
!
voice service voip
ip address trusted list
ipv4 
ipv4 
ipv4 
ipv4 
ip address trusted call-block cause not-in-cug
mode border-element
media disable-detailed-stats
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip handle-replaces
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g729br8
codec preference 3 g711ulaw
codec preference 4 g711alaw
!
!
!
!
!
!
voice translation-rule 1
rule 1 // /225/
!
!
voice translation-profile 1
translate called 1
!
!
!
!
voice-card 0/1
no watchdog
!
license udi pid ISR4321/K9 sn FDO21020LSK
!
spanning-tree extend system-id
!
username admin privilege 15 password 0 password
!
redundancy
mode none
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface GigabitEthernet0/0/0
no ip address
negotiation auto
!
interface GigabitEthernet0/0/0.1
description VOICE
encapsulation dot1Q 10
ip address  255.255.255.0
!
interface GigabitEthernet0/0/1
description ATT
ip address  255.255.255.0
negotiation auto
!
interface Service-Engine0/1/0
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
shutdown
negotiation auto
!
interface Vlan1
no ip address
shutdown
!
ip forward-protocol nd
ip http server
ip http authentication aaa
ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route 0.0.0.0 0.0.0.0 
!
!
!
snmp-server community public RO
!
!
!
!
control-plane
!
call threshold global cpu-avg low 68 high 75
call threshold global total-mem low 75 high 85
call threshold global total-calls low 20 high 23
!
voice-port 0/1/0
!
voice-port 0/1/1
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 1 voip
description CUBE to CUCM
destination-pattern [2-9].........
session protocol sipv2
session target ipv4:
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/0.1
voice-class sip bind media source-interface GigabitEthernet0/0/0.1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 2 voip
description CUCM to CUBE
session protocol sipv2
incoming called-number 9T
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/0.1
voice-class sip bind media source-interface GigabitEthernet0/0/0.1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 3 voip
description ATT to CUBE
session protocol sipv2
incoming called-number [2-9].........
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/1
voice-class sip bind media source-interface GigabitEthernet0/0/1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 4 voip
description CUBE to ATT
destination-pattern 9[2-9].........
session protocol sipv2
session target ipv4:
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/1
voice-class sip bind media source-interface GigabitEthernet0/0/1
dtmf-relay rtp-nte
no vad
!
!
sip-ua
credentials username user password 7 01445655025251 realm xxxxxxxxxx.com
authentication username user password 7 040C5B5756781B
timers connect 100
registrar ipv4: expires 3600
!

2 ACCEPTED SOLUTIONS

Accepted Solutions
Beginner

Have you read AT&T

Have you read AT&T implementation guide?

http://www.cisco.com/c/dam/en/us/solutions/collateral/enterprise/interoperability-portal/flexible-reach-v2-isr.pdf

Lots of other CUCM/IOS versions as well in that interoperability portal (as well as lots of other carriers):

http://www.cisco.com/c/en/us/solutions/enterprise/interoperability-portal/networking_solutions_products_genericcontent0900aecd805bd13d.html

I notice you're doing the translation on the outbound dial-peer. Although there's multiple ways to do it, I've always done the inbound call translations on the inbound dial peer, so I'm dealing with Internal Ext as soon as possible in logical call flow.  This means my Outbound Dial Peers are unique for Out to PSTN and Out to CUCM; and allows for SRST mode (if used) where phones directly register to Router in CUCM outage, Router will get 'automatic ' dial peer destination (of sorts) of the phone ext, and send the translated called number directly to the phone extension.

Also check on your CUCM trunk that you have defined an inbound Calling Search Space, and it includes a partition with the extension you're targeting (225).  RTMT can also help in easily monitoring what calls are coming into CUCM in real-time for what destination numbers...

Example of my typical inbound dial-peer translation:

dial-peer voice 110 voip
description ** Inbound SIP Trunk (PSTN) **
translation-profile incoming Inbound_DID
session protocol sipv2
incoming called-number ^555.......

dial-peer voice 40010 voip
description ** Outbound to Call Manager **
destination-pattern ^123..$
session protocol sipv2
session target ipv4:10.10.10.1 !CUCM IP!

voice translation-profile Inbound_DID
translate called 5

voice translation-rule 5
rule 10 /^5551234567$/ /12301/
rule 11 /^5557654321$/ /12304/

In this example case, make sure CUCM is then setup to accept inbound calling search space for ext 12301 and 12304 at a minimum.

View solution in original post

VIP Mentor

Hi,

Hi,

From the logs it looks like cucm can't find the called number 225.

This maybe because the css on the sip trunk can't see the partition of the device with this number. Can you check this please

Please rate all useful posts

View solution in original post

12 REPLIES 12
Beginner

with "debug voice ccapi inout

with "debug voice ccapi inout" I can see the call getting in from AT&T --> CUBE --> dial-peer 3 --> dial-peer 1 --> disconnect

Participant

Hi,

Hi,

can you attach a set of traces from cucm along with following debugs.

debug voice ccapi inout

debug ccsip messages

I can try to have a look at it.

Please rate and mark if helpful

Regards,

Adarsh Chauhan


Please rate and mark correct if helpful
Regards,
Adarsh Chauhan
Beginner

I changed my dial-peer voice

I changed my dial-peer voice 1 voip to the following in order to try and translate the dialed number into extension 225. I think that the problem is related to CUCM not accepting the request from CUBE. I placed on bold some things that could bring some light:

 

!
voice translation-rule 1
rule 1 // /225/
!
!
voice translation-profile 1
translate called 1
!
dial-peer voice 1 voip
description CUBE to CUCM
translation-profile outgoing 1
destination-pattern [2-9].........
session protocol sipv2
session target ipv4:
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/0.1
voice-class sip bind media source-interface GigabitEthernet0/0/0.1
dtmf-relay rtp-nte
no vad
!

 

Here are the debugs from AT&T to CUBE

 

login as: admin
Using keyboard-interactive authentication.
Password:

PFS-ISR#debug voice ccapi inout
voip ccapi inout debugging is on
PFS-ISR#
PFS-ISR#debug ccsip messages
SIP Call messages tracing is enabled
PFS-ISR#termo mon
^
% Invalid input detected at '^' marker.

PFS-ISR#term mon
PFS-ISR#

VIP Mentor

Hi,

Hi,

From the logs it looks like cucm can't find the called number 225.

This maybe because the css on the sip trunk can't see the partition of the device with this number. Can you check this please

Please rate all useful posts

View solution in original post

Beginner

Thanks Ayodeji.

Thanks Ayodeji.

That was the major problem. The Trunk's CSS was not part of the device's partition.

I still need to fix some other dial plan issues, but after changing the CSS, I was able to receive calls.

VIP Advisor

Hi,

Hi,

There are multiple mistakes here.

1. Your incoming dialpeers are matching 9T or 9[2-9].... I don't see voice translation profiles on to strip the access code '9'. How are you going to match outgoing dialpeers? You need to strip the access code

2. Your incoming called numbers for CUCM and AT&T are overlapping. Same thing for desitination patters. My feeling (without looking at the debugs) is telling me the call routing isn't going correct. You need to have more regular dialplan.

Beginner

Mohammed, in my case I want

Mohammed, in my case I want to allow any number from ATT to CUBE to be translated and sent to extension 225.

As for calls from CUCM to CUBE, the numbers are already stripped from the 9 by CUCM and I also want to allow any number to go out.

what are your recomendations? 

I will post the traces and debugs in a few minutes.

VIP Advisor

As expected this is a big

As expected this is a big mess in your dialplan. From the debugs the called number from AT&T is 7875039385. CUBE is sending invite to CUCM but CUCM isn't able to find out the called number. So you need to look in your CUCM if this number (7875039385) is a configured a DN or need translation to match a configured DN. Also, do you have a CSS on your incoming trunk to access the DN.

I think you need to spend more time in reading how to configure dialplan and translations before proceeding. US dialplan is very organized and easy to configure it in a structured way. 

Beginner

Have you read AT&T

Have you read AT&T implementation guide?

http://www.cisco.com/c/dam/en/us/solutions/collateral/enterprise/interoperability-portal/flexible-reach-v2-isr.pdf

Lots of other CUCM/IOS versions as well in that interoperability portal (as well as lots of other carriers):

http://www.cisco.com/c/en/us/solutions/enterprise/interoperability-portal/networking_solutions_products_genericcontent0900aecd805bd13d.html

I notice you're doing the translation on the outbound dial-peer. Although there's multiple ways to do it, I've always done the inbound call translations on the inbound dial peer, so I'm dealing with Internal Ext as soon as possible in logical call flow.  This means my Outbound Dial Peers are unique for Out to PSTN and Out to CUCM; and allows for SRST mode (if used) where phones directly register to Router in CUCM outage, Router will get 'automatic ' dial peer destination (of sorts) of the phone ext, and send the translated called number directly to the phone extension.

Also check on your CUCM trunk that you have defined an inbound Calling Search Space, and it includes a partition with the extension you're targeting (225).  RTMT can also help in easily monitoring what calls are coming into CUCM in real-time for what destination numbers...

Example of my typical inbound dial-peer translation:

dial-peer voice 110 voip
description ** Inbound SIP Trunk (PSTN) **
translation-profile incoming Inbound_DID
session protocol sipv2
incoming called-number ^555.......

dial-peer voice 40010 voip
description ** Outbound to Call Manager **
destination-pattern ^123..$
session protocol sipv2
session target ipv4:10.10.10.1 !CUCM IP!

voice translation-profile Inbound_DID
translate called 5

voice translation-rule 5
rule 10 /^5551234567$/ /12301/
rule 11 /^5557654321$/ /12304/

In this example case, make sure CUCM is then setup to accept inbound calling search space for ext 12301 and 12304 at a minimum.

View solution in original post

Beginner

Thansk Shawn.

Thansk Shawn.

The implementation guide is going to help me a lot!!!!!

Also, thanks a lot for the example of the translation.

Beginner

Shawn,

Shawn,

This is working perfectly for incoming calls from ITSP. I configured a pilot (700) on CUCM that is taking the calls.

 

But for outbound, I am having problems. Currently, I only have one route pattern in CUCM, using 9.@ with NANP and "discard digits - pre dot".

 

After your recommendations, I ended up with the following config on the voice router:

 

!
dial-peer voice 1 voip
description CUBE to CUCM
destination-pattern ^700$
session protocol sipv2
session target ipv4:
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/0.1
voice-class sip bind media source-interface GigabitEthernet0/0/0.1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 2 voip
description CUCM to CUBE
session protocol sipv2
incoming called-number 9T
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/0.1
voice-class sip bind media source-interface GigabitEthernet0/0/0.1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 3 voip
description ITSP to CUBE
translation-profile incoming 1
session protocol sipv2
incoming called-number ^787.......
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/1
voice-class sip bind media source-interface GigabitEthernet0/0/1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 4 voip
description CUBE to ITSP
destination-pattern 9T
session protocol sipv2
session target ipv4:
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/1
voice-class sip bind media source-interface GigabitEthernet0/0/1
dtmf-relay rtp-nte
no vad

!
voice translation-rule 1
rule 1 /.*/ /700/
!

voice translation-profile 1
translate called 1

!

 

Incoming calls are being taken by dial-peer 3 -> dial-peer 1 -> pilot 700. But outgoing calls are not routing through dial-peer 2 -> dial-peer 4 -> ITSP

 

Any other recommendations?

Highlighted
Beginner

You said above you're

You said above you're stripping the 9 prefix in CUCM before sending to the gateway, but then you're trying to match 9 on inbound AND outbound dial peers on CUBE.  You have to do one or the other.  Since you say it's not matching the dial-peer 2 or 4, it sounds like you are stipping the 9 in CUCM, but your config on CUBE is looking for 9-prefixed numbers, so you need to not strip them off in cucm (or as I do, strip them, convert to E.164 and then prefix them again before sending to CUBE).  Again, I prefer to do this logically on the inbound dial-peer, as then your outbound peers match the exact numbers, and you can handle more complicated situations in the future with additonal lines or SRST, or what not, but either way you'll need to strip off the prefix first. 

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here