ANNOUNCEMENT - The community will be down for maintenace this Thursday August 13 from 12:00 AM PT to 02:00 AM PT. As a precaution save your work.
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
708
Views
0
Helpful
0
Replies
Highlighted
Beginner

Authentication issues invoking CGI/Screenshot url

Hello

I have 2 7965 ip phones and one 7921. I am having serious issues attempting to push alert messages to the phones.

I push the messages by involking a CGI/Execute url on the phone. And having a web server respond with the desired message. This is working flawlessly on one of the 7965's but the other seem to fail to authenticate. All phones are allocated control by the same Application User.

The 7921 fails with a 401 http response and the following web page. It also displays an Authorization required message on screen.

<html>
<head>
<title>Protected Object</title>
</head>
<body>
<h1>Protected Object</h1>
This object on the RomPager server is protected.<p>
Return to <A HREF="/192.168.10.95/CGI/Screenshot">last page</A><p>

</body>
</html>

The 7965 fails with a 200 response and the <CiscoIPPhoneError Number="4"/> xml

All three phones have next to identical settings in Call Manager.

For simplicity i'm testing the permission to involke CGI url's by using the CGI/Screenshot url. If i get permission to do this the Execute should work.

What could be causing these issues? Any thoughs or suggestions welcome even is sombody could give me a break down of the different levels of authentication in Call Manager it would be greatly apreciated.

Everyone's tags (2)