Showing results for 
Search instead for 
Did you mean: 

BLF SD Duplicate Programming Issue

We recently upgraded from 7.1(2a)SU1 to 7.1(3b) after our licensing TAC case was resolved (too many license files to load before the allotted time causing UCM service to fail completely).  We also upgraded from the default firmware 8.5.2SR1 to 8.5.3 to resolve a dual audio issue we were having with our headsets and handsets.  I'm not exactly sure when/where this first crept up, but now if I go to a specific instrument and review its button programming for BLF SDs, I'm seeing duplicates in the list that aren't actually there.

For example, I have a 7975 w/ a 7916 where button 8 is programmed for a DN.  Button 9 is left empty, however the button settings page lists the same DN as button 8 as programmed for this instance.  It does not duplicate either Label and if I press the button it doesn't actually do anything.  In fact, it appears to do the same thing for each time there is one left empty as well as for the last programmed button where it duplicates it for the remaining unprogrammed buttons.

I'm going to open a TAC case for this issue since I believe it's an SQL error for the admin interface, but I was just wondering if anyone else has seen this too.



Lamar Demby

I'm fighting the same issue as I type.  We're running UCCM 7.1.3.  I have a 7975 with two 7916 expansion modules attached.  I configured two BLF Speed Dials.  After configuring the 2nd, I see the same BLF SD repeat on all the other speed dial buttons thereafter.  One thing I noticed different when this happens is that even though I can successfully find the DN for the BLF SD in UCCM, it does not list the partition the way it does for other working BLF Speed Dials.

For example, here are two entries...the 1st one works fine and the second has repeated entries thereafter:

- The working BLF SD appears as "5551212 in Test_Partition"

- The non-working BLF SD appears as "5551313" <--(Notice no Partition listed)

Has this post ever been answered or has anyone else dealt with this same issue?


Yep, that's the bug.  Manually entering the number appears to be the best workaround.


I am running into the same bug. However I am not able to set the buttons back to . If I delete the manually entered number, the dropbox is automatically set to . If I press save, the duplicate number is inserted again. So either I enter a number manually, or I get a duplicate number on that button...I would like the default though.

As a workaround I entered an "dummy" number in the destination field, making the button useless. I would however like to have no number at all, so the user won't get any reaction when pressing the button, and no description is displayed.

Anybody know how I can get this to work?


As Lamar suggested, manually entering the programmed number in the Destination field instead of using the Directory Number field worked for me.

Yes that also worked for me, but what I want is no number at all to be displayed in a particular field (like the default setting). If I remove the number for that field is displayed correctly, but as soon as I press save I get a duplicate number again. I am not able to return a field to the default setting.

I think you are running into the same issue I was having.  Ensure that every Directory Number field is set to "".  If one of them has anything else, it will continue to duplicate and program the remaining openings to whatever that value is.  If that's still not what you are referring to, then perhaps a screenshot of the BLF window would help.

Ok, I will try this. I think I had some BLFs still use the dialog box. I will try to enter the number manually everywhere and see what happens. Thank you for the tip!

How did you make out with your last attempt to clear out those duplicate BLFs ivarnhagen?

Hi! Entering the number manually everywhere on every button seemed to do the trick. The buttons are displayed as I want them to be now.


Recognize Your Peers
Content for Community-Ad