Showing results for 
Search instead for 
Did you mean: 

Bricked 7945G


I've been handed two 7945G's one thats stuck on upgrading and one with a blank screen.

When I do a factory reset they I can see from the switch that they get power (15.4W) but thats it, they are not recognised as Cisco phones on the Cisco switch over CDP (thus they are not dropping down to 6.3W). The mac address of the phone doesn't even show up on the switch.

So I created a console cable to console through the AUX port. From the phone I saw that it was trying to send DHCP discovers but not getting a reply

NOT 15:58:56.018630 DHCP:  dhcpSendReq: status 0x0
NOT 15:58:56.019180 DHCP: Sending Discover...
WRN 15:59:00.010078 DHCP: response not received, try again...
WRN 15:59:08.010087 DHCP: response not received, try again...
WRN 15:59:24.010081 DHCP: response not received, try again...

Then I noticed that the LED on the switch port wasnt even on even though the phone was getting power. So I got another switch (non POE) and got a power cube and connected the phone to the non POE switch via the PC port using a X-over cable. I also put a DHCP/TFTP server on my laptop with the phone firmware.

This time the phone got IP but thats it it makes no attempt to TFTP through the PC port (fair enough) but the switch port on both phones just seems to be dead (even though POE on phone is working)

Any Ideas ?



They sound pretty dead to me.

Send 'em back?


Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

I never seen a truly failed phone. But so many stuck and needed to be properly reset.

Beside, not everyone has support contracts, so sending back is not an option.

Hola buen dia,

Tengo un teléfono cisco ip 7945 que se reseteo de fabrica  pero no tengo o no cumplo con estos dos requisitos:

**Un servidor TFTP válida se debe establecer en la opción DHCP 150 (dirección IP) o la opción 66 (nombre) en el servidor DHCP.

**El archivo term75.default.loads y los archivos especificados en ese archivo debe estar disponible en el servidor TFTP que se especifica mediante el paquete DHCP.

y se queda como en un ciclo o bucle reiniciando y reiniciando como si hubiera echo la opcion de #  123456789  *0#

Como pudo evitar que se quede en ese ciclo o como cumplo con esos dos requisitos que no cumplo ??

para poder ingresar al menu del telefono 

Gracias a quien pueda ayudarme.


You need the tftp server. There is no other way.

paolo bevilacqua
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

This is discussed in so many post.

First, you try the factory reset sequences.

If no luck, your best choice is to connect to a test vlan with a PC with tftpd32,

That will allow you observe the boot process and eventually recover the phones.

If the phone doesn't TFTP, that is generally lack or incorrect option 150 in dhcpd settings.

The TFTP is pointed at my laptop with TFTPD32 running. Even from wireshark I cant see it trying to TFTP ?

Check option 150 setting in tftpd32. Some versions require "i x.x.x.x".

So it seems that the cisco phones will expect the option 150 IP in HEX, TFTPD32 hands out the options as ASCII so rather than messing around with HEX conversions I just manually set the alt server on the phone & rebooted but still no differnece.

The setup I have is:

1) A non poe switch acting like a hub

2) Phone connected through its pc port over X over cable into switch

3) Laptop with static IP of TFTPD32 running DHCP & TFTP

Here's the output ... it has the IP settings but it does nothing ? The screen just says upgrading.

========== Cisco Systems IP Phone Loading Operating System ==========

CNU Ver 3.3(0.3); Build 8.5(2TH1.9) Jan 01 20877 20:58:00 GMT
Copyright (c) 2001-2006   Cisco Systems, Inc. All rights reserved.

linearfs: find a image at: 0xB0060000
linearfs: apps file CRC32=0x78AC1061
linearfs: amalloc block size=0xE2000
linearfs: init, lfs_state -> 0
ip6_init called
GIG PHYs detected, PHYID = 0x143bcb1
SYSMSG: Last reboot cause -> Power Loss
-->init: ver 3.7(1.5b)
-->init: &bootInit.installHandlers
-->init: Starting syslogd...
-->syslogd: [2] ver 3.0 (2.0)
-->syslogd: waiting for filesystem...
-->fsck: checking /dev/fd0a
-->fsck: disk geometry
-->fsck:   block size        = 512 (0x200)
-->fsck:   sector size       = 131072 (0x20000)
-->fsck:   number of sectors = 117 (0x75)
-->fsck:   blocks/sector     = 256 (0x100)
-->fsck:   total blocks      = 29952 (0x7500)
-->fsck: journal file found in sector 1
-->fsck: journal file contained 20 valid transactions
-->fsck: filesystem updated
-->fsck: disk contains 83 valid blockmaps
-->fsck: disk contains 171 valid inodes
-->fsck: block usage
-->fsck:   used blocks  = 17073
-->fsck:   free blocks  = 9793
-->fsck:   dirty blocks = 3086
-->fsck: 5 orphaned block(s)
-->fsck: complete
-->fsck: complete
-->fsck: checking /dev/fd1a
-->fsck: disk geometry
-->fsck:   block size        = 512 (0x200)
-->fsck:   sector size       = 131072 (0x20000)
-->fsck:   number of sectors = 1 (0x1)
-->fsck:   blocks/sector     = 256 (0x100)
-->fsck:   total blocks      = 256 (0x100)
-->fsck: disk contains 1 valid blockmaps
-->fsck: disk contains 21 valid inodes
-->fsck: block usage
-->fsck:   used blocks  = 42
-->fsck:   free blocks  = 200
-->fsck:   dirty blocks = 14
-->fsck: complete
-->fsck: complete
-->syslogd: syslog continuing...
-->syslogd: syslog config file -> fsize=20480 fcnt=5
-->syslogd: Started strace [6]
strace: PID = 6, ver A
|=== Syslogd === Tue May  5 15:58:01 2009
NOT 21:58:01.217515 init: Mounting /dev/fd0a...
INF 21:58:01.478474 init: Mount succeeded.
NOT 21:58:01.517223 init: Mounting /dev/fd1a...
INF 21:58:01.533390 init: Mount succeeded.
NOT 21:58:01.536502 init: Starting espd...
NOT 21:58:01.557090 ESP: pid = 5
NOT 21:58:01.832607 init: Loading drivers from '/etc/sysdvrs.def'.
NOT 21:58:01.950002 init: Loading drivers from '/usr/local/etc/drivers.def'.
DBG 21:58:01.978650 pwr: maxPower = 12000 mwatts, alloc power = 12000
DBG 21:58:02.439628 LCD: Using external gamma
DBG 21:58:02.475216 LCDSWInit: LCD initialized
DBG 21:58:02.496496 audev: driver  INSTALLED
DBG 21:58:02.531461 dsp: dirver installed, version 1A0
DBG 21:58:02.532853  LED DRIVER: Model is: 7945
DBG 21:58:02.630253 linearfs: sysctl name=LFS_SWITCH_TO_FLASH0
DBG 21:58:02.630824 linearfs: switch to flash0
INIT: hit ENTER to abort to shell
DBG 21:58:03.055413 linearfs: using existing /flash0/apps
DBG 21:58:03.056031 linearfs: lfs_state -> 1
NOT 21:58:03.059250 init: Starting applications from /usr/tmp/
NOT 21:58:03.060368 init: Sending termination signals to apps for pending restart.
DBG 21:58:03.132705 lcd_open: return success!
NOT 21:58:04.050303 ESP: sending startup trigger
NOT 21:58:04.054465 ESP: send ADMIN, logging = 1, shell = 0, ipconfig = 1
DBG 21:58:04.155782 lcd_close: return success!
NOT 21:58:04.157624 init: Starting /sbin/inetd
NOT 21:58:04.159914 init: /sbin/inetd started as pid=8
NOT 21:58:04.182023 INETD: pid = 8
NOT 21:58:04.356979 init: Starting /sbin/imgauthd
NOT 21:58:04.359282 init: /sbin/imgauthd started as pid=13
NOT 21:58:04.359916 init: Starting /sbin/image
NOT 21:58:04.362878 init: /sbin/image started as pid=14
NOT 21:58:04.370911 CDP-D: pid = 10
NOT 21:58:04.380783 DHCP6: COLDBOOT - wait 1 seconds...
NOT 21:58:04.384545 PAE: pid = 12
NOT 21:58:04.385900 PAE: phone is not single port
NOT 21:58:04.450065 ESP: send ADMIN, logging = 1, shell = 0, ipconfig = 1
NOT 21:58:04.454823 IMG_AUTH: Version: 3.6(1.0): TNP REL

NOT 21:58:04.455059 IMG_AUTH: model: CP-7945G, check for built-in key
NOT 21:58:04.455198 IMG_AUTH: built-in platform RELEASE key is present
NOT 21:58:04.455347 IMG_AUTH: built-in common RELEASE key is present
NOT 21:58:04.458692 image: [14] ver 2.0 (0.1)
NOT 21:58:04.459721 image: **Legacy TFTP Mode Specified**
NOT 21:58:04.463572 image: Starting imgui...
ERR 21:58:04.475447      routeList NULL
WRN 21:58:04.475965 INETD: cdpMsgQue has not been created : No such file or directory
WRN 21:58:04.476574 INETD: cdpMsgQue has not been created : No such file or directory
WRN 21:58:04.477148 INETD: cdpMsgQue has not been created : No such file or directory
WRN 21:58:04.477782 INETD: cdpMsgQue has not been created : No such file or directory
DBG 21:58:04.487756 Opened cmd pipe '/tmp/imguicmd'
NOT 21:58:04.490877 imgUI: [15] ver 0.1 (0.0)
ERR 21:58:04.491963 imgUI: failed to connect w/ disp server - trying restart [146] Connection refused
DBG 21:58:04.563687 lcd_open: return success!
NOT 21:58:04.735144 image: Starting dload...
ERR 21:58:04.737828 image: exec /sbin/dload -inrv -p
NOT 21:58:04.771552 TLoad: Restart source file signal
NOT 21:58:04.774654 TLoad: ^.idl_inetd.c-waitForNetworkUp
INF 21:58:04.776695 TLoad: Opened cmd pipe '/tmp/idlcmd'
NOT 21:58:04.781833 PAE: /tmp/pae.stat does not exist
WRN 21:58:04.783244 PAE: paeReadPCStatus: empty file
NOT 21:58:04.783812 PAE: link-0 is DOWN
NOT 21:58:04.784330 PAE: supplicant will start when link-0 is UP
NOT 21:58:04.785127 IMG_AUTH: /tmp/midlet.conf does not exist
NOT 21:58:04.786556 IMG_AUTH: TNP, built-in keys  : Platform (curr), Common (curr)
WRN 21:58:04.789566 INETD: cdpMsgQue has not been created : No such file or directory
ERR 21:58:04.791307      routeList NULL
NOT 21:58:05.370345 CDP-D: Starting CFG_COMMAND_SMSme...365879296
NOT 21:58:06.220245 DHCP: pid = 18
NOT 21:58:06.235037 DHCP: COLDBOOT - wait 1 seconds...
ERR 21:58:06.370094 CDP-D: calling installHandlers
ERR 21:58:06.370856 CDP-D: calling cdpDrvrInit
ERR 21:58:06.372421 ETH_SET_IPV6 call in6_if_brcm_reset
ERR 21:58:06.372987 ETH_SET_IPV6 call in6_if_brcm_up
ERR 21:58:06.373526 in6_ifattach_linklocal
ERR 21:58:06.373561 in6_ifattach_linklocal call in6_update_ifa
ERR 21:58:06.373609      routeList NULL
ERR 21:58:06.373874 in6_ifattach_linklocal call in6ifa_ifpforlinklocal
ERR 21:58:06.373932 nd6_ifattach_linklocal ndpr:plen:64 mask:ffff:ffff:ffff:ffff:: prefix:fe80::0224:97ff:fe35:0d5c
ERR 21:58:06.374003 nd6_ifattach_linklocal return 0
ERR 21:58:06.374022 exit in6_if_brcm_up
ERR 21:58:06.374033 ETH_SET_IPV6 call in6_if_loopback_up
ERR 21:58:06.374043 enter in6_if_loopback_up
ERR 21:58:06.374392 in6_ifattach_linklocal
ERR 21:58:06.374415 in6_ifattach_linklocal call in6_update_ifa
ERR 21:58:06.374572 in6_ifattach_linklocal call in6ifa_ifpforlinklocal
ERR 21:58:06.374615 nd6_ifattach_linklocal ndpr:plen:64 mask:ffff:ffff:ffff:ffff:: prefix:fe80::0001
ERR 21:58:06.374666 nd6_ifattach_linklocal return 0
ERR 21:58:06.374683 exit in6_if_loopback_up
ERR 21:58:06.374697 ETH_SET_IPV6 returned from in6_if_loopback_up
NOT 21:58:06.386316 CDP-D: NA power detected, max power = 12000 milliwatts
NOT 21:58:06.388607 CDP-D: Enable values LLDP:3 CDP:3
NOT 21:58:06.390596 CDP-D: cdpSetRepeater 11
NOT 21:58:06.402711 CDP-D: PHY 0 --> LINK IS DOWN
NOT 21:58:06.403893 CDP-D: delayedCheckLinkTimer
NOT 21:58:06.404775 CDP-D: PHY 1 --> 100 MB LINK IS UP
WRN 21:58:06.405521 CDP-D: PC port up sending to cdpMsgQue
NOT 21:58:06.406255 CDP-D: ----lldpProtoInfo[1].enableState 1
NOT 21:58:06.407235 CDP-D: ----cdpProtoInfo[1].enableState 1
NOT 21:58:06.434888 PAE: SIGIPCFG received...
NOT 21:58:06.435722 INETD: inetdSSH tid 55
NOT 21:58:06.439921 CDP-D: catchipcfg:getdhcpinfo IP:0 domain: chngVal:0
NOT 21:58:06.442832 CDP-D: catchipcfg:getdhcpinfo IP:0 domain: chngVal:0
NOT 21:58:06.445319 CDP-D: catchipcfg:getdhcpinfo IP:0 domain: chngVal:0
NOT 21:58:06.451905 DNS: pid = 19
NOT 21:58:06.454757 ESP: send ADMIN, logging = 1, shell = 0, ipconfig = 1
NOT 21:58:06.455669 PAE: SIGIPCFG received...
ERR 21:58:06.459016 RTSOLD: opvvlan:0->4096 advvlan:0->4096
ERR 21:58:06.464110 RTSOLD: opvvlan:4096->4096 advvlan:4096->4096
NOT 21:58:06.469486 ESP: send ADMIN, logging = 1, shell = 0, ipconfig = 1
NOT 21:58:07.402712 CDP-D: Set timer to 1 sec to send a Trigger Response.
NOT 21:58:08.402026 CDP-D: Set timer to 1 sec to send a Trigger Response.
NOT 21:58:09.402851 CDP-D: Set timer to 1 sec to send a Trigger Response.
NOT 21:58:11.410059 CDP-D: dpCheckLinkThrd: check link on port 0
NOT 21:58:11.410752 CDP-D: port 0 link is down, send SIGCONT

setipcfg> Checking for inetd...
setipcfg> CRT 21:59:09.723894 init: Starting alternate command line

setipcfg> getcfg
        status - 0x12310000
        ip -
        subnet -
        default gateway -
        alternate tftp server -

tftpd32 correctly serves option 150 when configured as indicated above. No messing with conversion is necessary.

Phone must go to switch via network port using straight cable.

However, if you can access phones menus, what is the point of doing all this ?

It doesnt work when I connect it to the switch via the switch port. It will get power (if I connect it to a POE switch) but the switch port doesnt light up no matter what switch or cable I use.

I cant access the phone menu's its stuck on the upgrading screen.

Try diffrent swithc port settings.

Try the reset sequences.

If still not physical link to network port, phone is truly faulty.


Thanks for this! I had been trying without success and this was the trick. I had tried "ip x.x.x.x" and "x.x.x.x" but it needed "i x.x.x.x"...


Amr Gaber

Same here, i have blank screened 7945G,

the problem started when i tried to rest it to factory setting using # and 12345


Now the Phone got an IP address and i can ping it successfully but its stuck with Blank screen.

My question is did you manage to return it back to it's original state or it is really bricked ?

and how ?

I'm using CUCM 7.1 and DHCP subnet Configured on it.

Thank you in advance.

Same as always, you are missing the firmware files, or any other detail needed.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: