cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2721
Views
0
Helpful
2
Replies
iptuser55
Frequent Contributor

Call failing- Mandatory information element missing

I have two sites calling the same destination

Site A calls Site C

Site B calls Site C

Site A can call other sites ok but fails when calling Site C

Site B can call any where

Calls to site C terminate on the same Rouer regardless of calling from Site A or B

GW`s using H323

Site A debug

Calling Party Number i = 0x0081, Number'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, Number'

Plan:Unknown, Type:Unknown

Jul 2 11:29:12.149 CET: ISDN Se0/0/1:15 Q931: TX -> FACILITY pd = 8 callref = 0x0E53

Jul 2 11:29:12.165 CET: ISDN Se0/0/1:15 Q931: RX <- CALL_PROC pd = 8 callref = 0x8E53

Channel ID i = 0xA98382

Exclusive, Channel 2

Jul 2 11:29:12.181 CET: ISDN Se0/0/1:15 Q931: RX <- STATUS pd = 8 callref = 0x8E53

Cause i = 0x81E0 - Mandatory information element missing

Call State i = 0x09

Jul 2 11:29:12.185 CET: ISDN Se0/0/1:15 Q931: TX -> DISCONNECT pd = 8 callref = 0x0E53

Cause i = 0x82E0 - Mandatory information element missing

Jul 2 11:29:12.213 CET: ISDN Se0/0/1:15 Q931: RX <- RELEASE pd = 8 callref = 0x8E53

Jul 2 11:29:12.217 CET: ISDN Se0/0/1:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x0E53

Site B debug

Channel ID i = 0xA18384

Preferred, Channel 4

Calling Party Number i = 0x0081, Number'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, Number'

Plan:Unknown, Type:Unknown

Jul 2 13:02:52.657 CET: ISDN Se0/0/1:15 Q931: RX <- CALL_PROC pd = 8 callref = 0x8F1D

Channel ID i = 0xA98384

Exclusive, Channel 4

Jul 2 13:02:52.797 CET: ISDN Se0/0/1:15 Q931: RX <- FACILITY pd = 8 callref = 0x8F1D

Facility i = 0x91AA068001008201008B0100A11902010106042B0C0914300E0A01010A0102A006800438303030

Jul 2 13:02:52.937 CET: ISDN Se0/0/1:15 Q931: RX <- ALERTING pd = 8 callref = 0x8F1D

Facility i = 0x91AA06800100820100A10B02010106042B0C09018400

Progress Ind i = 0x8088 - In-band info or appropriate now available

Jul 2 13:02:53.277 CET: ISDN Se0/0/1:15 Q931: RX <- CONNECT pd = 8 callref = 0x8F1D

Facility i = 0x91AA06800100820100A10B02010206042B0C09028400

Progress Ind i = 0xA194 - Reserved value

Connected Number i = 0x0080, '8000'

Jul 2 13:02:53.281 CET: ISDN Se0/0/1:15 Q931: TX -> CONNECT_ACK pd = 8 callref = 0x0F1D

Jul 2 13:02:56.369 CET: ISDN Se0/0/1:15 Q931: TX -> DISCONNECT pd = 8 callref = 0x0F1D

Cause i = 0x8290 - Normal call clearing

Jul 2 13:02:56.397 CET: ISDN Se0/0/1:15 Q931: RX <- RELEASE pd = 8 callref = 0x8F1D

Jul 2 13:02:56.397 CET: ISDN Se0/0/1:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x0F1D

I noticed the Site A sends a Facility message before recievcing a CALL_PROC

What does Mandatory information element missing, I thought it was to do where CUCM puts messages. I configured up Site B H323 same as Site A and it works

Any ideas, where to look ?

thanks

2 REPLIES 2
kdotzoltan_2004
Beginner

Hi,

I know this has been a whie ago, but have you figured this one out by any chance?

I see a very similar problem, although I'm dialing in through SIP trunks from two different locations to a third site, which connects to a local PBX through E1/ISDN.

And the same thing happens. One site does not send an empty FACILITY message, call gets through, the other site sends a FACILITY message without an information element and the call fails.

Having the same issue, calls come in on a sip trunk to cucm then routes some calls to PBX.  Getting same error.

Create
Recognize Your Peers
Content for Community-Ad