cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
739
Views
5
Helpful
8
Replies
gsriraman
Beginner

Call Manager Express dial peer issue

We have configured call manager express on the router. We have two kinds of dialling. Any calls to mobile is working fine and sends all 10 digits

however when we dial local number of 8 digits, we are unable to dial. On checking we notice that calls are getting prefixed by 0. This should not happen

So for mobile 10 digits are perfectly going. However calls for 8 digits or 11 digits or international calls are not going through.

We need help

 

8 REPLIES 8
Chris Deren
Hall of Fame Master

post "show run" and let us know what trunk type you are using, i.e. SIP trunk, PRI, FXO, etc? Then we can request proper debug.

Chris

zahidanwar1
Beginner

Looks like issue may be with Digit Manipulation / Voice Translation but its hard to tell without see your run config

gsriraman
Beginner

Please see the attached Runnig Config

 

Router#
Router#
Router#
Router#sh run
Building configuration...


Current configuration : 2647 bytes
!
! Last configuration change at 10:45:06 UTC Tue May 27 2014 by ninesec
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
card type e1 0 0
enable secret 5 $1$eLS3$6pHArA2bG8ne2JYZJIAvb/
!
aaa new-model
!
!
!
!
 --More--         !
!
!
aaa session-id common
network-clock-participate wic 0
!
ip cef
!
!
!
ip dhcp excluded-address 10.87.122.1 10.87.122.10
!
ip dhcp pool VOICE
 network 10.87.122.0 255.255.255.0
 default-router 10.87.122.10
 option 150 ip 10.87.122.10
!
!
!
no ipv6 cef
multilink bundle-name authenticated
!
!
 --More--         !
!
isdn switch-type primary-net5
!
!
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
!
!
!
!
!
!
license udi pid CISCO2901/K9 sn FGL181423P2
hw-module ism 0
!
hw-module pvdm 0/0
!
!
 --More--         !
username ninesec privilege 15 secret 5 $1$dN18$I1gmZkecZRYnf4ibKj3kL/
username cisco privilege 15 password 0 cisco
!
redundancy
!
!
controller E1 0/0/0
 framing CRC4
 pri-group timeslots 1-5
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 10.87.122.10 255.255.255.0
 duplex auto
 speed auto
 --More--         !
interface ISM0/0
 no ip address
 shutdown
 !Application: CUE Running on ISM
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ISM0/1
 description Internal switch interface connected to Internal Service Module
 no ip address
!
interface Serial0/0/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-4ess
 isdn incoming-voice voice
 no cdp enable
!
 --More--         interface Vlan1
 no ip address
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:/cpconfig-29xx.cfg
!
!
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0:15
!
voice-port 0/1/0
!
 --More--         voice-port 0/1/1
 !
 !
 !
!
!
!
mgcp profile default
!
!
dial-peer voice 1 pots
destination-pattern 0T
direct-inward-dial
port 0/0/0:15
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 max-ephones 30
 max-dn 60
 --More--          ip source-address 10.87.122.10 port 2000
 max-conferences 8 gain -6
 web admin system name ninesec password c34ph&co
 transfer-system full-consult
!
!
ephone  1
!
!
!
!
line con 0
 privilege level 15
 logging synchronous
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line 67
 no activation-character
 --More--          no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 transport input all
!
scheduler allocate 20000 1000
!
end

Router#
Router#
Router#
Router#

Issue seems to be with this dial peer only. If you dial something which start from 0 (eg 0xxxxxxxxx), then it will remove the 0 automatically. Give "forward-digits all" command under this dial peer as below and then test.

dial-peer voice 1 pots
destination-pattern 0T
direct-inward-dial

forward-digits all
port 0/0/0:15

 

Suresh

gsriraman
Beginner

We had inserted the command, Forward-digit all,

 

all calls stopped  working

 

We changed the Pattern 0.T, it did not work

 

We have the debug below

 

debug isdn q931

 

debug voip ccapi inout

 

     Exclusive, Channel 5

        Calling Party Number i = 0x2180, '2400'

                Plan:ISDN, Type:National

        Called Party Number i = 0xA1, '67974078'

                Plan:ISDN, Type:National

*May 31 12:59:17.158: ISDN Se0/0/0:15 Q931: RX <- SETUP_ACK pd = 8  callref = 0x80F7

        Channel ID i = 0xA98385

                Exclusive, Channel 5

*May 31 12:59:29.162: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x80F7

        Cause i = 0x829C - Invalid number format (incomplete number)

        Progress Ind i = 0x8288 - In-band info or appropriate now available

*May 31 12:59:29.162: ISDN Se0/0/0:15 Q931: call_disc: PI received in disconnect; P

 

let me know the opinion

 

 

Calls disconnected bcoz you might be dialing 0 as a access code and then number. Anyway here this seems to be service provider issue, you can ask to service provider to check the same at their end and ask why they are sending "disconnect" message.

 

Suresh

Make another dial peer for 8 digit numbers & Preference or you can use voice translation rule command to manipulate numbers (the way you want them to outbound).

Let me know if you need any further help

Nadeem Ahmed
Cisco Employee

Calling Party Number i = 0x2180, '2400' Plan:ISDN, Type:National Called Party Number i = 0xA1, '67974078' You are sending 4 digit clg party number and 8 digit cld party number . You should know what digit you need to send for 8, 10 and 11 digit calling accordingly you can have dial-peer created on cme and calling and called party number can also be manipulated through translation pattern . Br Nadeem
Br, Nadeem Please rate all useful post.
Create
Recognize Your Peers
Content for Community-Ad