cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1649
Views
10
Helpful
23
Replies

Call Manager Upgrade from 8.6 to 10.5 fails

kwaldecker
Beginner
Beginner

Hello there

 

I am upgrading a customer from 8.6.2.24901-1 to 10.5

each time the upgrade fails and shows no inactive partition (obviously since the upgrade failed)

I tried upgrading to 10.5.2.11900-3 and 10.5.2.10000-5 both with the same results.

I will attach the install log to the post.

 

More detail on the steps taken.

loaded new version of 8.6 on UCS server and restored the call manager database

installed the version3-keys.cop file and then tried the upgrade which fails.

 

I also completely reloaded the steps above and tried to upgrade to the latest 8.6.2.25900-8 but after that upgrade the server would no longer boot :/

 

I have had a tac case open for a week on it with no luck so far.  they had me delete a SIP conference phone profile and try the upgrade again.  nothing changed

 

anyone see anything in the logs that might help?  i can't decipher them :P

23 Replies 23

Jitender Bhandari
Cisco Employee
Cisco Employee

Hi,

 

i see the below error in the logs,

 

05/21/2015 15:55:58 appmanager.sh|Internal Error, File:/usr/local/bin/base_scripts/appmanager.sh:273, Function: refresh_upgrade(), failed to refresh_upgrade infrastructure_post components|<LVL::Critical>

 

Can you provide me the output of below commands

 

file get activelog cm/trace/dbl/sdi/installdb/*
file get activelog cm/trace/dbl/sdi/*
file get activelog /cm/trace/dbl/sdi/installdb_ru.log.err
file get activelog /cm/trace/dbl/sdi/installdb_ru*

 

HTH

 

Jitender Bhandari

they are attached. I had to zip them as the size was pretty large

 

the 16meg one is the file get inactivelog cm/trace/dbl/sdi/installdb/*   by itself

 

 

Do you have any dial plan installed on CUCM

No dial plan installed.  that was the last thing TAC had me check a few hours ago.  the numbering plan section in route patterns is greyed out and in the installer section there is nothing listed

 

Hello Guys,

 

Issue is not related to dial-plans, I checked the logs and it appears something wrong in the auto configuration configurations:

 

15:55:53.391 |   installdb::fixAutoReg select pkid, AutoregistrationStartDN , AutoregistrationEndDN , AutoregistrationNextDN,fkRoutePartition_AutoRegistration,E164MaskAutoregistration,name  FROM callmanager where AutoregistrationStartDN <> AutoregistrationEndDN
15:55:53.393 |   installdb::fixAutoReg EXECUTE FUNCTION UniversalDeviceTemplate_CreateDefault('10.19.11.83')
15:55:53.400 |   installdb::fixAutoReg *ERROR* SQL Exception [0xffffff11] [Error fetching data from datasource: [Informix][Informix ODBC Driver][Informix]Could not insert new row - duplicate value in a UNIQUE INDEX column (Unique Index:assign).]
15:55:53.400 |<--installdb::fixAutoReg
15:55:53.400 |   installFull *ERROR* Error Processing fixAutoReg() : Action [RU] , Source DSN [DSN=ccm_b;Servername=morriscm2_ccm10_5_2_10000_5] , Dest DSN [DSN=ccm_super;Servername=morriscm2_ccm10_5_2_10000_5] ,Current status [0]
15:55:53.401 |   installFull installFull  rc[1]

 

can you please double-check the auto-rigistartion config and provide screenshot from auto-registration config for all servers?

 

Thank you,

Shadi

 

Are you talking about the auto registration of phones when they are plugged in without being manually configured?  if so what looks wrong?

 

Hi,

 

Nice catch Shadi.

 

I checked the logs again this morning we could see refresh upgrade failing with below error.

 

15:55:53.375 |<--DBUtil::TableExists
15:55:53.376 |   installdb::fixAutoReg update processconfig set paramvalue = 'T'  WHERE paramname = 'AutoRegistrationLegacyMode'
15:55:53.385 |   installdb::fixAutoReg SELECT FIRST 1 count(fkdevicepool) cnt,fkdevicepool FROM defaults  GROUP BY fkdevicepool ORDER BY cnt DESC
15:55:53.387 |   installdb::fixAutoReg SELECT FIRST 1 count(NVL(dp.fkcallingsearchspace_autoregistration,'')) cnt,NVL(dp.fkcallingsearchspace_autoregistration,'') css FROM defaults d join devicepool dp on d.fkdevicepool = dp.pkid   GROUP BY css ORDER BY cnt DESC
15:55:53.391 |   installdb::fixAutoReg select pkid, AutoregistrationStartDN , AutoregistrationEndDN , AutoregistrationNextDN,fkRoutePartition_AutoRegistration,E164MaskAutoregistration,name  FROM callmanager where AutoregistrationStartDN <> AutoregistrationEndDN
15:55:53.393 |   installdb::fixAutoReg EXECUTE FUNCTION UniversalDeviceTemplate_CreateDefault('10.19.11.83')
15:55:53.400 |   installdb::fixAutoReg *ERROR* SQL Exception [0xffffff11] [Error fetching data from datasource: [Informix][Informix ODBC Driver][Informix]Could not insert new row - duplicate value in a UNIQUE INDEX column (Unique Index:assign).]
15:55:53.400 |<--installdb::fixAutoReg
15:55:53.400 |   installFull *ERROR* Error Processing fixAutoReg() : Action [RU] , Source DSN [DSN=ccm_b;Servername=morriscm2_ccm10_5_2_10000_5] , Dest DSN [DSN=ccm_super;Servername=morriscm2_ccm10_5_2_10000_5] ,Current status [0]

 

I've got a question

 

1) are you using PCD

 

If the answer to above is Yes, we are running into a known issue i would recommend disabling auto registration on any active node on cluster and re-run the upgrade.

 

HTH

 

Jitender Bhandari

what is PCD?  not familiar with that acronym

 

Can you try disabling Auto Registration and start the upgrade again?

I'm trying it now! thanks for the suggestion.  i'll post what happens

 

 

The upgrade failed again.  Any particular logs to look at this time?

 

same logs please.

Here are the install logs from the RTMT.  i have to go back and grab the other ones we got