cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
484
Views
15
Helpful
5
Replies
Beginner

Call routing issue

Our provider change our did numbers range we have configured it on router and it working fine but the issue is we requested Provider to forward old call to new numbers call is landing to gateway but not destination

 

Channel ID i = 0xA9838E
                Exclusive, Channel 14
*Feb  9 07:31:06.842: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8  callref = 0x3A77
        Sending Complete
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA9839E
                Exclusive, Channel 30
        Progress Ind i = 0x8183 - Origination address is non-ISDN
        Calling Party Number i = 0x2180, '2133133840'
                Plan:ISDN, Type:National
        Called Party Number i = 0xC1, '3118452946'
                Plan:ISDN, Type:Subscriber(local)
*Feb  9 07:31:07.030: ISDN Se0/0/0:15 Q931: RX <- CALL_PROC pd = 8  callref = 0xBA77
        Channel ID i = 0xA9839E
                Exclusive, Channel 30
*Feb  9 07:31:07.034: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0xBA77
        Cause i = 0x8281 - Unallocated/unassigned number
*Feb  9 07:31:07.034: ISDN Se0/0/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x3A77
*Feb  9 07:31:07.210: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0xBA77
*Feb  9 07:31:07.214: ISDN Se0/0/0:15 Q931: TX -> DISCONNECT pd = 8  callref = 0x93C9
        Cause i = 0x8081 - Unallocated/unassigned number
*Feb  9 07:31:07.394: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x13C9
*Feb  9 07:31:07.394: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x93C9
*Feb  9 07:31:11.590: ISDN Se0/0/0:15 Q931: RX <- CONNECT pd = 8  callref = 0xBA76
        Progress Ind i = 0x8284 - Call has returned to the ISDN
        Date/Time i = 0x1202090C2B13
                Date (dd-mm-yr)   = 18-02-09
                Time (hr:mnt:sec) = 12:43:19
*Feb  9 07:31:11.590: ISDN Se0/0/0:15 Q931: TX -> CONNECT_ACK pd = 8  callref = 0x3A76

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Rising star

Re: Call routing issue

You should voip dial-peers (identical to 300,400,500,600) that would route the range that number 3118452946 is part of. Of-course, at the destination platform (eg 192.168.33.4) you should add the proper translation (you can look what you do for the 2133142[8-9].. range), so that 3118452946 is translated to some internal extension.

Georgios
Please rate if you find this helpful.

View solution in original post

5 REPLIES 5
VIP Rising star

Re: Call routing issue

Is 3118452946 the old number? If yes, then you can use a translation-profile (or even num-exp) to convert that number to one of your internal extensions and route accordingly.

Georgios
Please rate if you find this helpful.
Highlighted
Beginner

Re: Call routing issue

Yes can you please explain

VIP Rising star

Re: Call routing issue

How do you currently route your new DID range? Also, where does it end up to; CUCM, CME? Can you explain what the exact call route is?

Georgios
Please rate if you find this helpful.
Beginner

Re: Call routing issue

Translation rule on CUCM configuration as below

 

Current configuration : 3680 bytes
!
! Last configuration change at 07:30:41 UTC Fri Feb 9 2018 by cisco
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname HC-PRI
!
boot-start-marker
boot-end-marker
!
!
card type e1 0 0
card type e1 0 1
enable secret 5 $1$TIC/$1Y9WwccdTa9x7txj/2.Sm0
!
no aaa new-model
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-select 1 E1 0/0/0
!
!
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address x.x.x.x x.x.x.x
!
ip dhcp pool IPT-HC-Voice
network x.x.x.x x.x.x.x
default-router x.x.x.x
domain-name dibpak.com
!
!
!
ip domain name dibpak.com
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
isdn switch-type primary-net5
!
cts logging verbose
!
!
voice-card 0
!
!
!
voice service voip
ip address trusted list
  ipv4 x.x.x.x x.x.x.x
  ipv4 x.x.x.x x.x.x.x
no supplementary-service sip handle-replaces
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
!
!
voice iec syslog
!
voice statistics type iec
!
!
license udi pid CISCO2901/K9 sn FGL19352319
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
username admin password 7 045A0F0B062F
username cisco privilege 15 secret 5 $1$Gk8v$kKFiEIyilwgMWJKRBoHyy/
!
redundancy
!
!
controller E1 0/0/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 0/1/0
pri-group timeslots 1-31
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address x.x.x.x x.x.x.x
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr x.x.x.x
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
!
interface Serial0/1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
ip route x.x.x.x x.x.x.x
ip route x.x.x.x x.x.x.x
!
!
!
!
control-plane
!
!
voice-port 0/0/0:15
!
voice-port 0/1/0:15
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/2/2
!
voice-port 0/2/3
!
voice-port 0/3/0
!
voice-port 0/3/1
!
voice-port 0/3/2
!
voice-port 0/3/3
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 200 pots
incoming called-number 311845[2-3]...
port 0/0/0:15
!
dial-peer voice 100 pots
destination-pattern .T
port 0/0/0:15
!
dial-peer voice 300 voip
destination-pattern 2133142[8-9]..
session target ipv4:192.168.33.4
codec g711ulaw
!
dial-peer voice 400 voip
destination-pattern 21331430..
session target ipv4:192.168.33.4
!
dial-peer voice 500 voip
preference 1
destination-pattern 2133142[8-9]..
session target ipv4:x.x.x.x
!
dial-peer voice 600 voip
preference 1
destination-pattern 21331430..
session target ipv4:x.x.x.x
!
dial-peer voice 101 pots
destination-pattern 0T
port 0/0/0:15
!
dial-peer voice 2901 pots
destination-pattern 2901
port 0/3/0
!
!
!
!
gatekeeper
shutdown
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4

login local
transport input all
line vty 5 15
login local
transport input none
scheduler allocate 20000 1000
!

VIP Rising star

Re: Call routing issue

You should voip dial-peers (identical to 300,400,500,600) that would route the range that number 3118452946 is part of. Of-course, at the destination platform (eg 192.168.33.4) you should add the proper translation (you can look what you do for the 2133142[8-9].. range), so that 3118452946 is translated to some internal extension.

Georgios
Please rate if you find this helpful.

View solution in original post

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards