cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1432
Views
10
Helpful
6
Replies
Highlighted
Beginner

calling name and alerting name with sip gateway

topology:

[cucm] -- sip -- [2821 router] -- Q.Sig on T1 PRI -- [Nortel PBX]

Q: Can CUCM/[IP phones] get calling name or alerting name from SIP gateway (2821 router)? The router used to be configured as MGCP gateway, both names were sent to CUCM.

Any comment is appreciated!

Jonathan

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Ok, do you have "isdn supp-service name calling"

and "voice service voip

qsig decode" ?

Then take "debug ccsip message".

View solution in original post

6 REPLIES 6
Highlighted
Hall of Fame Master

Yes.

Highlighted

thanks Paolo. I set up the sip gateway, when i make outbound call from IP Phone, the other party with Nortel phone sees my name, but i don't see hers(alerting name), do you have this experience?

Highlighted

Start checking "debug isdn q931".

Highlighted

PBX does send facility IE over:

Oct 25 15:20:23.662 PST: ISDN Se0/1/0:23 Q931: RX <- CALL_PROC pd = 8  callref = 0x80F4

        Channel ID i = 0xA98397

                Exclusive, Channel 23

Oct 25 15:20:23.790 PST: ISDN Se0/1/0:23 Q931: RX <- ALERTING pd = 8  callref = 0x80F4

SI2821-2#

Oct 25 15:20:26.558 PST: ISDN Se0/1/0:23 Q931: RX <- CONNECT pd = 8  callref = 0x80F4

        Facility i = 0x9FAA068001008201008B0100A11602020100020102800D4D61726965204D63496E6E6573

i think it's SIP that doesn't transform alerting name and send it to cucm.

Highlighted

Ok, do you have "isdn supp-service name calling"

and "voice service voip

qsig decode" ?

Then take "debug ccsip message".

View solution in original post

Highlighted

i put "isdn supp-service name calling" on at beginning, that made calling name work.

for alerting name display, "qsig decode" under "voice service voip" does the trick.

by the way, i originally converted the router to H.323 gateway, the name display issue occured. then I tried SIP gateway, same issue happens. After it's resolved on SIP gateway, i go back to H.323 gateway, with same solution, name display works as well.

thanks for the help!

Content for Community-Ad