cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
782
Views
10
Helpful
10
Replies
Suchi
Beginner

calling number from pstn to internal

Hi,

Recently i configured CUCM with MGCP ( CUCM-MGCP-GW-ISDN). But the incoming  number ( calling number from pstn to internal) displays only nine digits ( first 0 dosent display, eg : 413428912  instead of 0413428912).

Please advise

Thanks

Suchira

2 ACCEPTED SOLUTIONS

Accepted Solutions

So you have various options in CUCM to add '0' as prefix to CLI. You can do it on Gateway configuration (inside CUCM) on the basis of number type (viz national, subscriber etc) or use calling party transformation.

View solution in original post

Hi,

Go to your gateway>incoming calling party settings>Number type

set the ff:

National Number--under the prefix colum remove the default and add 0,

international--uder the prefix column remove the default and add 011

untick use device pool css..

Save,

then do

"conf t

no mgcp

mgcp"

 

NB: This is service disrupting as active calls will be dropped once you do a no mgcp..do do it at a less busy time

 

Please rate all useful posts

View solution in original post

10 REPLIES 10
Vivek Batra
Engager

What TELCO is sending? Please verify the same using debug isdn q931 and share the output.

Hi,

below is the debug & Telco sends only 9 digits.What is the best way to add aonther digit?

 

Sep 17 11:17:12.504: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x0073
        Sending Complete
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA18385
                Preferred, Channel 5
        Calling Party Number i = 0x2183, '413427982'
                Plan:ISDN, Type:National
        Called Party Number i = 0xC1, '85877576'
                Plan:ISDN, Type:Subscriber(local)
Sep 17 11:17:12.520: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x8073
        Channel ID i = 0xA98385
                Exclusive, Channel 5
Sep 17 11:17:12.520: ISDN Se0/0/0:15 Q931: TX -> ALERTING pd = 8  callref = 0x8073
        Progress Ind i = 0x8088 - In-band info or appropriate now available
Sep 17 11:17:20.588: ISDN Se0/0/0:15 Q931: TX -> CONNECT pd = 8  callref = 0x8073
Sep 17 11:17:20.608: ISDN Se0/0/0:15 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x0073
Sep 17 11:17:29.444: ISDN Se0/0/0:15 Q931: TX -> DISCONNECT pd = 8  callref = 0x8073
        Cause i = 0x8090 - Normal call clearing
Sep 17 11:17:29.512: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x0073
Sep 17 11:17:29.536: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8073

So you have various options in CUCM to add '0' as prefix to CLI. You can do it on Gateway configuration (inside CUCM) on the basis of number type (viz national, subscriber etc) or use calling party transformation.

View solution in original post

Hi,

Go to your gateway>incoming calling party settings>Number type

set the ff:

National Number--under the prefix colum remove the default and add 0,

international--uder the prefix column remove the default and add 011

untick use device pool css..

Save,

then do

"conf t

no mgcp

mgcp"

 

NB: This is service disrupting as active calls will be dropped once you do a no mgcp..do do it at a less busy time

 

Please rate all useful posts

View solution in original post

Imran Ul Haq
Beginner

this is usual behaviour from some telco's. 

therefore if you have something like an inbound dial-peer as below - then you can direct the call as you please:

 

dial peer voice 10 pots
incomng called number .
direct inward dial
port y/y/y:15

that will be for the incoming call leg

then you can create a dial-peer for the voip call leg which will be outbound towards the cucm server

dial peer voice 20 voip
Destination pattern <pattern>
session target ipv4: <cucm ip address>
voice class codec <number>

Imran,

This is mgcp gateway. Calls are not routed via any dial-peers.

Can you please send your debug isdn q931..so we know if the Telco is sending the leading zero..as said earlier most of them don't send the leading zero. You will need to prefix this in cucm

Please rate all useful posts

Hi,

Just adding to Ayodeji, Telco at times (atleast in North America) sends digits per our request (either 4 digit or 10 digits).

Please confirm with the Telco what exactly they are sending and reconfirm with them.

However if the PSTN is not able to send the preceding 0, then you may add it using Translation Pattern or Calling Transformation Pattern.

Could you please describe what is the desired effect you wanted to achieve?

Regards

Nathan Compton
Enthusiast

0 could be prepended in the inbound gateway config or with a calling party transformation applied to the MGCP T1.

Hi,

 

I am just going to organize the steps which have been mentioned by the team (as they are relevant to my point of view):

 

1. Check debug isdn q931 and see what the calling number sent by telco. They might not be sending '0'.

2. Check the debug mgcp packets to see if the gateway is sending '0' to CUCM or it is getting stripped in the gateway

3. If '0' is being sent with calling number to CUCM, generate a DNA report from CUCM to see what is happening to the call and where this is getting stripped in CUCM

Suchi
Beginner

Thanks guys, it works ....

Content for Community-Ad

Spotlight Awards 2021