cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1510
Views
19
Helpful
16
Replies
monasir
Beginner

Calls not able to route out of the local gateway

I am not able to place calls from my ucm phones to my pstn site.

What i did is the following:

I created routegroups, ( added my branch gateway in selected devices also the same thing for my hq router.

Created dial-peers in my hq router:

I am not able to call 911 to my pstn site, i created a routepattern in cucm which is pointing to my local gateway of cucm.

I'm hearing a busy tone., i am able to call from pstn to hq and branch sites.

In my hq and branch router if i debug i don't see nothing comes in.

I also created 2 calling party transformation patterns ( 1XXX and 5XXX)

I have to send a e164 format number to the pstn site. ( +1212394XXX) i also did this.

Voice translation rules also have been created.

But somethings goes wrong, i don't see the call arrives in the gateway when i debug isdn.

The strang part of this task is that i have to create a RL in cucm and point it to the created routed pattern (911)

When placing a call to the hq site i see its going true the branch1 gateway.

HQ router

HQ-RTR#sh run

Building configuration...

Current configuration : 3360 bytes

!

! Last configuration change at 12:46:03 PST Mon Jan 28 2013

! NVRAM config last updated at 12:45:36 PST Mon Jan 28 2013

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname HQ-RTR

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

clock timezone PST -8

network-clock-participate wic 2

dot11 syslog

ip source-route

!

!

!

!

ip cef   

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-ni

!

!

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

!

!

voice class h323 1

  h225 timeout tcp establish 3

!

!

!

!

!

!        

!

!

!

!

voice translation-rule 911

rule 1 /^1/ /+1/

!

!

voice translation-profile ANI-OUT

translate calling 911

!

!

voice-card 0

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

controller T1 0/2/0

pri-group timeslots 1-3,24

!

controller T1 0/2/1

!

!

!

!

!

interface Loopback0

ip address 10.10.110.1 255.255.255.255

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.10

encapsulation dot1Q 10 native

ip address 10.10.100.1 255.255.255.0

!

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 10.10.200.3 255.255.255.0

ip helper-address 10.10.210.10

h323-gateway voip bind srcaddr 10.10.200.3

!

interface FastEthernet0/0.30

encapsulation dot1Q 30

ip address 10.10.210.1 255.255.255.0

!

interface FastEthernet0/1

no ip address

speed 100

full-duplex

!

interface Serial0/1/0

description network connection to Branch1 router

ip address 10.10.111.1 255.255.255.0

encapsulation ppp

ip ospf mtu-ignore

clock rate 64000

!

interface Serial0/1/1

description network connection to Branch2 router

ip address 10.10.112.1 255.255.255.0

encapsulation ppp

ip ospf mtu-ignore

clock rate 64000

!

interface Serial0/2/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn outgoing display-ie

no cdp enable

!

interface Serial0/3/0

no ip address

shutdown

no fair-queue

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

ip forward-protocol nd

no ip http server

ip http authentication local

no ip http secure-server

!

!

!

disable-eadi

!

!

!

!

!

!

!        

control-plane

!

!

!

voice-port 0/2/0:23

!

ccm-manager fax protocol cisco

!

!

!

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

!

dial-peer voice 5001 voip

destination-pattern 2123945...

voice-class codec 1

voice-class h323 1

session target ipv4:10.10.210.10

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 911 pots

translation-profile outgoing ANI-OUT

destination-pattern 911

no digit-strip

port 0/2/0:23

forward-digits 3

!

!

sip-ua

retry invite 2

timers trying 300

!

!

!

gatekeeper

zone local PL proctorlabs.com

zone prefix PL 1... gw-priority 10 gk-trunk_2

zone prefix PL 1... gw-priority 9 gk-trunk_1

zone prefix PL 1... gw-priority 0 BR2-RTR

zone prefix PL 5... gw-priority 10 gk-trunk_2

zone prefix PL 5... gw-priority 9 gk-trunk_1

zone prefix PL 5... gw-priority 0 BR2-RTR

no shutdown

!

!

line con 0

exec-timeout 0 0

password cisco

login

line aux 0

line vty 0 4

exec-timeout 0 0

password cisco

login

transport input telnet

!

scheduler allocate 20000 1000

ntp source Loopback0

ntp master 5

ntp server 10.10.210.1

end

Branch1 router

BR1-RTR#sh run

Building configuration...

Current configuration : 2818 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname BR1-RTR

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret 5 $1$wNOA$XSwMLgrwkVM.XnurXmwyJ.

!

no aaa new-model

network-clock-participate wic 2

dot11 syslog

ip source-route

!

!

!

!

ip cef

ip domain name proctorlabs.com

no ipv6 cef

!        

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-ni

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

!

!        

!

!

archive

log config

  hidekeys

!

!

!

!

!

controller T1 0/2/0

pri-group timeslots 1-3,24 service mgcp

!

controller T1 0/2/1

!

!

!

!

!

interface Loopback0

ip address 10.10.110.2 255.255.255.255

ip ospf network point-to-point

!

interface FastEthernet0/0

ip address 10.10.210.16 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1/0

switchport trunk native vlan 130

switchport mode trunk

switchport voice vlan 240

!

interface FastEthernet0/1/1

switchport trunk native vlan 130

switchport mode trunk

switchport voice vlan 240

!

interface FastEthernet0/1/2

switchport trunk native vlan 130

switchport mode trunk

switchport voice vlan 240

!

interface FastEthernet0/1/3

switchport trunk native vlan 130

switchport mode trunk

switchport voice vlan 240

!        

interface Serial0/2/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial0/3/0

ip address 10.10.111.2 255.255.255.0

encapsulation ppp

ip ospf mtu-ignore

!

interface Serial0/3/1

no ip address

clock rate 2000000

!

interface Vlan1

no ip address

!

interface Vlan130

ip address 10.10.101.1 255.255.255.0

!

interface Vlan240

ip address 10.10.201.1 255.255.255.0

ip helper-address 10.10.210.10

!        

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

disable-eadi

!

!

!

!

!

!

!

control-plane

!

!

!

voice-port 0/2/0:23

!

ccm-manager switchback immediate

ccm-manager redundant-host 10.10.210.10

ccm-manager mgcp

ccm-manager fax protocol cisco

!

mgcp

mgcp call-agent 10.10.210.10 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp bind control source-interface Loopback0

mgcp bind media source-interface Loopback0

!

mgcp profile default

!

!

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

exec-timeout 0 0

password cisco

login

line aux 0

line vty 0 4

exec-timeout 0 0

privilege level 15

password cisco

login

transport preferred none

transport input telnet

line vty 5 15

exec-timeout 0 0

privilege level 15

logging synchronous

no login

transport preferred none

!

scheduler allocate 20000 1000

end

1 ACCEPTED SOLUTION

Accepted Solutions

do not use any thing in Router pattern , use default , use route list ( rl-local-gw)..

cheers

Amim

Note:Rate if you find useful.

.

View solution in original post

16 REPLIES 16
Chris Deren
Hall of Fame Master

What version of CUCM are you using and what is Dialed Number Analyzer showing?

Have you tried "debug voice dialpeer"?

Chris

Hi Chris,

I'm using version 8.

I don't see anything comes in the gateway.

I haven't used DNA yet.

mohamed

Hi,

You need to create Route list , and that need to be mapped with local standard route group and that need to maped with devcie pool , and in route pattern you need ti use that route list .

Rgds
amim

Hi Amim,

What i did was the following:

Created 2 routegroups (HQ and BR1)

Added the h323 gateway and the br1 gateway in the selected devices.

Then i created a routelist ( rl-local-gw)

Then i created a routepattern (911)

This routepattern is mapped to the above routelist

After that i've applied the routelist at both devicepools (HQ, BR1 devicepools)

Created css & partitions.

2 calling transformations patterns  ( 1XXX & 5XXX )

After that i created voice translations rules as i've mentioned in my above post.

But still after al my configurations i don't see anything comes in my HQ router, you don't see the call comes in my router if

i do a debug isdn q931 nothing comes in.

Chris Deren
Hall of Fame Master

What are you dialing? Are you dialing 911? You mention adding RG to DP, so are you using local route group feature on other route patterns?

Go to serviceability page and find Dialed Number Analyzer and use to to see what CUCM is doing, this is very simple tool that will show you what is going on.

HTH,

Chris

I'm dialing 911

Yes that's true, i'm using local routegroup.

When i create a routelist, i'm adding standard local route group.

I'm going to try the dna.

HI,

in H323

use this

voice translation-rule 1

rule 1 // // type any unknown plan any isdn

voice translation-rule 2

rule 1 /^XXX/ /XXXXXX$/ type any national plan any isdn

where X is any isdn

Voice translation-profile 911

translate calling 2

translate called 1

dial-peer voice 1 pots

translation-profile outgoing 911

destination-pattern 911

no digit-strip

port XXXXX

and in route list , first prefrence give standard local route group , then go to device pool , and in local route group select

BR1 Route Group

then check

Amim

Note:Rate if you find useful.

do not use any thing in Router pattern , use default , use route list ( rl-local-gw)..

cheers

Amim

Note:Rate if you find useful.

.

View solution in original post

Thank you,

I'm going to try this when i'm at home.

Chris Deren
Hall of Fame Master

Amim,

Please review his responses, he is using Local Route Group feature.

Chris

Yes cris , thats why   i told him to go to device pool , and i in local route group , slect BR1 Route Group., it will work as in locla route group , gateway is bidned with device pool of BR1 , so every time 911 calls will only use BR1 gateway.

rgds

Amim

Note:Rate if you find useful.

Hi Guys,

It worked.

I've only changed something in my routepattern (911)

I didn't select anything on my routepartition ( nowe i have "none")

Before i had a partition called " pt-nanp-911 "

Very strange, the book is explaining that you could put it in a partition in case we had phones in other dialing domains

registered to UCM which should not be able to dial 911.

Can someone please explain this to me?

Guys Thanks anyway for such the great help!

Chris Deren
Hall of Fame Master

Apparently your phone's CSS does not have access to this partition, having patterns/DNs in none partition is a very bad practice which will lead your deployment to run into many limitations, it is especially bad when you have remote sites as now you have no controll over which site calls go out of.  If you do not understand partitions and CSSes I suggest you read the SRND and system guide as that is the most fundamental items in CUCM.

HTH, please rate all useful posts!

Chris

Hi Chris,

Thanks for your advise.

By the way this is for lab purposes not a real live environment.

Content for Community-Ad

Spotlight Awards 2021