cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
440
Views
0
Helpful
6
Replies
Highlighted
Beginner

Can't call from SCCP phone to Analog FXS

Hi,

I have some problem here in CME 2811.

Please inform me which part I miss

thanks

 

PROBLEM:
1. SCCP Phone ext 2001 can't call Analog phone extension 2021 on FXS port 0/0/0
2. Analog phone extension 2021 on FXS port 0/0/0 can call SCCP Phone ext 2001 but shown as Unknown Number
 
HW INFO:
-2811 flash:c2800nm-adventerprisek9-mz.151-4.M10.bin
VIC2-4FXO
VIC-4FXS/DID
PVDM2-32+PVDM2-16
-7912
 
#sh voice port sum
                                           IN       OUT
PORT            CH   SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
=============== == ============ ===== ==== ======== ======== ==
0/0/0           --  fxs-ls      up    dorm on-hook  idle     y
0/0/1           --  fxs-ls      up    dorm on-hook  idle     y
0/0/2           --  fxs-ls      up    dorm on-hook  idle     y
0/0/3           --  fxs-ls      up    dorm on-hook  idle     y
0/2/0           --  fxo-ls      up    dorm idle     on-hook  y
0/2/1           --  fxo-ls      up    dorm idle     on-hook  y
0/2/2           --  fxo-ls      up    dorm idle     on-hook  y
0/2/3           --  fxo-ls      up    dorm idle     on-hook  y
50/0/1          1      efxs     up    dorm on-hook  idle     y
50/0/1          2      efxs     up    dorm on-hook  idle     y
50/0/2          1      efxs     up    up   on-hook  idle     y
50/0/2          2      efxs     up    up   on-hook  idle     y
50/0/3          1      efxs     up    dorm on-hook  idle     y
50/0/3          2      efxs     up    dorm on-hook  idle     y
50/0/4          1      efxs     up    dorm on-hook  idle     y
50/0/5          1      efxs     up    up   on-hook  idle     y
50/0/5          2      efxs     up    up   on-hook  idle     y
PWR FAILOVER PORT        PSTN FAILOVER PORT
=================        ==================
 
#show dial-peer voice summary
dial-peer hunt 0
             AD                                    PRE PASS                OUT
TAG    TYPE  MIN  OPER PREFIX    DEST-PATTERN      FER THRU SESS-TARGET    STAT PORT    KEEPALIVE
1      voip  up   up             [+,9]1[2-9]..[2--  0  syst dns:sip.sg.didlogic.
                                 9]......
6      voip  up   up             [+,9]852........   0  syst dns:sip1.hoiio.com
3      pots  up   down 9         911                0                      down
4      pots  up   down           9911               0                      down
16     voip  up   up             [+628,908]......-  0  syst ipv4:10.0.10.77
                                 ..T
10     voip  up   up                                0  syst
20     voip  up   up                                0  syst
2      pots  up   down                              0                      down
41     voip  up   up             081298998222       0  syst ipv4:10.0.10.77
1000   voip  up   up             1...               0  syst ipv4:10.0.10.77
2021   pots  up   up             2021               0                      up   0/0/0
20001  pots  up   up             2001$              0                           50/0/1
20002  pots  up   up             2002$              0                           50/0/2
20003  pots  up   up             2003$              0                           50/0/3
20004  pots  up   up             888$               0                           50/0/4
20005  pots  up   up             2004$              0                           50/0/5
 
# sh run
voice service voip
ip address trusted list
  ipv4 192.170.159.194 255.255.255.255
  ipv4 54.251.255.196 255.255.255.255
  ipv4 10.0.10.0 255.255.255.0
  ipv4 10.0.20.0 255.255.255.0
  ipv4 10.0.30.0 255.255.255.0
  ipv4 10.0.41.0 255.255.255.0
  ipv4 10.0.43.0 255.255.255.0
  ipv4 10.0.42.0 255.255.255.0
  ipv4 10.0.44.0 255.255.255.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
redirect ip2ip
sip
  bind control source-interface FastEthernet0/0
  bind media source-interface FastEthernet0/0
  registrar server expires max 600 min 60
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 3 g729r8
voice register global
mode cme
source-address 10.0.10.206 port 5060
max-dn 144
max-pool 35
authenticate register
authenticate realm poc.com
tftp-path flash:
file text
create profile sync 0004537381553209
!
voice register dn  2
number 2011
name Adi Sasongko
shared-line
label Adi (x2011)
!
voice register pool  1
id mac 0000.0000.2011
number 1 dn 2
username Adi password 1234
!
voice translation-rule 1
!
voice translation-rule 9
rule 1 /^9/ //
!
voice translation-rule 628
rule 1 /^628/ /08/
!
voice translation-rule 9628
rule 1 /^9/ //
rule 2 /^\(.+62\)/ /0/
!
voice translation-profile 9
translate called 9
!
voice translation-profile 9628
translate called 9628
!
voice translation-profile VOICE_SECURITY_AUDIT_BLOCK
translate called 1
!
voice-card 0
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.10.206 255.255.255.0
ip pim sparse-dense-mode
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.31.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
router eigrp 1
network 1.1.1.1 0.0.0.0
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http secure-port 8443
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip pim rp-address 10.0.10.206
ip nat inside source list 101 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 10.0.10.1
!
ip access-list standard blockedhost
deny   46.165.249.4
deny   118.136.227.177
permit any
tftp-server flash:CP7912080004SCCP080108A.sbin
control-plane
!
call threshold global cpu-avg low 68 high 75
call threshold global total-mem low 75 high 85
!
voice-port 0/0/0
cptone ID
timeouts interdigit 5
timeouts ringing infinity
description FXS0
station-id number 2021
caller-id enable
!
voice-port 0/0/1
cptone ID
caller-id enable
!
voice-port 0/0/2
cptone ID
caller-id enable
!
voice-port 0/0/3
cptone ID
caller-id enable
!
voice-port 0/2/0
timeouts interdigit 5
connection plar 2001
description IncomingFXO0
station-id number 081298998222
caller-id enable
!
voice-port 0/2/1
voice-port 0/2/2
voice-port 0/2/3
!
ccm-manager music-on-hold
mgcp fax t38 ecm
mgcp profile default
!
dial-peer voice 1 voip
description Outgoing SIP DIDLogic
translation-profile outgoing 9
destination-pattern [+,9]1[2-9]..[2-9]......
session protocol sipv2
session target dns:sip.sg.didlogic.net
voice-class codec 1
dtmf-relay sip-notify
!
dial-peer voice 3 pots
description 911
translation-profile outgoing 9
destination-pattern 911
prefix 9
!
dial-peer voice 4 pots
description 9911
translation-profile outgoing 9
destination-pattern 9911
!
dial-peer voice 16 voip
description Outgoing SIP CUCM
translation-profile outgoing 9628
destination-pattern [+628,908]........T
session protocol sipv2
session target ipv4:10.0.10.77
codec g711ulaw
!
dial-peer voice 10 voip
answer-address 1001
voice-class codec 1
!
dial-peer voice 20 voip
answer-address 1001
voice-class codec 1
!
dial-peer voice 2 pots
no digit-strip
!
dial-peer voice 41 voip
description Incoming SIP CUCM
destination-pattern 081298998222
session protocol sipv2
session target ipv4:10.0.10.77
!
dial-peer voice 1000 voip
destination-pattern 1...
session target ipv4:10.0.10.77
!
dial-peer voice 2021 pots
destination-pattern 2021
incoming called-number 2...
port 0/0/0
!
num-exp 14159172000 1001
num-exp 081298998222 2001
sip-ua
credentials username 08844 password 7 01232617481C561D22 realm sip.sg.didlogic.net
authentication username 08844 password 7 15222B1F173D7B3622 realm sip.sg.didlogic.net
registrar 1 dns:sip.sg.didlogic.net expires 3600
sip-server dns:sip.didlogic.net
!
telephony-service
no auto-reg-ephone
max-ephones 35
max-dn 144
ip source-address 10.0.10.206 port 2000
max-redirect 5
timeouts interdigit 5
cnf-file location flash:
load 7912 CP7912080004SCCP080108A.sbin
date-format dd-mm-yy
max-conferences 8 gain -6
moh flash:/Wave.au
multicast moh 239.1.1.1 port 2000 route 10.0.10.1
web admin system name admin secret 5 $1$JGDo$afA54af/90u3S4gnt0sUPP
transfer-system full-consult
transfer-pattern 2...
create cnf-files version-stamp 7960 Sep 29 2015 13:21:21
!
ephone-dn  1  dual-line
number 2001 no-reg both
label Alabama (x2001)
name Alabama City
!
ephone-dn  2  dual-line
number 2002 no-reg both
label Boston (x2002)
name Boston City
!
ephone-dn  3  dual-line
number 2003 no-reg both
label Chicago (x2003)
mobility
snr +6287809777444 delay 10 timeout 30
!
ephone-dn  4
number 888 no-reg both
name POC-Paging
paging ip 239.1.1.2 port 2000
!
ephone-dn  5  dual-line
number 2004
label Delaware (x2004)
!
ephone  1
device-security-mode none
mac-address 000B.BE3B.9E9C
username "Alabama" password 1234
type 7912
button  1:1
pin 1234
!
ephone  2
device-security-mode none
mac-address 0012.0127.A14A
username "Boston" password 1234
paging-dn 4
type 7912
button  1:2
pin 1234
!
ephone  3
device-security-mode none
mac-address E0DB.55A9.B3D5
username "Chicago" password 1234
paging-dn 4
type CIPC
button  1:3
pin 1234
6 REPLIES 6
Highlighted
Engager

Please share the ouput of debug ccapi inout (SCCP to FXS)...

Highlighted
Cisco Employee

along with Debug voice ccapi inout also collect debug vtsp all and vpm signal too.

 

Br,
nadeem ahmed

Br, Nadeem Please rate all useful post.
Highlighted

Here the result of calling SCCP x2001 to Analog FXS x2021.

SCCP x2001 shown ringout but Analog FXS x2021 never ring

#debug voice ccapi inout
#debug vtsp all
#debug vpm signal
#term mon


Sep 30 21:57:27.820: htsp_dsp_message: SEND_SIG_STATUS: state=0xC timestamp=4640 systime=96515
Sep 30 21:57:27.820: htsp_process_event: [50/0/1.1, EFXS_ONHOOK, E_DSP_SIG_1100]efxs_onhook_offhook htsp_setup_ind
Sep 30 21:57:27.820: [50/0/1.1] get_local_station_id calling num=2001 calling name=Alabama City calling time=10/01 04:57  orig called=
Sep 30 21:57:27.828: //-1/131AB16E802B/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=
   ----- ccCallInfo IE subfields -----
   cisco-ani=2001
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=0
   dest=
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=0
   cisco-rdnsi=0
   cisco-redirectreason=0   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

Sep 30 21:57:27.828: //-1/131AB16E802B/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x4C8AF93C, Call Info(
   Calling Number=2001,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE,
   Incoming Dial-peer=20001, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=TRUE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1
Sep 30 21:57:27.828: //-1/131AB16E802B/CCAPI/ccCheckClipClir:
   In: Calling Number=2001(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
Sep 30 21:57:27.832: //-1/131AB16E802B/CCAPI/ccCheckClipClir:
   Out: Calling Number=2001(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
Sep 30 21:57:27.832: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Sep 30 21:57:27.832: :cc_get_feature_vsa malloc success
Sep 30 21:57:27.832: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Sep 30 21:57:27.832:  cc_get_feature_vsa count is 1
Sep 30 21:57:27.832: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Sep 30 21:57:27.832: :FEATURE_VSA attributes are: feature_name:0,feature_time:1232744648,feature_id:9
Sep 30 21:57:27.832: //68/131AB16E802B/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=2001(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=(TON=Unknown, NPI=Unknown))
Sep 30 21:57:27.832: //68/131AB16E802B/CCAPI/cc_process_call_setup_ind:
   Event=0x4B96A308
Sep 30 21:57:27.832: //68/131AB16E802B/CCAPI/ccCallSetContext:
   Context=0x4CDDB15C
Sep 30 21:57:27.836: //68/131AB16E802B/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 68 with tag 20001 to app "_ManagedAppProcess_Default"
Sep 30 21:57:27.836: //68/131AB16E802B/CCAPI/ccCallSetupAck:
   Call Id=68
Sep 30 21:57:27.836: //68/131AB16E802B/CCAPI/cc_api_set_transfer_info:
   Transfer Number=, Transfer Reason=0x0
Sep 30 21:57:27.836: //68/131AB16E802B/CCAPI/ccGenerateToneInfo:
   Stop Tone On Digit=TRUE, Tone=Dial Tone,
   Tone Direction=Network, Params=0x0, Call Id=68
Sep 30 21:57:27.836: //68/131AB16E802B/CCAPI/ccSetDigitTimeouts:
   Initial Digit Timeout=-1000(ms), Inter Digit Timeout=-1000(ms)
Sep 30 21:57:27.836: //68/131AB16E802B/CCAPI/ccSetDigitTimeouts:
   Call Entry(Inter Digit Timeout=10000(ms), Initial Digit Timeout=10000(ms))
Sep 30 21:57:27.836: //68/131AB16E802B/CCAPI/ccCallReportDigits:
   (callID=0x44, digit_event=0x1, enable=TRUE, consume=FALSE)
Sep 30 21:57:27.840: //68/131AB16E802B/CCAPI/ccCallReportDigits:
   Enabled=TRUE, Call Id=68
Sep 30 21:57:27.840: //68/131AB16E802B/CCAPI/cc_api_call_report_digits_done:
   (vdbPtr=0x4C8AF93C, callID=0x44, disp=0, digit_event=0x1, enable=TRUE, consume=FALSE)
Sep 30 21:57:27.840: //68/131AB16E802B/CCAPI/cc_api_call_report_digits_done:
   Enabled=TRUE, Disposition=0x0, Interface=0x4C8AF93C, Call Id=68
Sep 30 21:57:27.840: //68/131AB16E802B/CCAPI/cc_api_call_report_digits_done:
   Call Entry(Initial Digit Timeout=15000(ms), Inter Digit Timeout=5000(ms))
Sep 30 21:57:27.840: htsp_process_event: [50/0/1.1, EFXS_WAIT_SETUP_ACK, E_HTSP_SETUP_ACK]efxs_check_auto_call
Sep 30 21:57:29.760: //68/131AB16E802B/CCAPI/cc_api_call_digit_begin:
   Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
   Source Call Id=68, Digit=2, DigitBeginFlags=0x0,
   Rtp Timestamp=0xA1608, Rtp Expiration=0x0
Sep 30 21:57:29.760: //68/131AB16E802B/CCAPI/cc_api_call_digit_end:
   Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
   Source Call Id=68, Digit=2, Duration=100,
   Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
Sep 30 21:57:29.760: //68/131AB16E802B/CCAPI/cc_api_call_digit_end:
   Call Entry(Handoff Depth=0)
Sep 30 21:57:29.760: htsp_digit_ready(50/0/1.1): digit = 2
Sep 30 21:57:30.400: //68/131AB16E802B/CCAPI/cc_api_call_digit_begin:
   Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
   Source Call Id=68, Digit=0, DigitBeginFlags=0x0,
   Rtp Timestamp=0xA9308, Rtp Expiration=0x0
Sep 30 21:57:30.400: //68/131AB16E802B/CCAPI/cc_api_call_digit_end:
   Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
   Source Call Id=68, Digit=0, Duration=100,
   Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
Sep 30 21:57:30.400: //68/131AB16E802B/CCAPI/cc_api_call_digit_end:
   Call Entry(Handoff Depth=0)
Sep 30 21:57:30.400: htsp_digit_ready(50/0/1.1): digit = 0
Sep 30 21:57:31.008: //68/131AB16E802B/CCAPI/cc_api_call_digit_begin:
   Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
   Source Call Id=68, Digit=2, DigitBeginFlags=0x0,
   Rtp Timestamp=0xB1008, Rtp Expiration=0x0
Sep 30 21:57:31.012: //68/131AB16E802B/CCAPI/cc_api_call_digit_end:
   Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
   Source Call Id=68, Digit=2, Duration=100,
   Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
Sep 30 21:57:31.012: //68/131AB16E802B/CCAPI/cc_api_call_digit_end:
   Call Entry(Handoff Depth=0)
Sep 30 21:57:31.012: htsp_digit_ready(50/0/1.1): digit = 2
Sep 30 21:57:31.480: //68/131AB16E802B/CCAPI/cc_api_call_digit_begin:
   Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
   Source Call Id=68, Digit=1, DigitBeginFlags=0x0,
   Rtp Timestamp=0xB8D08, Rtp Expiration=0x0
Sep 30 21:57:31.480: //68/131AB16E802B/CCAPI/cc_api_call_digit_end:
   Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
   Source Call Id=68, Digit=1, Duration=100,
   Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
Sep 30 21:57:31.480: //68/131AB16E802B/CCAPI/cc_api_call_digit_end:
   Call Entry(Handoff Depth=0)
Sep 30 21:57:31.480: htsp_digit_ready(50/0/1.1): digit = 1
Sep 30 21:57:31.484: //68/131AB16E802B/CCAPI/ccCallReportDigits:
   (callID=0x44, digit_event=0x0, enable=FALSE, consume=FALSE)
Sep 30 21:57:31.484: //68/131AB16E802B/CCAPI/ccCallReportDigits:
   Enabled=TRUE, Call Id=68
Sep 30 21:57:31.484: //68/131AB16E802B/CCAPI/cc_api_call_report_digits_done:
   (vdbPtr=0x4C8AF93C, callID=0x44, disp=0, digit_event=0x0, enable=FALSE, consume=FALSE)
Sep 30 21:57:31.484: //68/131AB16E802B/CCAPI/cc_api_call_report_digits_done:
   Enabled=TRUE, Disposition=0x0, Interface=0x4C8AF93C, Call Id=68
Sep 30 21:57:31.484: //68/131AB16E802B/CCAPI/cc_api_call_report_digits_done:
   Call Entry(Initial Digit Timeout=15000(ms), Inter Digit Timeout=5000(ms))
Sep 30 21:57:31.484: //68/131AB16E802B/CCAPI/ccCallProceeding:
   Progress Indication=NULL(0)
Sep 30 21:57:31.488: //68/131AB16E802B/CCAPI/ccCallSetupRequest:
   Destination=, Calling IE Present=TRUE, Mode=0,
   Outgoing Dial-peer=2021, Params=0x4CDDC66C, Progress Indication=ORIGINATING SIDE IS NON ISDN(3)
Sep 30 21:57:31.492: //68/131AB16E802B/CCAPI/ccCheckClipClir:
   In: Calling Number=2001(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
Sep 30 21:57:31.492: //68/131AB16E802B/CCAPI/ccCheckClipClir:
   Out: Calling Number=2001(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
Sep 30 21:57:31.492: //68/131AB16E802B/CCAPI/ccCallSetupRequest:
   Destination Pattern=2021, Called Number=2021, Digit Strip=TRUE
Sep 30 21:57:31.492: //68/131AB16E802B/CCAPI/ccCallSetupRequest:
   Calling Number=2001(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=2021(TON=Unknown, NPI=Unknown),
   Redirect Number=, Display Info=Alabama City
   Account Number=, Final Destination Flag=FALSE,
   Guid=131AB16E-66F5-11E5-802B-9E87BF22F922, Outgoing Dial-peer=2021
Sep 30 21:57:31.492: //68/131AB16E802B/CCAPI/cc_api_display_ie_subfields:
   ccCallSetupRequest:
   cisco-username=
   ----- ccCallInfo IE subfields -----
   cisco-ani=2001
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=0
   dest=2021
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=0
   cisco-rdnsi=0
   cisco-redirectreason=0   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

Sep 30 21:57:31.492: //68/131AB16E802B/CCAPI/ccIFCallSetupRequestPrivate:
   Interface=0x4B9BC8E4, Interface Type=6, Destination=, Mode=0x0,
   Call Params(Calling Number=2001,(Calling Name=Alabama City)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=2021(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,
   Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE, Outgoing Dial-peer=2021, Call Count On=FALSE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)
Sep 30 21:57:31.492: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Sep 30 21:57:31.492: :cc_get_feature_vsa malloc success
Sep 30 21:57:31.492: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Sep 30 21:57:31.492:  cc_get_feature_vsa count is 2
Sep 30 21:57:31.492: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Sep 30 21:57:31.492: :FEATURE_VSA attributes are: feature_name:0,feature_time:1232744872,feature_id:10
Sep 30 21:57:31.496: //69/131AB16E802B/CCAPI/ccIFCallSetupRequestPrivate:
   SPI Call Setup Request Is Success; Interface Type=6, FlowMode=1
Sep 30 21:57:31.496: //69/131AB16E802B/CCAPI/ccCallSetContext:
   Context=0x4CDDC61C
Sep 30 21:57:31.496: //68/131AB16E802B/CCAPI/ccSaveDialpeerTag:
   Outgoing Dial-peer=2021
Sep 30 21:57:31.496: htsp_timer_stop3
Sep 30 21:57:31.496: htsp_process_event: [50/0/1.1, EFXS_OFFHOOK, E_HTSP_PROCEEDING]efxs_offhook_proceeding
Sep 30 21:57:31.496: [50/0/1.1] set signal state = 0x8 timestamp = 0htsp_setup_req
Sep 30 21:57:31.504: htsp_process_event: [0/0/0, FXSLS_ONHOOK, E_HTSP_SETUP_REQ]fxsls_onhook_setuphtsp_progress
Sep 30 21:57:31.504: [0/0/0] set signal state = 0x0 timestamp = 0
Sep 30 21:57:31.504: [0/0/0] htsp_set_caller_id_tx calling num=2001 display_info=Alabama City called num=2021
Sep 30 21:57:31.504: [0/0/0] Caller ID String 80 1E 01 08 31 30 30 31 30 34 35 37 02 04 32 30 30 31 07 0C 41 6C 61 62 61 6D 61 20 43 69 74 79 93
Sep 30 21:57:31.504: [0/0/0] get_caller_id_ring_cadence mode 19, on_time1=1000 off_time1=4000on_time2=0 off_time2=0
Sep 30 21:57:31.504: [0/0/0] htsp_set_caller_id_tx_time Caller ID:FSK_DURING_RING
Sep 30 21:57:31.504: [0/0/0] htsp_start_caller_id_tx string length=33
Sep 30 21:57:31.508: //69/131AB16E802B/CCAPI/cc_api_call_proceeding:
   Interface=0x4B9BC8E4, Progress Indication=NULL(0)
Sep 30 21:57:31.512: //69/131AB16E802B/CCAPI/cc_api_call_cut_progress:
   Interface=0x4B9BC8E4, Progress Indication=INBAND(8), Signal Indication=INTERCEPT(2),
   Cause Value=0
Sep 30 21:57:31.516: //69/131AB16E802B/CCAPI/cc_api_call_cut_progress:
   Call Entry(Responsed=TRUE)
Sep 30 21:57:31.516: //68/131AB16E802B/CCAPI/ccCallCutProgress:
   Progress Indication=INBAND(8), Signal Indication=INTERCEPT(2), Cause Value=0
   Voice Call Send Alert=FALSE, Call Entry(Alert Sent=FALSE)
Sep 30 21:57:31.516: //68/131AB16E802B/CCAPI/ccCallCutProgress:
   Call Entry(Responsed=TRUE)
Sep 30 21:57:31.520: //68/131AB16E802B/CCAPI/ccGenerateToneInfo:
   Stop Tone On Digit=FALSE, Tone=Null,
   Tone Direction=Network, Params=0x0, Call Id=68
Sep 30 21:57:31.520: //68/131AB16E802B/CCAPI/ccConferenceCreate:
   (confID=0x4CFB5080, callID1=0x44, gcid=131AB16E-66F511E5-802B9E87-BF22F922, tag=0x0)
Sep 30 21:57:31.520: //69/131AB16E802B/CCAPI/ccConferenceCreate:
   (confID=0x4CFB5080, callID2=0x45, gcid=131AB16E-66F511E5-802B9E87-BF22F922, tag=0x0)
Sep 30 21:57:31.520: //68/131AB16E802B/CCAPI/ccConferenceCreate:
   Conference Id=0x4CFB5080, Call Id1=68, Call Id2=69, Tag=0x0
Sep 30 21:57:31.520: htsp_call_bridged invoked
Sep 30 21:57:31.520: //68/131AB16E802B/CCAPI/cc_api_bridge_done:
   Conference Id=0x2, Source Interface=0x4C8AF93C, Source Call Id=68,
   Destination Call Id=69, Disposition=0x0, Tag=0xFFFFFFFF
Sep 30 21:57:31.520: htsp_call_bridged invoked
Sep 30 21:57:31.524: //69/131AB16E802B/CCAPI/cc_api_bridge_done:
   Conference Id=0x2, Source Interface=0x4B9BC8E4, Source Call Id=69,
   Destination Call Id=68, Disposition=0x0, Tag=0xFFFFFFFF
Sep 30 21:57:31.524: //68/131AB16E802B/CCAPI/cc_generic_bridge_done:
   Conference Id=0x2, Source Interface=0x4B9BC8E4, Source Call Id=69,
   Destination Call Id=68, Disposition=0x0, Tag=0xFFFFFFFF
Sep 30 21:57:31.524: //68/131AB16E802B/CCAPI/ccConferenceCreate:
   Call Entry(Conference Id=0x2, Destination Call Id=69)
Sep 30 21:57:31.524: //69/131AB16E802B/CCAPI/ccConferenceCreate:
   Call Entry(Conference Id=0x2, Destination Call Id=68)htsp_progress_notify
Sep 30 21:57:31.524: //68/131AB16E802B/CCAPI/cc_api_caps_ind:
   Destination Interface=0x4B9BC8E4, Destination Call Id=69, Source Call Id=68,
   Caps(Codec=0x1, Fax Rate=0x2, Vad=0x1,
   Modem=0x2, Codec Bytes=160, Signal Type=2)
Sep 30 21:57:31.524: //68/131AB16E802B/CCAPI/cc_api_caps_ind:
   Caps(Playout Mode=1, Playout Initial=60(ms), Playout Min=40(ms),
   Playout Max=1000(ms), Fax Nom=300(ms))
Sep 30 21:57:31.524: //69/131AB16E802B/CCAPI/cc_api_caps_ind:
   Destination Interface=0x4C8AF93C, Destination Call Id=68, Source Call Id=69,
   Caps(Codec=0x1, Fax Rate=0x1, Vad=0x1,
   Modem=0x2, Codec Bytes=160, Signal Type=2)
Sep 30 21:57:31.524: //69/131AB16E802B/CCAPI/cc_api_caps_ind:
   Caps(Playout Mode=1, Playout Initial=60(ms), Playout Min=40(ms),
   Playout Max=1000(ms), Fax Nom=300(ms))
Sep 30 21:57:31.528: //69/131AB16E802B/CCAPI/cc_api_caps_ack:
   Destination Interface=0x4C8AF93C, Destination Call Id=68, Source Call Id=69,
   Caps(Codec=g711ulaw(0x1), Fax Rate=FAX_RATE_VOICE(0x2), Vad=OFF(0x1),
   Modem=ON(0x2), Codec Bytes=160, Signal Type=2, Seq Num Start=8249)
Sep 30 21:57:31.528: //68/131AB16E802B/CCAPI/cc_api_caps_ack:
   Destination Interface=0x4B9BC8E4, Destination Call Id=69, Source Call Id=68,
   Caps(Codec=g711ulaw(0x1), Fax Rate=FAX_RATE_NONE(0x1), Vad=OFF(0x1),
   Modem=ON(0x2), Codec Bytes=160, Signal Type=2, Seq Num Start=8215)
Sep 30 21:57:31.528: //68/131AB16E802B/CCAPI/ccCallFeature:
   Feature Type=25, Call Id=68htsp_call_feature:feature 25
htsp_call_feature: caller id enable 0x3 call_connected 0
Sep 30 21:57:31.528: htsp_process_event: [50/0/1.1, EFXS_OFFHOOK, E_HTSP_CALLERID_WAITING]
Sep 30 21:57:31.528: efxs_callerid_update
Sep 30 21:57:31.528: efxs_callerid_update process caller_id_string
Sep 30 21:57:31.528: efxs_callerid_update process caller_id_string OK
Sep 30 21:57:31.528: efxs_callerid_update number= [2021] name= []
Sep 30 21:57:31.532: //68/131AB16E802B/CCAPI/cc_api_voice_mode_event:
   Call Id=68
Sep 30 21:57:31.532: //68/131AB16E802B/CCAPI/cc_api_voice_mode_event:
   Call Entry(Context=0x4CDDB15C)
Sep 30 21:57:31.532: //69/131AB16E802B/CCAPI/cc_api_voice_mode_event:
   Call Id=69
Sep 30 21:57:31.532: //69/131AB16E802B/CCAPI/cc_api_voice_mode_event:
   Call Entry(Context=0x4CDDC61C)
Sep 30 21:57:31.536: htsp_process_event: [50/0/1.1, EFXS_OFFHOOK, E_HTSP_VOICE_CUT_THROUGH]efxs_offhook_cutthru
Sep 30 21:57:31.536: [50/0/1.1] set signal state = 0x7 timestamp = 0
Sep 30 21:57:31.536: //68/131AB16E802B/CCAPI/cc_process_notify_bridge_done:
   Conference Id=0x2, Call Id1=68, Call Id2=69
Sep 30 21:57:31.536: htsp_process_event: [0/0/0, FXSLS_WAIT_OFFHOOK, E_HTSP_VOICE_CUT_THROUGH]fxsls_waitoff_voice
Sep 30 21:57:34.284: htsp_timer_stop3
Sep 30 21:57:48.688: htsp_dsp_message: SEND_SIG_STATUS: state=0x4 timestamp=2568 systime=98602
Sep 30 21:57:48.692: htsp_process_event: [50/0/1.1, EFXS_OFFHOOK, E_DSP_SIG_0100]efxs_offhook_onhook
Sep 30 21:57:48.692: htsp_timer - 10 msec
Sep 30 21:57:48.704: htsp_process_event: [50/0/1.1, EFXS_OFFHOOK, E_HTSP_EVENT_TIMER]efxs_offhook_timer
Sep 30 21:57:48.708: //68/131AB16E802B/CCAPI/cc_api_call_disconnected:
   Cause Value=16, Interface=0x4C8AF93C, Call Id=68
Sep 30 21:57:48.708: //68/131AB16E802B/CCAPI/cc_api_call_disconnected:
   Call Entry(Responsed=TRUE, Cause Value=16, Retry Count=0)
Sep 30 21:57:48.708: //68/131AB16E802B/CCAPI/ccConferenceDestroy:
   Conference Id=0x2, Tag=0x0
Sep 30 21:57:48.708: //68/131AB16E802B/CCAPI/cc_api_bridge_drop_done:
   Conference Id=0x2, Source Interface=0x4C8AF93C, Source Call Id=68,
   Destination Call Id=69, Disposition=0x0, Tag=0x0
Sep 30 21:57:48.708: //69/131AB16E802B/CCAPI/cc_api_bridge_drop_done:
   Conference Id=0x2, Source Interface=0x4B9BC8E4, Source Call Id=69,
   Destination Call Id=68, Disposition=0x0, Tag=0x0
Sep 30 21:57:48.708: //68/131AB16E802B/CCAPI/cc_generic_bridge_done:
   Conference Id=0x2, Source Interface=0x4B9BC8E4, Source Call Id=69,
   Destination Call Id=68, Disposition=0x0, Tag=0x0
Sep 30 21:57:48.712: //69/131AB16E802B/CCAPI/ccCallDisconnect:
   Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
Sep 30 21:57:48.712: //69/131AB16E802B/CCAPI/ccCallDisconnect:
   Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
Sep 30 21:57:48.712: //69/131AB16E802B/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
Sep 30 21:57:48.716: htsp_timer_stop3
Sep 30 21:57:48.716: //68/131AB16E802B/CCAPI/ccCallDisconnect:
   Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=16)
Sep 30 21:57:48.716: //68/131AB16E802B/CCAPI/ccCallDisconnect:
   Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
Sep 30 21:57:48.716: //68/131AB16E802B/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
Sep 30 21:57:48.720: htsp_process_event: [0/0/0, FXSLS_WAIT_OFFHOOK, E_HTSP_RELEASE_REQ]fxsls_waitoff_release
Sep 30 21:57:48.720: [0/0/0] set signal state = 0x4 timestamp = 0
Sep 30 21:57:48.724: //-1/xxxxxxxxxxxx/CCAPI/cc_build_csv_feature_vsa:

Sep 30 21:57:48.724: :Inside cc_build_feature_vsa
Sep 30 21:57:48.724: //-1/xxxxxxxxxxxx/CCAPI/cc_build_csv_feature_vsa:

Sep 30 21:57:48.724:  feature call basic
Sep 30 21:57:48.724: //-1/xxxxxxxxxxxx/CCAPI/cc_build_csv_feature_vsa:

Sep 30 21:57:48.724: cc_build_feature_vsa attr is "TWC","10/01/2015 04:57:31.492","2001","2021",0,10,131AB16E 66F511E5 802B9E87 BF22F922,45,"","","",""
Sep 30 21:57:48.728: htsp_process_event: [50/0/1.1, EFXS_ONHOOK, E_HTSP_RELEASE_REQ]efxs_onhook_release
Sep 30 21:57:48.728: htsp_timer_stop
Sep 30 21:57:48.728: [50/0/1.1] set signal state = 0x4 timestamp = 0
Sep 30 21:57:48.732: //-1/xxxxxxxxxxxx/CCAPI/cc_build_csv_feature_vsa:

Sep 30 21:57:48.732: :Inside cc_build_feature_vsa
Sep 30 21:57:48.732: //-1/xxxxxxxxxxxx/CCAPI/cc_build_csv_feature_vsa:

Sep 30 21:57:48.732:  feature call basic
Sep 30 21:57:48.732: //-1/xxxxxxxxxxxx/CCAPI/cc_build_csv_feature_vsa:

Sep 30 21:57:48.732: cc_build_feature_vsa attr is "TWC","10/01/2015 04:57:27.832","2001","",0,9,131AB16E 66F511E5 802B9E87 BF22F922,44,"","","",""
Sep 30 21:57:48.740: //68/131AB16E802B/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x4C8AF93C, Tag=0x0, Call Id=68,
   Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
Sep 30 21:57:48.740: //68/131AB16E802B/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
Sep 30 21:57:48.744: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Sep 30 21:57:48.744: :cc_free_feature_vsa freeing 497A30C0
Sep 30 21:57:48.744: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Sep 30 21:57:48.744:  vsacount in free is 1
Sep 30 21:57:48.756: //69/131AB16E802B/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x4B9BC8E4, Tag=0x0, Call Id=69,
   Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
Sep 30 21:57:48.756: //69/131AB16E802B/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
Sep 30 21:57:48.756: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Sep 30 21:57:48.756: :cc_free_feature_vsa freeing 497A31A0
Sep 30 21:57:48.756: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Sep 30 21:57:48.756:  vsacount in free is 0

Highlighted
Hall of Fame Master

From the trace everything appears to be working, perhaps there is an issue with the ringer on the analog phone?

What if you just pick the phone up while the caller is calling?

Highlighted

If I pick up, it will be like you pickup handset, you will hear long tone.

Do I need to make the analog phone as SCCP phone.

Because I can successfully call SCCP phone from analog phone, but it displayed as Unknown Number in SCCP phone.

When I try to add analog phone as SCCP phone using CCP. It give me message "No FXS port available in device to create Analog phone"

Do I need to add stcapp like this

http://www.experts-exchange.com/Networking/Telecommunications/IP_Telephony/Q_26836860.html

 

tq

Highlighted

STATUS: DONE

After adding stcapp, I can call Analog FXS from SCPP phone.

Another mistake is I mistakenly put Analog in FXS port 3 instead of 0

Thanks for all of your input

 

#sh run
! No configuration change since last restart
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
hostname RTR2811a
!
boot-start-marker
boot system flash:c2800nm-adventerprisek9-mz.151-4.M10.bin
warm-reboot count 10 uptime 7
boot-end-marker
! card type command needed for slot/vwic-slot 0/1
no logging buffered
enable secret level 1 5 $1$x7gl$51pMNUYmWN1CGmLdk5R11/
enable secret 5 $1$/gpD$2T/eGV0VQPHsiyNHDnRuUU
!
aaa new-model
aaa session-id common
clock timezone Bangkok 7 0
dot11 syslog
ip source-route
ip cef
!
no ip domain lookup
ip domain name poc.com
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip multicast-routing
ip port-map https port tcp 8443
no ipv6 cef
multilink bundle-name authenticated
!
stcapp ccm-group 1
stcapp
stcapp feature access-code
stcapp supplementary-services
 port 0/0/0
  fallback-dn 2021
voice service voip
 ip address trusted list
  ipv4 192.170.159.194 255.255.255.255
  ipv4 54.251.255.196 255.255.255.255
  ipv4 10.0.10.0 255.255.255.0
  ipv4 10.0.20.0 255.255.255.0
  ipv4 10.0.30.0 255.255.255.0
  ipv4 10.0.41.0 255.255.255.0
  ipv4 10.0.43.0 255.255.255.0
  ipv4 10.0.42.0 255.255.255.0
  ipv4 10.0.44.0 255.255.255.0
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 redirect ip2ip
 sip
  bind control source-interface FastEthernet0/0
  bind media source-interface FastEthernet0/0
  registrar server expires max 600 min 60
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 3 g729r8
voice register global
 mode cme
 source-address 10.0.10.206 port 5060
 max-dn 144
 max-pool 35
 authenticate register
 authenticate realm poc.com
 tftp-path flash:
 file text
 create profile sync 0004537381553204
!
voice register dn  2
 number 2011
 name Adi Sasongko
 shared-line
 label Adi (x2011)
!
voice register pool  1
 id mac 0000.0000.2011
 number 1 dn 2
 username Adi password 1234
!
voice translation-rule 1
voice translation-rule 9
 rule 1 /^9/ //
voice translation-rule 628
 rule 1 /^628/ /08/
voice translation-rule 9628
 rule 1 /^9/ //
 rule 2 /^\(.+62\)/ /0/
voice translation-profile 9
 translate called 9
voice translation-profile 9628
 translate called 9628
voice translation-profile VOICE_SECURITY_AUDIT_BLOCK
 translate called 1
voice-card 0
!
license udi pid CISCO2811 sn FTX0918A0PF
archive
 log config
  hidekeys
username admin privilege 15 secret 5 $1$XeEC$YORXhK8ZUtFjwabnYoHpSS
username cisco secret 5 $1$nFBH$Q6uWzeOmiu20v0UFFhqzYY
!
redundancy
no ip ftp passive
gw-accounting file
 primary ftp 10.0.10.112:22/cdr username cisco password 7 02050D48080944
 acct-template callhistory-detail
 maximum retry-count 3
 maximum cdrflush-timer 30
 cdr-format compact
bip host-emulation
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.10.206 255.255.255.0
 ip pim sparse-dense-mode
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.31.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
router eigrp 1
 network 1.1.1.1 0.0.0.0
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http secure-port 8443
ip http timeout-policy idle 60 life 86400 requests 10000
ip pim rp-address 10.0.10.206
ip nat inside source list 101 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 10.0.10.1
!
ip access-list standard blockedhost
 deny   46.165.249.4
 deny   118.136.227.177
 permit any
tftp-server flash:CP7912080004SCCP080108A.sbin
!
control-plane
call threshold global cpu-avg low 68 high 75
call threshold global total-mem low 75 high 85
voice-port 0/0/0
 cptone ID
 timeouts ringing infinity
 caller-id enable
voice-port 0/0/1
 cptone ID
 caller-id enable
voice-port 0/0/2
 cptone ID
 caller-id enable
voice-port 0/0/3
 cptone ID
 caller-id enable
voice-port 0/2/0
 timeouts interdigit 5
 connection plar 081298998288
 description IncomingFXO0
 caller-id enable
voice-port 0/2/1
voice-port 0/2/2
voice-port 0/2/3
ccm-manager music-on-hold
!
mgcp fax t38 ecm
mgcp profile default
!
sccp local FastEthernet0/0
sccp ccm 10.0.10.206 identifier 1 priority 1 version 7.0
sccp
sccp ccm group 1
 bind interface FastEthernet0/0
 associate ccm 1 priority 1
!
dial-peer voice 1 voip
 description Outgoing SIP DIDLogic
 translation-profile outgoing 9
 destination-pattern [+,9]1[2-9]..[2-9]......
 session protocol sipv2
 session target dns:sip.sg.didlogic.net
 voice-class codec 1
 dtmf-relay sip-notify
!
dial-peer voice 6 voip
 description Outgoing SIP Hoiio
 translation-profile outgoing 9
 destination-pattern [+,9]852........
 session protocol sipv2
 session target dns:sip1.hoiio.com
 voice-class codec 1
 dtmf-relay sip-notify
!
dial-peer voice 3 pots
 description 911
 translation-profile outgoing 9
 destination-pattern 911
 prefix 9
!
dial-peer voice 4 pots
 description 9911
 translation-profile outgoing 9
 destination-pattern 9911
!
dial-peer voice 16 voip
 description Outgoing SIP CUCM
 translation-profile outgoing 9628
 destination-pattern [+628,908]........T
 session protocol sipv2
 session target ipv4:10.0.10.77
 codec g711ulaw
!
dial-peer voice 10 voip
 answer-address 1001
 voice-class codec 1
!
dial-peer voice 20 voip
 answer-address 1001
 voice-class codec 1
!
dial-peer voice 2 pots
 no digit-strip
!
dial-peer voice 41 voip
 description Incoming SIP CUCM
 destination-pattern 081298998288
 session protocol sipv2
 session target ipv4:10.0.10.77
!
dial-peer voice 1000 voip
 destination-pattern 1...
 session target ipv4:10.0.10.77
!
dial-peer voice 5 pots
 service stcapp
 port 0/0/0
!
dial-peer voice 2021 pots
 service stcapp
 port 0/0/0
num-exp 85258010007 1001
num-exp 14159172008 1001
num-exp 081298998288 2001
sip-ua
 credentials username 08844 password 7 01232617481C561D25 realm sip.sg.didlogic.net
 authentication username 08844 password 7 15222B1F173D7B362C realm sip.sg.didlogic.net
 registrar 1 dns:sip.sg.didlogic.net expires 3600
 sip-server dns:sip.didlogic.net
!
telephony-service
 no auto-reg-ephone
 max-ephones 35
 max-dn 144
 ip source-address 10.0.10.206 port 2000
 max-redirect 5
 timeouts interdigit 5
 cnf-file location flash:
 load 7912 CP7912080004SCCP080108A.sbin
 date-format dd-mm-yy
 max-conferences 8 gain -6
 moh flash:/Wave.au
 multicast moh 239.1.1.1 port 2000 route 10.0.10.1
 web admin system name admin secret 5 $1$JGDo$afA54af/90u3S4gnt0sUPP
 transfer-system full-consult
 transfer-pattern 2...
 create cnf-files version-stamp 7960 Sep 29 2015 13:21:21
ephone-dn  1  dual-line
 number 2001 no-reg both
 label Alabama (x2001)
 name Alabama City
ephone-dn  2  dual-line
 number 2002 no-reg both
 label Boston (x2002)
 name Boston City
ephone-dn  3  dual-line
 number 2003 no-reg both
 label Chicago (x2003)
 name Chicago City
 mobility
 snr +6287809777433 delay 10 timeout 30
ephone-dn  4
 number 888 no-reg both
 name POC-Paging
 paging ip 239.1.1.2 port 2000
ephone-dn  5  dual-line
 number 2004
 label Delaware (x2004)
ephone-dn  6  dual-line
 number 2021
 label Dian (x2021)
 name Dian Sastro
ephone  1
 device-security-mode none
 mac-address 000B.BE3B.9E9C
 username "Alabama" password 1234
 type 7912
 button  1:1
 pin 1234
!
ephone  2
 device-security-mode none
 mac-address 0012.0127.A14A
 username "Boston" password 1234
 paging-dn 4
 type 7912
 button  1:2
 pin 1234
!
ephone  3
 device-security-mode none
 mac-address E0DB.55A9.B3D5
 username "Chicago" password 1234
 paging-dn 4
 type CIPC
 button  1:3
 pin 1234
!
ephone  4
 device-security-mode none
 !MAC address=last 12 digits of Device Name "sh stcapp device voice-port x/y/z"
 mac-address 3C32.CCC6.0000
 max-calls-per-button 2
 username "Dian"
 type anl
 button  1:6
line con 0
line aux 0
line vty 0 4
 privilege level 15
 transport input telnet
 transport output telnet
line vty 5 15
 privilege level 15
 transport input ssh
 transport output ssh
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server 202.162.32.12
end