cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
620
Views
22
Helpful
7
Replies
Alex Deiwor
Beginner

Can't change voice LAN on CME v8.6

Hi,

I have a Cisco 1861 Integrated Services Router using the voice service, with 3 VoIP phones.

At first, I made a  configuration with a LAN voice 172.22.0.0/24, working everything OK.

I'm trying to make a second configuration, with a LAN voice 172.16.0.0/24 using the previous config, but this does not work.

I see how the DHCP service provides the correct IP address to each phone, but when I try to use the phone, is sounds a continous beep.

I attach the configuration config I made. May be I forgot something to execute, but as I told before, If i replace all 172.16.x.x to 172.22.x.x it works. That's driving me crazy.

Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Alex

I´m assum that was working before with IP 172.22.x.x, right?

Anyway try reset the Phones to factory default and do a no create cnf-files and create cnf-files.

Cheers
Bruno Rangel
Please remember to rate helpful responses using the star bellow and identify helpful or correct answers

View solution in original post

7 REPLIES 7
Bruno Rangel
Advocate

Hi Alex

Your question isn´t clear for me, I don´t understand your setup.

Please correct me if i´m wrong, you have a Voice network with IP 172.22.x.x/24 and is trying change that IP range to 172.16.x.x/24 right?

From your config i was unable to find the range 172.16.x.x/24, just found that 172.16.0.0/12. Check both the DHCP and Phone and confirm if the correct mask is assigned to.

If yes try change the command in the telephony-service session source ip source-address 172.16.x.1 port 2000.

I hope this help

Cheers
Bruno Rangel
Please remember to rate helpful responses using the star bellow and identify helpful or correct answers

Hi,

Thank you for your reply. You're right, I'm trying to change the voice range from 172.22.0.0/24 to 172.16.0.0/24. Notice that the voice VLAN has no VRF. The range 172.16.0.0/12 you checked is a data range from one of the clients I have set up one VRF called green (Verde). As i told before, the phones receives the IP trhu DHCP, but can't finish the whole configuration

Well, I modified the config as I think it would be correct, I list the changes (The whole config is attached).

The last option I keep in mind is that may be have to rebuild any configuration that the IP Phones have to download.

Header 1

!

ip dhcp pool VOICE

network 172.16.0.0 255.255.255.0

default-router 172.16.0.1

domain-name Voice.com

option 150 ip 172.16.0.1

!

interface FastEthernet0/0

description Interfaz MANAGEMENT

ip address 1.1.1.1 255.255.255.0 secondary

ip address 1.1.1.250 255.255.255.0

no ip redirects

no ip proxy-arp

load-interval 30

duplex auto

speed auto

!

interface Integrated-Service-Engine0/0

ip unnumbered FastEthernet0/0

shutdown

service-module ip address 1.1.1.254 255.255.255.0

service-module ip default-gateway 1.1.1.250

!

interface FastEthernet0/1/0

description ** VoIP Ext.1**

switchport access vlan 101

switchport voice vlan 75

no ip address

!

interface FastEthernet0/1/1

description ** VoIP Ext.2**

switchport access vlan 101

switchport voice vlan 75

no ip address

!

interface FastEthernet0/1/2

description ** VoIP Ext.3**

switchport access vlan 101

switchport voice vlan 75

no ip address

!

interface Vlan75

description VLAN VOICE

ip address 172.16.0.1 255.255.255.0

no ip redirects

no ip proxy-arp

load-interval 30

!

interface Vlan101

description VLAN DATA

ip vrf forwarding azul

ip address 10.10.10.1 255.255.255.0

no ip redirects

no ip proxy-arp

load-interval 30

!

ip route 1.1.1.254 255.255.255.255 Integrated-Service-Engine0/0

!

dial-peer voice 2 voip

destination-pattern 2...

session protocol sipv2

session target ipv4:1.1.1.254

dtmf-relay sip-notify

codec g711ulaw

no vad

!

!

!

!

ephone-type 1

num-buttons 1

max-presentation 1

!

!

telephony-service

max-ephones 6

max-dn 48

ip source-address 172.16.0.1 port 2000

system message Telefonia

time-zone 2

voicemail 2000

max-conferences 4 gain -6

moh music-on-hold.au

multicast moh 239.10.16.4 port 2000

web admin system name usal secret 5 $1$P9E2$SPpxQxCkMpfupefW7Fl6r.

dn-webedit

transfer-system full-consult

!

!

ephone-dn  1  dual-line

number 1101

name 1101

call-forward busy 2000

call-forward noan 2000 timeout 10

!

!

ephone-dn  2  dual-line

number 1102

name 1102

call-forward busy 2000

call-forward noan 2000 timeout 10

!

!

ephone-dn  3  dual-line

number 1103

name 1103

call-forward busy 2000

call-forward noan 2000 timeout 10

!

!

ephone-dn  14

number 8000....

mwi on

!

!

ephone-dn  15

number 8001....

mwi off

!

!

ephone  1

device-security-mode none

mac-address 001D.70FC.984F

max-calls-per-button 2

type 6911

button  1:1

!

!

!

ephone  2

device-security-mode none

mac-address 001D.70FC.992E

max-calls-per-button 2

type 6911

button  1:2

!

!

!

ephone  3

device-security-mode none

mac-address 001D.70FC.98BC

max-calls-per-button 2

type 6911

button  1:3

!

!

!

ephone  99

device-security-mode none

description "Multicast Music On Hold"

Hi Alex

I´m assum that was working before with IP 172.22.x.x, right?

Anyway try reset the Phones to factory default and do a no create cnf-files and create cnf-files.

Cheers
Bruno Rangel
Please remember to rate helpful responses using the star bellow and identify helpful or correct answers

View solution in original post

Hi,

Yes, the configuration works correcty if set 172.22.x.x as voice VLAN.

I'll try to rebuild the cnf-files, because it's the last thing i have to try.

I'm a little scared about rebuild this. Next monday I have to make a conference with the equipment, and  don't want damage the actual working configuration.

Anyway, tonight i will try that. Thank you Bruno!

Hi,

Problem solved. If I change the LAN range, i've to create the cnf files.

Thats a little bit disturbing, because my objective is to load different configs with the command

copy flash:configNEW.conf startup-config

and now I have to rebuild manually that files.

Edit: I forgot to add the command telephony-serivce > create cnf-files

Well, I had a last question, but i try to google it. sometimes when I create the cnf files, the router shows that message:

Cisco-1861VOZ(config-telephony)#create cnf-files

Creating CNF files

CNF-FILES: Clock is not set or synchronized, retaining old versionStamps

But the clock  is up to date

Cisco-1861VOZ(config-telephony)#do show clock

*00:24:34.795 UTC Wed Oct 10 2012

Cisco-1861VOZ(config-telephony)#

Any ideas?

Thank you!

I reply to myself:

The following message:

CNF-FILES: Clock is not set or synchronized, retaining old versionStamps

Is due to i had no the specific clock configuration entered as configuration terminal mode.

In other words, setting up the clock is not enough, also its needed the following config:

Clock configuration

router# config t

router(config)#clock timezone ESPANA 1 0 (Spain as my country)

router(config)#clock summer-time ESPANA recurring

router(config)#clock calendar-valid

router(config)#telephony-service (Now create the cnf files)

router(config-telephony)#create cnf-files

Creating CNF files

router(config-telephony)# (created with no sync error!! Let's check it out)

router(config-telephony)#do show run | i cnf

create cnf-files version-stamp 7960 Oct 10 2012 00:45:35

router(config-telephony)#

It's done, Bruno, so many thanks for your support!  

Good Job Alex!!!

Thanks for the nice rating

Cheers
Bruno Rangel
Please remember to rate helpful responses using the star bellow and identify helpful or correct answers
Content for Community-Ad

Spotlight Awards 2021