cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
configure & troubleshoot anyconnect
146
Views
5
Helpful
5
Replies
Highlighted
Enthusiast

Cannot change 8945 from SCCP to SIP

I have SCCP894x.9-4-2SR3-1 loaded on my phone and want to change it to SIP894x.9-4-2SR3-1 but I must be missing a step.  I am running CME 12 on a 2911 router.  Before I start with my config, how easy is it to have both SCCP and SIP versions of the same phone model number on a CME config? 

I deleted the tftp stuff for 8945 SCCP files.  The SCCP phones work perfect.  I need to learn SIP which is why I am changing the phones.

!
ip dhcp excluded-address 192.168.101.1 192.168.101.20
ip dhcp excluded-address 192.168.201.1 192.168.201.20
!
ip dhcp pool Users
network 192.168.101.0 255.255.255.0
dns-server 1.1.1.1
default-router 192.168.101.1
option 150 ip 192.168.201.1
lease 0 12
!
ip dhcp pool Voice
network 192.168.201.0 255.255.255.0
dns-server 1.1.1.1
default-router 192.168.201.1
option 150 ip 192.168.201.1
option 66 ip 192.168.201.1
lease 0 12
!

voice service voip
ip address trusted list
ipv4 72.999.999.999
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
redirect ip2ip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
registrar server expires max 1200 min 300
!
voice class codec 1
codec preference 1 g711ulaw
!
voice register global
mode cme
source-address 192.168.201.1 port 5060
max-dn 100
max-pool 20
load 8945 SIP894x.9-4-2SR3-1
authenticate register
tftp-path flash:
create profile sync 0017727297051011
!
voice register dn 10
number 3000
name SIP_Phone
label SIP_Phone_1
!
voice register pool 10
busy-trigger-per-button 2
id mac 7081.0585.B908
type 8945
number 1 10
dtmf-relay sip-notify
username user1 password cisco
codec g711ulaw
!
interface Vlan201
ip address 192.168.201.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
tftp-server flash0:/PhoneFiles/8945SIP/BOOT894x.0-0-2-0.bin.sgn alias BOOT894x.0-0-2-0.bin.sgn
tftp-server flash0:/PhoneFiles/8945SIP/SIP894x.9-4-2SR3-1.loads alias SIP894x.9-4-2SR3-1.loads
tftp-server flash0:/PhoneFiles/8945SIP/SIP894x.9-4-2SR3-1.bin1.sgn alias SIP894x.9-4-2SR3-1.bin1.sgn
tftp-server flash0:/PhoneFiles/8945SIP/SIP894x.9-4-2SR3-1.bin2.sgn alias SIP894x.9-4-2SR3-1.bin2.sgn
tftp-server flash0:/PhoneFiles/8945SIP/SIP894x.9-4-2SR3-1.bin3.sgn alias SIP894x.9-4-2SR3-1.bin3.sgn
tftp-server flash0:/PhoneFiles/8945SIP/SIP894x.9-4-2SR3-1.bin4.sgn alias SIP894x.9-4-2SR3-1.bin4.sgn
tftp-server flash0:/PhoneFiles/8945SIP/SIP894x.9-4-2SR3-1.bin5.sgn alias SIP894x.9-4-2SR3-1.bin5.sgn
tftp-server flash0:/PhoneFiles/8945SIP/SIP894x.9-4-2SR3-1.bin6.sgn alias SIP894x.9-4-2SR3-1.bin6.sgn
tftp-server flash0:/PhoneFiles/8945SIP/SIP894x.9-4-2SR3-1.bin7.sgn alias SIP894x.9-4-2SR3-1.bin7.sgn
tftp-server flash0:/PhoneFiles/8945SIP/SIP894x.9-4-2SR3-1.bin8.sgn alias SIP894x.9-4-2SR3-1.bin8.sgn
tftp-server flash0:/PhoneFiles/8945SIP/SIP894x.9-4-2SR3-1.bin9.sgn alias SIP894x.9-4-2SR3-1.bin9.sgn
tftp-server flash0:/PhoneFiles/8945SIP/SIP894x.9-4-2SR3-1.bin10.sgn alias SIP894x.9-4-2SR3-1.bin10.sgn
tftp-server flash0:/PhoneFiles/8945SIP/SIP894x.9-4-2SR3-1.bin11.sgn alias SIP894x.9-4-2SR3-1.bin11.sgn
!
telephony-service
sdspfarm units 2
sdspfarm tag 1 TDCCONF
sdspfarm tag 2 tdxcode
conference hardware
no auto-reg-ephone
authentication credential user1 cisco
max-ephones 20
max-dn 100
ip source-address 192.168.201.1 port 2000
service phone daysDisplayNotActive 1,7
service phone displayOnTime 08:00
service phone displayOnDuration 12
service phone displayIdleTimeout 00:10
service phone settingsAccess 1
service phone modeOfOperation 1
service phone displaywhebincomingcall 1
service phone webAccess 0
service phone ehookEnable 1
service phone displayOnWhenIncomingCall 1
system message DEMO_CME
url services http://192.168.201.10/voiceview/common/login.do
url authentication http://192.168.201.1/CCMCIP/authenticate.asp
load 7921 CP7921G-1.4.1SR1
load 7935 P00503021900
load 7961 SCCP41.9-2-1S
load 7962 SCCP42.9-2-1S
load 7970 SCCP70.9-2-1S
load 7971 SCCP70.9-2-1S
load 7975 SCCP75.9-4-2SR3-1S
load 7985 cmterm_7985.4-1-7-0
load 8941 cmterm-894x-sccp.9-2-2-0
load 8945 SIP894x.9-4-2SR3-1
!

Router#dir
Directory of flash0:/PhoneFiles/

153 -rw- 13182 Jun 11 2019 20:21:32 +00:00 XMLDefault.cnf.xml
8 drw- 0 May 30 2019 12:26:00 +00:00 7914
10 drw- 0 May 30 2019 12:26:00 +00:00 7915
12 drw- 0 May 30 2019 12:26:04 +00:00 7921
20 drw- 0 May 30 2019 12:26:08 +00:00 7925
30 drw- 0 May 30 2019 12:26:08 +00:00 7960
35 drw- 0 May 30 2019 12:26:12 +00:00 7961
44 drw- 0 May 30 2019 12:26:14 +00:00 7962
53 drw- 0 May 30 2019 12:26:16 +00:00 7965
62 drw- 0 May 30 2019 12:26:20 +00:00 7971
71 drw- 0 May 30 2019 12:26:22 +00:00 7975
79 drw- 0 May 30 2019 12:26:22 +00:00 7985
81 drw- 0 Jun 1 2019 20:23:36 +00:00 8945
139 drw- 0 Jun 11 2019 18:00:46 +00:00 8945SIP

Directory of flash0:/PhoneFiles/8945SIP/

140 -rw- 111552 Jun 11 2019 18:02:12 +00:00 BOOT894x.0-0-2-0.bin.sgn
141 -rw- 3145116 Jun 11 2019 18:03:04 +00:00 SIP894x.9-4-2SR3-1.bin1.sgn
142 -rw- 3145116 Jun 11 2019 18:03:26 +00:00 SIP894x.9-4-2SR3-1.bin2.sgn
143 -rw- 3145116 Jun 11 2019 18:03:52 +00:00 SIP894x.9-4-2SR3-1.bin3.sgn
144 -rw- 3145116 Jun 11 2019 18:04:18 +00:00 SIP894x.9-4-2SR3-1.bin4.sgn
145 -rw- 3145116 Jun 11 2019 18:04:44 +00:00 SIP894x.9-4-2SR3-1.bin5.sgn
146 -rw- 3145116 Jun 11 2019 18:05:08 +00:00 SIP894x.9-4-2SR3-1.bin6.sgn
147 -rw- 3145116 Jun 11 2019 18:07:34 +00:00 SIP894x.9-4-2SR3-1.bin7.sgn
148 -rw- 3145116 Jun 11 2019 18:08:02 +00:00 SIP894x.9-4-2SR3-1.bin8.sgn
149 -rw- 3145116 Jun 11 2019 18:10:04 +00:00 SIP894x.9-4-2SR3-1.bin9.sgn
150 -rw- 3145120 Jun 11 2019 18:11:02 +00:00 SIP894x.9-4-2SR3-1.bin10.sgn
151 -rw- 2453524 Jun 11 2019 18:13:34 +00:00 SIP894x.9-4-2SR3-1.bin11.sgn
152 -rw- 747 Jun 11 2019 18:13:54 +00:00 SIP894x.9-4-2SR3-1.loads

2096955392 bytes total (1831469056 bytes free)

Router#deb tftp events
TFTP Event debugging is on
Router#
Jun 11 22:40:57.640: TFTP: Looking for CTLSEP70810585B908.tlv
Jun 11 22:40:57.676: TFTP: Looking for ITLSEP70810585B908.tlv
Jun 11 22:40:57.720: TFTP: Looking for ITLFile.tlv
Jun 11 22:40:57.888: TFTP: Looking for SEP70810585B908.cnf.xml
Jun 11 22:40:57.920: TFTP: Looking for XMLDefault.cnf.xml
Jun 11 22:40:57.920: TFTP: Opened system:/its/vrf1/XMLDefault.cnf.xml, fd 10, size 3687 for process 165
Jun 11 22:40:57.936: TFTP: Finished system:/its/vrf1/XMLDefault.cnf.xml, time 00:00:00 for process 165

Everyone's tags (3)
5 REPLIES 5
Rising star

Re: Cannot change 8945 from SCCP to SIP

Add the tftp alias commands for SIP Firmware files like you have added for SCCP files.

*** Please rate helpful post; Mark "Accept as a Solution" if applicable

Thanks,
Haris
Enthusiast

Re: Cannot change 8945 from SCCP to SIP

I have them configured, my post above had the wrong copy/paste from my notepad. Still having the problem
Cisco Employee

Re: Cannot change 8945 from SCCP to SIP

1. I have not observed .sgn files for CME loads on phones. For the CME, we download the cmterm-<phonemodel>-<firmwareversion>.zip file from cisco.com. This usually contains 7 to 8 files.

2. The above files have to be copied to the bootflash and set in the tftp-server command.

3. From the logs, it looks like the phone isn't able to get its respective cnf.xml file. Please check if the file is created under the flash:/its/ folder. If the file is missing, please run the create profile command under voice register global again.

4. Under the voice register pool config, it says "number 1 10". Is this a typo? There should be a dn keyword there. 

Enthusiast

Re: Cannot change 8945 from SCCP to SIP

#4 I get this error when I try the way you suggest.

Router(config-register-pool)#number 1 dn 10
Error: number defined in pattern format

Right now I can make calls from the SIP phone to the SCCP phone but not from the SCCP phone to the SIP. I'm investigating.....

Enthusiast

Re: Cannot change 8945 from SCCP to SIP

I found the solution.  First I placed the XMLDefault.cnf.xml in the root directory of the flash (not sure if this was required.  Next I entered the following commands:

configure terminal
voice register global
file text
create profile
end

As soon as I did that, the upgrade process started.  It takes a while for each phone to upgrade.

 

 

CreatePlease to create content