cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
598
Views
0
Helpful
4
Replies
Highlighted
Beginner

CAP bandwidth in addition to QoS... is this efficient?

Hello everyone!

We have a situation in a couple of our locations. They, unfortunately, have a T1 and ONLY a T1 @ 1.5Mbps ... inside they have about 10 phones...

whenever someone has a need to download a considerable sized file from the web or simply when ALL of them decide to do certain things at the same time, they eat up the 1.5 and then they start experiencing delays and issues with the calls.

Out QoS is configured like this:

 

class-map match-any call_signaling
 match ip dscp af31
class-map match-any voice_media
 match ip dscp ef
!
!
policy-map voip
 class voice_media
  priority percent 70
 class call_signaling
  bandwidth remaining percent 5
 class class-default
  priority percent 30
 

then the "voip" policy map is applied to the s0/0/0:0 interface which is their only means of communication. Phones are on VLAN 100 and computers on VLAN 1 native...

I was thinking that if I CAP the bandwidth for VLAN 1 to 1.25 Mbps, that would leave the rest for VLAN100 to use and not experience delays...

Is this viable? ... I don't know enough so I am asking is this the right way to do it... would it be better to modify QoS? would a combination insure neat non delayed calls every time?

Thank you for your help!!

Regards,

Mario

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

First change your LLQ policy map to:

class-map match-any call_signaling
 match ip dscp af31

match ip dscp cs3

 

​How is the uplink port to the router on the switch configured?

View solution in original post

4 REPLIES 4
Highlighted
Hall of Fame Master

QoS is meat to help in situations like this, sounds like your QoS policy is not working as expected.

Glancing at your config you are matching signaling on af31, most Cisco phones use CS3 so you should add that to your class.

How is your LAN policy configured?

Do you see packets matching when you issue "sh policy-map interface serial0/0/0"? 

Highlighted

Thank you Chris for the response! ... Here is the output... yes we see matching packets and we really don't have a LAN policy, which I think is part of the problem (see all of this was done when I was hired) ... I am trying to adapt and change accordingly.. Below see a section of our switch and how it is configured as of now... again, THANKS!

 

Serial0/0/0:0

  Service-policy output: voip

    queue stats for all priority classes:

      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 3004636/526541932

    Class-map: voice_media (match-any)
      1677943 packets, 256493034 bytes
      30 second offered rate 200000 bps, drop rate 0 bps
      Match: ip dscp ef (46)
        1677943 packets, 256493034 bytes
        30 second rate 200000 bps
      Priority: 70% (1050 kbps), burst bytes 26250, b/w exceed drops: 0


    Class-map: call_signaling (match-any)
      92625 packets, 4911112 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: ip dscp af31 (26)
        92625 packets, 4911112 bytes
        30 second rate 0 bps
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 92625/4912136
      bandwidth remaining 5% (0 kbps)

    Class-map: class-default (match-any)
      1310159 packets, 255876552 bytes
      30 second offered rate 70000 bps, drop rate 0 bps
      Match: any
      Priority: 30% (450 kbps), burst bytes 11250, b/w exceed drops: 6413
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

auto qos srnd4
!
!
!
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0
 no ip address
 shutdown
!
interface GigabitEthernet1/0/1
 description Asha Kaul
 switchport voice vlan 100
 load-interval 30
 mls qos trust dscp
 storm-control broadcast level pps 80
 storm-control action shutdown
 spanning-tree portfast

Highlighted

First change your LLQ policy map to:

class-map match-any call_signaling
 match ip dscp af31

match ip dscp cs3

 

​How is the uplink port to the router on the switch configured?

View solution in original post

Highlighted

I did and also noticed different "ip precedence" values on the dial peers... so I also added cs1 , 2 and 3 ... and I am getting matching packets as well...

This is the port to the router from the switch:

interface GigabitEthernet1/0/24
 description 2901 Router
 switchport mode trunk
 switchport voice vlan 100
 mls qos trust dscp
 storm-control broadcast level pps 300
 spanning-tree portfast trunk
 

Thanks!

Content for Community-Ad