Showing results for 
Search instead for 
Did you mean: 

CCM 5.1 Backup



I am trying to get the backup working from CCM 5.1.2.

I have a server running an SFTP server and I have confirmed I can send files to this server via an SFTP client.

I have configured the Callmanager and it accepts the Server Name, IP Address, Path etc, so that side looks ok.

When I perform a manual backup the CCM creates the TAR file locally, however the copy to the SFTP server just sits at 0%.

I can see the Callmanager constantly logging into the SFTP server and I can see the password etc is all ok. However the backup never actually completes and just loops around.

I have attached the output of the logs from the CCM.

Anyone else seen this issue? Any ideas?



7 Replies 7


What SFTP server are you using ? Can you try using Freeftpd. Use anonymous login first to see if it works. With anonymous login, it doesnt matter, what password you use. As long as the username is correct, it should work. Once this works, you can go ahead and setup a proper username and password in freeftpd (can even use active directory accounts).



PS: please remember to rate posts!

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

Thanks for the post Sankar.

Just before I left this evening I downgraded to 5.1.1 and tried the backup, it worked. So it looks like an issue with 5.1.2.




I am having the same problem with a 5.1.2 installation. The logs of the freeFTPd application are a repetition of the following lines. Shutting down the sftp server does not stop the connection attempts from the Call Manager server, they just get denied.

06-04-2007 15:06:35 IP x.x.x.x SFTP connection attempt

06-04-2007 15:06:36 IP x.x.x.x SFTP TestUser access denied

06-04-2007 15:06:37 IP x.x.x.x SFTP TestUser connected

06-04-2007 15:06:37 IP x.x.x.x SFTP TestUser is changing dir to / (c:\temp\)

06-04-2007 15:06:37 IP x.x.x.x SFTP TestUser is changing dir to /tmp (c:\temp\tmp\)

06-04-2007 15:06:37 IP x.x.x.x SFTP TestUser is listing /tmp (c:\temp\tmp\)

06-04-2007 15:06:37 IP x.x.x.x SFTP TestUser is listing /tmp (c:\temp\tmp\)

06-04-2007 15:06:37 IP x.x.x.x SFTP TestUser is listing /tmp (c:\temp\tmp\2007-06-04-10-56-01*.tar)

06-04-2007 15:06:37 IP x.x.x.x SFTP TestUser disconnected

When attempting to stop the transfer from the CLI, it responds the transfer is in progress and cannot be stopped. I am now assuming the only way to kill this process is to reboot the server.


Just to confirm after I downgraded to 5.1.1 and completed a successful backup, I then switched versions to 5.1.2 and tried a backup, this time the backup was successful! So you might want to try switching versions, and then trying a backup in the previous version. I found the only way to get around the server not letting you cancel was to ssh into the box and then force a reboot from there.

Rising star
Rising star

Hi Glen,

We had exactly the same issue and there is a bug open for that:

CSCsj12178 "DRS backup fails to transfer tar files to the sftp server"

-> Open a TAC case and the TAC engineer can change some files on your system and it will work afterward.


Brian Houston

Its worth mentioning that once your server gets stuck in a loop of attempting to copy the TAR files, you can stopp the loop by restarting the DRF service on the Publisher. It doesn't solve the backup problem but does mean that you don't have to reboot the server.

I've had the same issue and now that I know there is a bug I am awaiting the workaround from TAC.



I hit this same problem with a couple of different 5.1.2 installations over the past few weeks. It only seems to effect callmanagers with the following patch loaded cisco-ipt-k9-patch5.1.2.1000-11.tar.gz.gz

We logged a TAC case and got hold of an Engineering Special version 5_1_2_1102-2.

This ES has solved the problem.


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers