Showing results for 
Search instead for 
Did you mean: 

CIPC TFTP Settings change


Anyone know if it's possible to do a mass change of the tftp settings in CIPC 7.x. Need to move a group of 100 users to a new TFTP settings, and dont want to manually have to ask for users to change inside the client.

William Bell


CIPC does support DHCP Option 150 on the network. Of course, that won't help you if you have manually assigned the TFTP servers when you deployed the software. Most people I have worked with use the static TFTP server assignment because, well, CIPC is mobile and isn't necessarily using corporate DHCP servers.

I am guessing you are part of the majority here. So, I think your best route is to look at the option of using a script of some type that is ran local on the user's PC and can edit the registry. The TFTP server information is stored in the registry (HKLM\SOFTWARE\Cisco Systems, Inc.\Communicator). The parameters of interest are TFTPServer1 and TFTPServer2.

The mechanics of this approach would depend on how your systems folks manage software distribution and maintenance for desktop and laptop users. Particularly if your CIPC users are part of your mobile workforce. There are a wide variety of paths here.




HTH -Bill (b) (t) @ucguerrilla

Please remember to rate helpful responses and identify

Thanks Bill. Appreciate your great response.

The TFTPServer settings are in hex in regedit..did you find any quick tool to do the conversion?

I did neglect to mention that part. Sorry.

Here is a URL that has a java tool that can do the conversion (at least part of it):

It is also worth noting that when storing the value in the registry, the "bytes" are stored in reverse order.

So, let's say you have an IP address of : as your TFTP server

If you convert that to hex it is: 0a78a811 (or, for clarification purposes, 0a.78.a8.11)

But you have to reverse the byte order before saving it to the registry: 11a8780a

In the URL above, paste your current registry value in the appropriate section and you will see what I mean.




HTH -Bill (b) (t) @ucguerrilla

Please remember to rate helpful responses and identify

Brian Meade
Rising star

Just wanted to add to this thread as I've been battling issues with this.  The new TFTPServer1/2 location for 64-bit machines is here- 

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Cisco Systems, Inc.\Communicator\


It's also under HKCU but HKLM takes precedence.


Hopefully this helps someone else going down this path.

Thanks for this response. I ran into this same issue.


I don't suppose you also stumbled on the specific registry entry to force an erasure of the CTL/ITL?


I'm administering 6 clusters and use CIPC frequently to register to a specific site and test user facing features and want to script something to make it easier to switch between servers / sites.

Looks like that's stored as a file in AppData\Roaming\Cisco\Communicator\sec

Yeah I'd tried clearing that out already, but it didn't seem to force a new ctl download though. I guess when I have time I'll try shift through process monitor output to see if I can find what triggers it.

By the way it was indeed that folder - but because I had launched IP Communicator with my local admin account I was looking at the wrong %appdata%  userprofile (i.e. my normal user instead of the admin user).


The following seems to work manually, just need to script something now:

  • Modify HKLM\SOFTWARE\WOW6432Node\Cisco Systems, Inc.\Communicator\TftpServer1 & TftpServer2 with hex representation of desired cluster TFTP servers
  • Delete C:\Users\username\AppData\Roaming\Cisco\Communicator\sec folder
  • Restart IP Communicator (I'll probably just do a task kill and start it up again in the script)

Then will be able to easily Launch IP Communicator to a specific cluster without having to manually update the address in Preferences.

Recognize Your Peers
Content for Community-Ad