cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
2248
Views
5
Helpful
18
Replies

Cisco 3905 problem / remote site

Hi all!

Information:

I have CUCM 8.6.2.20000-2 and many Cisco IP Phone 3905 (SIP). Some of them deployed in central office and some in remote sites.

Phone information:

Boot Version: 3905.0-0-0-01-01

DSP Version: 12.0.0.8

Application: 3905.9-2-2-0

Symptoms:

In remote sites only!

The phone is registered and working fine. However, after few hours idle state I lift the handset, dial any number and nothing happens. Drop the call and try again 2-3 times. After that either call passed or get permanent busy tone (need to reboot the phone to work again).

The phone is marked as registered on CUCM and I hear dial tone when lifted the handset.

I cannot collect debug messages from phones, because as soon as I login via telnet it going work fine.

There is no such problem in central office.

Phones print following messages in terminal all the time:

17:07:10:302 x [CENTRAL] CDP/LLDP-MED CB function is called

17:07:26:491   [sip]  03:58:24.490    pjsua_acc.c  SIP outbound status for acc 0 is not active

17:07:26:495   [sip]  03:58:24.494    pjsua_acc.c  "п°п╦я┘п╟п╦п╩ п я┐пЇя▄п╪п╦пҐ"<sip:7102@192.168.13.50:5060>: registration success, status=200 (OK              ), will re-register in 120 seconds

17:07:26:502   [sip]  03:58:24.500         pjcu.c  pjcu_on_reg_state2(), Account["п°п╦я┘п╟п╦п╩ п я┐пЇя▄п╪п╦пҐ"<sip:7102@192.168.13.50:5060>] : OK,               status=200

17:07:26:506 x [pcu] pcuRcvHandler(CALL), SRV_EV, eid=0, cid=65535,

17:07:26:510 x [pcu] [pcux_insrv_cb():7071] CUCM_DateTime:Mon, 27 May 2013 11:07:26 GMT

17:07:26:511 x [pcu] Sync time from server: Mon, 27 May 2013 11:07:26 GMT

17:07:26:515 x [pcu] [set_svr_type][1599] Bfe active_server_idx=0, serverType=0

17:07:26:515 x [pcu] [set_svr_type][1602] Aft  serverType=0, Server Number=2

17:07:26:531   [ipps] ----- PCU: CC_SRV, pid=0, eid=0, cid=65535 -----

17:07:26:532   [ipps] In func: remoteNtyEvtProcess(), lib = 0, cid = 65535, ntyEv = 0

17:07:26:533 f [ipps] In func: remoteNtyEvtProcess(), recv inservice nty, svrType = 0, cause = 0

17:07:26:534 f [MMI] <RCV>: In func: ui_nty(), lid = 0, cid = 65535, ntyEv = 0

17:07:26:535 x [CENTRAL] IPPS CB function(RegStatus) is called (1) with Line (0)

17:07:26:536 f [ipps] In func: mlcu_isKpmlEnabled(), KPML value = 3, blRet = 1

17:07:26:537 x [CENTRAL] Enter FSM: State(STANDBY) | Event(REGISTER_OK) | Cause(0)

17:07:26:540 x [CENTRAL] Unexpected event REGISTER_OK (cause=0) at STANDBY state

17:07:26:541 x [CENTRAL] Waiting event in STANDBY

17:07:58:990 x [CENTRAL] CDP/LLDP-MED CB function is called

17:08:39:022   [sip]  03:59:37.021         pjcu.c  pjcuRcvHandler(KA), KA_REQUEST, eid=-1, p1=192.168.70.1:5060

17:08:39:040   [sip]  03:59:37.036         pjcu.c  pjcu_rpt_ka_status(), target(192.168.70.1:5060): status=1, id=27

17:08:39:044 x [pcu] pcuRcvHandler(KA), KA_RESPONSE, eid=0, addr=192.168.70.1:5060, status=1

17:08:39:050 x [pcu] [pcu_polling_sipserver_thread():1478] mark!

17:08:54:130 x [CENTRAL] CDP/LLDP-MED CB function is called

Thanks for your help.

1 ACCEPTED SOLUTION

Accepted Solutions

Please try to upgrade to the latest available firmware, 9.4(1), and try again.

HTH

--
Jorge Armijo

Please remember to rate helpful responses and identify helpful or correct answers.

-- Jorge Armijo Please remember to rate helpful responses and identify helpful or correct answers.

View solution in original post

18 REPLIES 18
Leo Salcie Tejeda
Rising star

Hi Anton,

Have you try upgrading the phone firmware?

Please remember to rate useful posts clicking on the stars below.
Favor calificar todos las respuestas útiles dando click en las estrellas de mas abajo.
___________________________________________
LinkedIn Profile: do.linkedin.com/in/leosalcie

__________________________________________________
Please remember to rate useful posts clicking on the stars below.
LinkedIn Profile: do.linkedin.com/in/leosalcie

Hi!

Upgraded to the latest firmware.

Application: 3905.9-2-2-0

Have you try running a softphone (CIPC) instead of 3905? Try this to see if the problem is the phone or CME.

Please remember to rate useful posts clicking on the stars below.
Favor calificar todos las respuestas útiles dando click en las estrellas de mas abajo.
___________________________________________
LinkedIn Profile: do.linkedin.com/in/leosalcie

__________________________________________________
Please remember to rate useful posts clicking on the stars below.
LinkedIn Profile: do.linkedin.com/in/leosalcie

I have tried Cisco IP Communicator and other models of cisco ip phones (like 7911 and 7945). They are working perfectly well. Also, there is no problem with third-party SIP devices, tested CSipSimple softphone on android. The problem is only with 3905 phones.

Try Downgrating the phone to another firmware version.

Please remember to rate useful posts clicking on the stars below.
Favor calificar todos las respuestas útiles dando click en las estrellas de mas abajo.
___________________________________________
LinkedIn Profile: do.linkedin.com/in/leosalcie

__________________________________________________
Please remember to rate useful posts clicking on the stars below.
LinkedIn Profile: do.linkedin.com/in/leosalcie

There are 2 versions of firmware on cisco.com. cmterm-3905.9-2-1-0 is the default firmware going with CUCM 8.6.2.20000-2 for 3905 phones and cmterm-3905.9-2-2-0 I've installed recently. Both versions of firmware with same problems.

       Some new information. I get traffic dump with wireshark.

INVITE sip:7@192.168.13.50:5060;transport=tcp SIP/2.0

Via: SIP/2.0/TCP 192.168.70.86:3457;rport;branch=z9hG4bKPjdp3HjFLs7Dy03RL9ce.16qung.tOq5O3

Max-Forwards: 70

From: "............ .............." <7102>;tag=5a25b465-747b-4c31-a020-1a9636827427

To: sip:7@192.168.13.50

Contact: <42C2685B-4526-F89D-C009-8B283FCF69A5>;+sip.instance="";+u.sip!devicename.ccm.cisco.com="SEP10BD18DD3F59";+u.sip!model.ccm.cisco.com="592"

Call-ID: e9edcc43-6a9b-42b8-8efc-99f702b313d1

CSeq: 28324 INVITE

Allow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, SUBSCRIBE, NOTIFY, REFER, MESSAGE, OPTIONS

User-Agent: Cisco-CP3905/9.2.1

Supported: replaces,join,sdp-anat,norefersub,extended-refer,X-cisco-callinfo,X-cisco-serviceuri,X-cisco-escapecodes,X-cisco-service-control,X-cisco-monrec,X-cisco-config,X-cisco-sis-4.0.0,X-cisco-xsi-7.0.1

Expires: 900

Accept: application/sdp

Allow-Events: kpml,dialog

Remote-Party-ID: "............ .............."<7102>;privacy=off

Content-Type: application/sdp

Content-Length:   294

As you can see phone trying to invite 7@192.168.13.50:5060, BUT I dial 7103 DN from 7102. So where are other numbers? Bug?

Hi Anton Proskuryakov,

Have you found a solution for this problem or not?

I have same problem here. 3905.9-2-2T14 is the 3905 version and

8.6.2.22900-9 is the CUCM version.

I haven't found a solution yet.

what about cucm patches? or tac case?

Hi, i have the same problem. Did you find  a soluction to fix it? 

Regards

what is your cucm version?

hi, i've just opened a tac case. I'll tell you if i find a fix.

Full CUCM version: 8.6.2.23900-10

Number of servers on your cluster: 3

Firmware on the affected phone: 9.2.2.ES6

Regards

Hi, f.rowan

Did you find a solution for this bug?

I have the same problem on CUCME 10.0 and 9.1 versions. I tried all phone firmware versions, but unsuccessfully.

I will be very grateful if you write the fix. Thanks in advance.


Content for Community-Ad

Spotlight Awards 2021