cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

659
Views
5
Helpful
6
Replies
Highlighted
Beginner

Cisco 7911 SIP registration problem

Hello! I have a some problems with sip phone registration. Our topology: Cisco 7911 SIP ----- Internet ---- Public SIP server. I analyzed traffic with Wireshark. Cisco phone send SIP Register, then Public SIP server response with SIP 401 Unauthortized with WWW-Authenticate. But my cisco phone do not send SIP Register with WWW-Authenticate again. Why ? I attached config file of cisco phone. Please, help me!

6 REPLIES 6
Beginner

Re: Cisco 7911 SIP registration problem

Hi nurhat19921 and community,

You have not received a reply and that is frustrating. I am having the same problem with a SIP provider called DirectCall. I configure the 7911 as I have done hundreds of time with other phones but I cannot seem to register for the life of me. My Polycom phone and Linksys ATA register almost immediately after I click on the SAVE button but the Cisco phone does not. I just get REGISTERING for ever and then it gives up.

In the logs, I found registration errors:

9006: ERR 06:41:17.884833 NTP: Wed Dec 16 11:41:17 2009
9007: ERR 06:41:39.520715 JVM: %REG auth failed: ack timer
9008: ERR 06:42:07.524355 JVM: %REG send failure: REGISTER
9009: ERR 06:42:11.541351 JVM: %REG auth failed: ack timer
9010: ERR 06:42:43.520728 JVM: %REG auth failed: ack timer

 

My SEP file seems correct, I have tried dozens os examples of ppl who claimed to make it register. I have the right login information. I am using firmware SIP11.8-5-4S which is notorious for working with most devices.

 

Anyone out there know what the heck is going on with this device? Other models work but this 7911 has frustrated me for a while.

 

I appreciate any help

VIP Advisor

Re: Cisco 7911 SIP registration problem

Can you get a 3rd party softclient to register with these creds?

 

In all honestly get onto your provider and ask the why they are sending you the UNauthorised message.  The phone is sending something they are not liking, they should be able to tell you what

Please remember to rate useful posts, by clicking on the stars below.

Beginner

Re: Cisco 7911 SIP registration problem

Hi Dennis,

Thank you for your reply. I can register successfully with Zoiper. It detects SIP UDP service and registers successfully. Polycom IP550 phone also registers immediately as well as a Cisco SPA2102 ATA. It is something that the Cisco phone is sending that is being refused.

I will try their support tomorrow, but it also occurred to me now that I do have a test Asterisk server I could try registering to, so I tried putting an extension in there to try to test the phone. It also does not register. I tried setting NAT=NO on the extension as that has worked before. I also tried putting USECALLMANAGER in the <PROXY> entry for LINE 1 but nothing worked.

 

I looked in the Asterisk logs for a registration to extension 5002 that I created but all I see in the logs are there entries:

[2018-03-26 01:56:08] SECURITY[26868] res_security_log.c: SecurityEvent="ChallengeSent",EventTV="2018-03-26T01:56:08.277-0300",Severity="Informational",Service="SIP",EventVersion="1",AccountID="5002",SessionID="0x7f2f6cd72300",LocalAddress="IPV4/UDP/52.xx.xxx.184/5060",RemoteAddress="IPV4/UDP/177.xxx.xxx.44/5060",Challenge="685a0df1"

 

(I removed the IP address for security purposes). It seems a challenge is being sent to the device and maybe the device does not know what to do with that?

 

Regards

Beginner

Re: Cisco 7911 SIP registration problem

Could this be a firmware version issue like I had with other models? It might be the SEP file that I am using that might be for a different firmware version. I am going to start over. I will download the latest version of the firmware and try to find a sample SEP file for that version and try again.

I am totally frustrated with this problem.
Beginner

Re: Cisco 7911 SIP registration problem

Hi everyone,

 

Still stuck with this problem. None of the 7911 register. I was able to register 6921 and 6941 successfully on the same server. But the 7911does not register and in the logs, I keep seeing the 

%REG send failure: REGISTER

error message. Anyone able to register 7911 on an Asterisk server? If so please help. I have several 7911 devices that are very nice paperweights for now.

 

Thank you.

Beginner

Re: Cisco 7911 SIP registration problem

A quick update on this issue, it seems the problem is the device is sending the timestamp in the registration and since it does not update the date/time from the NTP server, it is sending a date in 2008 and the server is refusing due to that. Not sure how to solve it yet, tried firmware upgrade and all, but the date/time does not update from the NTP server.
CreatePlease to create content
Content for Community-Ad
FusionCharts will render here