cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
6753
Views
5
Helpful
22
Replies
Highlighted
Enthusiast

Cisco 7962 Corporate Directory - not working says to Contact Administrator

I recently bought 350 Cisco 7962s for UCM 7.X of those 350 about 100 of them I cannot access our corporate directory. I get an error saying to contact the administrator.

I have tried to do the factory reset; there are no Config differences between the phones that work and the phones that do not work, Same Firmware, Same Subnet, and same UCM Config, I know this for sure as I used the same bulk template for them all.

Just wanted to see if anyone else has seen this, our next step is to update the firmware but I did not want to do firmware updates during our busy season in case that causing any other issuers.

Thanks,


Ed

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi,

Not sure if this bug has something to do with your issue

CSCte05181 Bug Details
Blank Page if corporate directories is pressed during requesting mode
Symptom:

On the CM 7, users press the directories button, the personal and corporate directories are available while "requesting" is displayed. If the users press either 4 or 5 to get one of these options while the "requesting" shows on the screen, they get a blank page that does not away.


Conditions:

none.

Workaround:

none.
StatusStatus
Fixed
(Verified)
Severity Severity
3 - moderate

Last Modified Last Modified
In Last Year

Product Product
Cisco Unified IP Phone 7900 Series

Technology Technology


1st Found-In 1st Found-in
8.4(2)

Fixed-In Fixed-in
9.0(3)MN1.10

Component(s) Component
sw-phone-jphone

Regression Regression
Y

Regards

Alex

Please rate useful posts

Regards, Alex. Please rate useful posts.

View solution in original post

22 REPLIES 22
Highlighted
Rising star

Is that when you press the Directories button or when you try to select Corporate Directory

Graham

Highlighted

Only after pressing the Corporate Directory. At first I was thinking LDAP issue, but I have nearly 1000 other phones that do not have an issue and a little under 200 7962s that are okay.

Highlighted

Strange

The only thing I can suggest is make sure the "Span to PC port" is on for the phone. Load Wireshark onto the PC plugged into the back of the phone and capture the network traffic between the Phone and CUCM.

Whatever URL the phone is accessing you should be able to put into IE and see the XML results back from CUCM

Graham

Highlighted

Hi,

Can you look at the phone settings ---> Device config ---> HTTP Config

What does the Directies URL show ?

Regards

Alex

Regards, Alex. Please rate useful posts.
Highlighted

it is the same on all phones, working and non working

Http://10.8.224.21:8080/ccmcip/xmldirectory.jsp

the IP is the IP of our PUB.

I can get to this address from the PC that the phone is connected to and from any other PC...

this is what I get... so that appears to be working.

 

-

  Select a directory

 

Highlighted

Hi,

Well at least that proves it does NOT look like a DNS problem.

Are all the phones that dont work in the same vlan/subnet, I know you said that you

can reach the URL from a PC in the back of

the phone but that will probably be on your DATA subnet/vlan not the VOIP vlan.

Regards

Alex

Regards, Alex. Please rate useful posts.
Highlighted

On the subnet, there is a mix of phones that work and do not work, the strage thing here is I can pull the 7962 out and put in a 7960 or 7940 and it works. I am only seeing this on a handful of Cisco 7962s.

Highlighted

Hi,

Could you try to factory reset ONE 7962 phone

Step 1 Unplug the power cable from the phone and then plug it back in.

The phone begins its power up cycle.

Step 2 While the phone is powering up, and before the Speaker button flashes on and off,

press and hold #.

Continue to hold # until each line button flashes on and off in sequence in amber.

Step 3 Release # and press 123456789*0#.

You can press a key twice in a row, but if you press the keys out of sequence, the factory reset will not take place.

After you press these keys, the line buttons on the phone flash red and the phone goes through the factory reset process.

Do not power down the phone until it completes the factory reset process and the main screen appears.


Regards

Alex

Regards, Alex. Please rate useful posts.
Highlighted

Good thought, but ... still the same.

its very strange, I am hoping a firmware update will do it but I have my doubts.

Highlighted

Hi,

Not sure if this bug has something to do with your issue

CSCte05181 Bug Details
Blank Page if corporate directories is pressed during requesting mode
Symptom:

On the CM 7, users press the directories button, the personal and corporate directories are available while "requesting" is displayed. If the users press either 4 or 5 to get one of these options while the "requesting" shows on the screen, they get a blank page that does not away.


Conditions:

none.

Workaround:

none.
StatusStatus
Fixed
(Verified)
Severity Severity
3 - moderate

Last Modified Last Modified
In Last Year

Product Product
Cisco Unified IP Phone 7900 Series

Technology Technology


1st Found-In 1st Found-in
8.4(2)

Fixed-In Fixed-in
9.0(3)MN1.10

Component(s) Component
sw-phone-jphone

Regression Regression
Y

Regards

Alex

Please rate useful posts

Regards, Alex. Please rate useful posts.

View solution in original post

Highlighted

This does look similar, I will investigate. Thank you so much for all your help so far!

Highlighted

Alex thank you so much this looks like it is the issue. I have the firmware, I will get this updated.


Graham thanks for your help too!

Highlighted

Upgraded to the latest Firware Version 9.2(3)

Still NO Corporate Directory... really strange

That bug really looked similar so I guess I just jumpped the gun or just wishful thinking.

I am going to open a TAC on this one and I will update this string when it is fixed.

Highlighted

If you want to collect a Wireshark trace and post it I will have a look at it.

Graham

Content for Community-Ad